Highlighted

SAML Issues After Authentciation

New Here ,
May 21, 2018

Copy link to clipboard

Copied

After Setting up a SAML SP Initiated workflow for my IdP on the Adobe Sign Platform, I am facing issues Post Authentication. I am unable to reach the home page after login and get this error message:

I have followed these guides to troubleshoot my issue Enabling Single Sign-On with SAML and How to perform a SAML Trace. ​I am able to generate a successful SAML response, but it seems that there is another issue post authentication. I have attached my SAML Trace below and it seems to have the right information.

<samlp:Response ID="_ec3cc053-4e9c-40a8-8eee-d379a548bb37" InResponseTo="_62115fc7-9957-4abb-a9da-1e251f3c6e33" Version="2.0" IssueInstant="2018-05-21T22:46:15.93Z" Destination="https://anthony1.na2.echosign.com/public/samlConsume?" xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol" > <saml:Issuer xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion">https://snaosaspidp09.saint.sacustom.local/SecureAuth44</saml:Issuer> <samlp:Status> <samlp:StatusCode Value="urn:oasis:names:tc:SAML:2.0:status:Success" /> </samlp:Status> <saml:Assertion Version="2.0" ID="_6d458e4f-78e0-4cf5-bb8d-f8d0beaf27d3" IssueInstant="2018-05-21T22:46:15.931Z" xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion" > <saml:Issuer>https://snaosaspidp09.saint.sacustom.local/SecureAuth44</saml:Issuer> <saml:Subject> <saml:NameID Format="urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress">aolivar@secureauth.com</saml:NameID> <saml:SubjectConfirmation Method="urn:oasis:names:tc:SAML:2.0:cm:bearer"> <saml:SubjectConfirmationData NotOnOrAfter="2018-05-21T23:46:15.936Z" Recipient="https://anthony1.na2.echosign.com/public/samlConsume?" InResponseTo="_62115fc7-9957-4abb-a9da-1e251f3c6e33" /> </saml:SubjectConfirmation> </saml:Subject> <saml:Conditions NotBefore="2018-05-21T22:46:15.936Z" NotOnOrAfter="2018-05-21T23:46:15.936Z" > <saml:AudienceRestriction> <saml:Audience>http://echosign.com</saml:Audience> </saml:AudienceRestriction> </saml:Conditions> <saml:AuthnStatement AuthnInstant="2018-05-21T22:46:15.936Z" SessionIndex="_62115fc7-9957-4abb-a9da-1e251f3c6e33" > <saml:AuthnContext> <saml:AuthnContextClassRef>urn:oasis:names:tc:SAML:2.0:ac:classes:unspecified</saml:AuthnContextClassRef> </saml:AuthnContext> </saml:AuthnStatement> <saml:AttributeStatement> <saml:Attribute Name="Email" NameFormat="urn:oasis:names:tc:SAML:2.0:attrname-format:basic" > <saml:AttributeValue>aolivar@secureauth.com</saml:AttributeValue> </saml:Attribute> <saml:Attribute Name="FirstName" NameFormat="urn:oasis:names:tc:SAML:2.0:attrname-format:basic" > <saml:AttributeValue>Anthony</saml:AttributeValue> </saml:Attribute> <saml:Attribute Name="LastName" NameFormat="urn:oasis:names:tc:SAML:2.0:attrname-format:basic" > <saml:AttributeValue>Olivar</saml:AttributeValue> </saml:Attribute> </saml:AttributeStatement> </saml:Assertion> </samlp:Response>

Views

182

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

SAML Issues After Authentciation

New Here ,
May 21, 2018

Copy link to clipboard

Copied

After Setting up a SAML SP Initiated workflow for my IdP on the Adobe Sign Platform, I am facing issues Post Authentication. I am unable to reach the home page after login and get this error message:

I have followed these guides to troubleshoot my issue Enabling Single Sign-On with SAML and How to perform a SAML Trace. ​I am able to generate a successful SAML response, but it seems that there is another issue post authentication. I have attached my SAML Trace below and it seems to have the right information.

<samlp:Response ID="_ec3cc053-4e9c-40a8-8eee-d379a548bb37" InResponseTo="_62115fc7-9957-4abb-a9da-1e251f3c6e33" Version="2.0" IssueInstant="2018-05-21T22:46:15.93Z" Destination="https://anthony1.na2.echosign.com/public/samlConsume?" xmlns:samlp="urn:oasis:names:tc:SAML:2.0:protocol" > <saml:Issuer xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion">https://snaosaspidp09.saint.sacustom.local/SecureAuth44</saml:Issuer> <samlp:Status> <samlp:StatusCode Value="urn:oasis:names:tc:SAML:2.0:status:Success" /> </samlp:Status> <saml:Assertion Version="2.0" ID="_6d458e4f-78e0-4cf5-bb8d-f8d0beaf27d3" IssueInstant="2018-05-21T22:46:15.931Z" xmlns:saml="urn:oasis:names:tc:SAML:2.0:assertion" > <saml:Issuer>https://snaosaspidp09.saint.sacustom.local/SecureAuth44</saml:Issuer> <saml:Subject> <saml:NameID Format="urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress">aolivar@secureauth.com</saml:NameID> <saml:SubjectConfirmation Method="urn:oasis:names:tc:SAML:2.0:cm:bearer"> <saml:SubjectConfirmationData NotOnOrAfter="2018-05-21T23:46:15.936Z" Recipient="https://anthony1.na2.echosign.com/public/samlConsume?" InResponseTo="_62115fc7-9957-4abb-a9da-1e251f3c6e33" /> </saml:SubjectConfirmation> </saml:Subject> <saml:Conditions NotBefore="2018-05-21T22:46:15.936Z" NotOnOrAfter="2018-05-21T23:46:15.936Z" > <saml:AudienceRestriction> <saml:Audience>http://echosign.com</saml:Audience> </saml:AudienceRestriction> </saml:Conditions> <saml:AuthnStatement AuthnInstant="2018-05-21T22:46:15.936Z" SessionIndex="_62115fc7-9957-4abb-a9da-1e251f3c6e33" > <saml:AuthnContext> <saml:AuthnContextClassRef>urn:oasis:names:tc:SAML:2.0:ac:classes:unspecified</saml:AuthnContextClassRef> </saml:AuthnContext> </saml:AuthnStatement> <saml:AttributeStatement> <saml:Attribute Name="Email" NameFormat="urn:oasis:names:tc:SAML:2.0:attrname-format:basic" > <saml:AttributeValue>aolivar@secureauth.com</saml:AttributeValue> </saml:Attribute> <saml:Attribute Name="FirstName" NameFormat="urn:oasis:names:tc:SAML:2.0:attrname-format:basic" > <saml:AttributeValue>Anthony</saml:AttributeValue> </saml:Attribute> <saml:Attribute Name="LastName" NameFormat="urn:oasis:names:tc:SAML:2.0:attrname-format:basic" > <saml:AttributeValue>Olivar</saml:AttributeValue> </saml:Attribute> </saml:AttributeStatement> </saml:Assertion> </samlp:Response>

Views

183

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 21, 2018 0

Have something to add?

Join the conversation