Highlighted

Workflow API V5 exceptions

New Here ,
Nov 28, 2018

Copy link to clipboard

Copied

I have recently gotten my manager to setup a workflow in Adobe Sign, for a specific document.

We have published the workflow and are able to retrieve the details form the rest API.

https://transperfect.na2.echosign.com/public/docs/restapi/v5#!/workflows/getWorkflowInfo

the response looks to be ok in order to get the workflow to send the agreement:

{

    "name": "5771f473b70b2f6151bf662cd64db2b7",

    "displayName": "Letter",

    "created": "2018-11-27T02:32:12-08:00",

    "modified": "2018-11-27T02:32:12-08:00",

    "status": "ACTIVE",

    "scope": "GROUP",

    "scopeId": "",

    "description": "Please select a person to approve and a person to issue the document to",

    "agreementNameInfo": {

        "required": true,

        "defaultValue": "To customize",

        "editable": true,

        "visible": true

    },

    "messageInfo": {

        "required": true,

        "defaultValue": "To customize",

        "editable": true,

        "visible": true

    },

    "fileInfos": [

        {

            "name": "document1",

            "label": "ToSend",

            "required": false,

            "workflowLibraryDocumentSelectorList": [

                {

                    "workflowLibDoc": "3AAABLblqZhAF87SdfsxcvbEDSAUtEBRKzgXTvqh4EUFj_YmkqAKDSm5w_Tb8HtO5lhaXP4b-JsIXMUc7NaQ9mSV-9JUIo",

                    "label": "Letter"

                }

            ]

        }

    ],

    "recipientsListInfo": [

        {

            "name": "Signer1",

            "label": "Editor",

            "defaultValue": "",

            "minListCount": 1,

            "maxListCount": 1,

            "editable": true,

            "visible": true,

            "allowfax": false,

            "allowSender": true,

            "authenticationMethod": "NONE"

        },

        {

            "name": "signer2",

            "label": "Approver",

            "defaultValue": "${sender.email}",

            "minListCount": 1,

            "maxListCount": 1,

            "editable": true,

            "visible": true,

            "allowfax": false,

            "allowSender": true,

            "authenticationMethod": "NONE"

        },

        {

            "name": "signer1",

            "label": "Receiver",

            "defaultValue": "",

            "minListCount": 1,

            "maxListCount": 1,

            "editable": true,

            "visible": true,

            "allowfax": false,

            "allowSender": true,

            "authenticationMethod": "NONE"

        }

    ],

    "passwordInfo": {

        "required": false,

        "visible": false,

        "defaultValue": ""

    }

}

First Try:
I created a Transient Document (through the API) and retrieved my document Id, when i try to put this into the workflow I receive the error of
400MISC_ERROR: Some miscellaneous error has occurred.

Second Try:

I tried to create the request with just the minimal amount of data (according to the swagger)

{

    "documentCreationInfo": {

        "fileInfos": [

            {

                "name": "document1",

                "workflowLibraryDocumentId": "3AAABLblqZhAF87SdfsxcvbEDSAUtEBRKzgXTvqh4EUFj_YmkqAKDSm5w_Tb8HtO5lhaXP4b-JsIXMUc7NaQ9mSV-9JUIo"

            }

        ],

        "name": "Letter",

        "recipientsListInfo": [

            {

                "name": "Signer1",

                "recipients": [

                    {

                        "email": "sender@email.com"

                    }

                ]

            },

            {

                "name": "signer2",

                "recipients": [

                    {

                        "email": "sender1@email.com"

                    }

                ]

            }

        ]

    }

}

and I now receive the error:

{ "code": "MISSING_REQUIRED_TO_FIELD", "message": "Required ToField tosC is missing" }

As I am using the V5 version of the RestAPI and all the documentation i can find is for the V6 version, does anyone have an idea of what is the potential issues?

I've been banging my head for the last few days trying to get this sorted.

I don't have an Admin account to be able to change the workflow directly,

Hello Colmd,

We're sorry for the trouble you had, I will request you to contact our technical support team over the chat/call so that they can assist you with the custom API workflow.

For the subscribed account, find the below steps to contact support:

• Login to your Adobe Sign account directly via https://secure.echosign.com/public/login

• Once logged in, check the upper right corner of the page and click the question mark icon.

• It will re-direct you to the page where you get the option to create the support case or to start a chat with the team.

• If you've never logged in this way, use the forgot password option on the login link to set your password.

Adobe Sign Support Page

Thanks,

Anand Sri.

Topics

Questions Need Help

Views

244

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Workflow API V5 exceptions

New Here ,
Nov 28, 2018

Copy link to clipboard

Copied

I have recently gotten my manager to setup a workflow in Adobe Sign, for a specific document.

We have published the workflow and are able to retrieve the details form the rest API.

https://transperfect.na2.echosign.com/public/docs/restapi/v5#!/workflows/getWorkflowInfo

the response looks to be ok in order to get the workflow to send the agreement:

{

    "name": "5771f473b70b2f6151bf662cd64db2b7",

    "displayName": "Letter",

    "created": "2018-11-27T02:32:12-08:00",

    "modified": "2018-11-27T02:32:12-08:00",

    "status": "ACTIVE",

    "scope": "GROUP",

    "scopeId": "",

    "description": "Please select a person to approve and a person to issue the document to",

    "agreementNameInfo": {

        "required": true,

        "defaultValue": "To customize",

        "editable": true,

        "visible": true

    },

    "messageInfo": {

        "required": true,

        "defaultValue": "To customize",

        "editable": true,

        "visible": true

    },

    "fileInfos": [

        {

            "name": "document1",

            "label": "ToSend",

            "required": false,

            "workflowLibraryDocumentSelectorList": [

                {

                    "workflowLibDoc": "3AAABLblqZhAF87SdfsxcvbEDSAUtEBRKzgXTvqh4EUFj_YmkqAKDSm5w_Tb8HtO5lhaXP4b-JsIXMUc7NaQ9mSV-9JUIo",

                    "label": "Letter"

                }

            ]

        }

    ],

    "recipientsListInfo": [

        {

            "name": "Signer1",

            "label": "Editor",

            "defaultValue": "",

            "minListCount": 1,

            "maxListCount": 1,

            "editable": true,

            "visible": true,

            "allowfax": false,

            "allowSender": true,

            "authenticationMethod": "NONE"

        },

        {

            "name": "signer2",

            "label": "Approver",

            "defaultValue": "${sender.email}",

            "minListCount": 1,

            "maxListCount": 1,

            "editable": true,

            "visible": true,

            "allowfax": false,

            "allowSender": true,

            "authenticationMethod": "NONE"

        },

        {

            "name": "signer1",

            "label": "Receiver",

            "defaultValue": "",

            "minListCount": 1,

            "maxListCount": 1,

            "editable": true,

            "visible": true,

            "allowfax": false,

            "allowSender": true,

            "authenticationMethod": "NONE"

        }

    ],

    "passwordInfo": {

        "required": false,

        "visible": false,

        "defaultValue": ""

    }

}

First Try:
I created a Transient Document (through the API) and retrieved my document Id, when i try to put this into the workflow I receive the error of
400MISC_ERROR: Some miscellaneous error has occurred.

Second Try:

I tried to create the request with just the minimal amount of data (according to the swagger)

{

    "documentCreationInfo": {

        "fileInfos": [

            {

                "name": "document1",

                "workflowLibraryDocumentId": "3AAABLblqZhAF87SdfsxcvbEDSAUtEBRKzgXTvqh4EUFj_YmkqAKDSm5w_Tb8HtO5lhaXP4b-JsIXMUc7NaQ9mSV-9JUIo"

            }

        ],

        "name": "Letter",

        "recipientsListInfo": [

            {

                "name": "Signer1",

                "recipients": [

                    {

                        "email": "sender@email.com"

                    }

                ]

            },

            {

                "name": "signer2",

                "recipients": [

                    {

                        "email": "sender1@email.com"

                    }

                ]

            }

        ]

    }

}

and I now receive the error:

{ "code": "MISSING_REQUIRED_TO_FIELD", "message": "Required ToField tosC is missing" }

As I am using the V5 version of the RestAPI and all the documentation i can find is for the V6 version, does anyone have an idea of what is the potential issues?

I've been banging my head for the last few days trying to get this sorted.

I don't have an Admin account to be able to change the workflow directly,

Hello Colmd,

We're sorry for the trouble you had, I will request you to contact our technical support team over the chat/call so that they can assist you with the custom API workflow.

For the subscribed account, find the below steps to contact support:

• Login to your Adobe Sign account directly via https://secure.echosign.com/public/login

• Once logged in, check the upper right corner of the page and click the question mark icon.

• It will re-direct you to the page where you get the option to create the support case or to start a chat with the team.

• If you've never logged in this way, use the forgot password option on the login link to set your password.

Adobe Sign Support Page

Thanks,

Anand Sri.

Topics

Questions Need Help

Views

245

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Nov 29, 2018

Copy link to clipboard

Copied

Hello Colmd,

We're sorry for the trouble you had, I will request you to contact our technical support team over the chat/call so that they can assist you with the custom API workflow.

For the subscribed account, find the below steps to contact support:

• Login to your Adobe Sign account directly via https://secure.echosign.com/public/login

• Once logged in, check the upper right corner of the page and click the question mark icon.

• It will re-direct you to the page where you get the option to create the support case or to start a chat with the team.

• If you've never logged in this way, use the forgot password option on the login link to set your password.

Adobe Sign Support Page

Thanks,

Anand Sri.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...