Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Adobe XD displays different Roboto font than Adobe Illustrator - why?

Community Beginner ,
May 13, 2020 May 13, 2020

Copy link to clipboard

Copied

I am trying to mockup some Android screens using Adobe XD and the Roboto Regular font. However, XD keeps using the wrong Roboto font. This is especially noticable in the "1s" and "9s". (see attached)

 

Interestingly enough, the Roboto Regular font does appear correctly in Adobe Illustrator. Also, when my colleague opens the XD file on her machine, she is able to see the correct font. 

 

I have Windows 10 and have tried to uninstall the Roboto font from the control panel, but get a message saying "cannot be deleted because it's in use". Even if I reboot my computer and go straight to the font panel, I get that message. I went to regedit and deleted all the Roboto fonts from "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts" and rebooted. Now I am left with the wrong font for Illustrator and XD. I install the latest Roboto font again and it is good in AI but not XD. Back to square one.

 

When I open the font families in XD I can see 3 "Regular" options for Roboto. Each one I select is the same, and they are all wrong. When I open families in AI, there is just one for Regular and it is correct.

 

How and where is XD getting this font? How can I force it to use the correct Roboto font?

 

 

Views

368

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 14, 2020 May 14, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear you are facing trouble. Would you mind sharing a sample file with me over a private message? Please upload the file to a shared location such as Creative Cloud app or Dropbox and share the url with me. It would be really helpful if you can share the screenshot of your about XD info page. Is your colleague using the same operating system?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 21, 2020 May 21, 2020

Copy link to clipboard

Copied

Thank you Harshika - for some reason the notice of your reply went to my spam folder. I am on Windows 10 and my colleague has a Mac.  Below is a screenshot of my XD install and I will send a message with link to an example file now. Thanks again for any help you can provide!

greenhorsez_0-1590069983781.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 26, 2020 May 26, 2020

Copy link to clipboard

Copied

Thanks for sharing the file. I will investigate about the issue with the team and will update you as soon as I have any updates or need any more information from you. 

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2020 Nov 26, 2020

Copy link to clipboard

Copied

LATEST

Hi!

Any updates on this? I have exactly same problem with Roboto Slab rendition - it seems it messed up the font styles names and the real Regular and Black are not even in there, instead 3 Regular (which all are same Bold)

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines