Adobe XD, potential MacOS Monterey Bug (Interface/Menu Options Disabled)

Community Beginner ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Having critical issues since updating to MacOS Monterey.

 

I can no longer export documents or take any interface actions. I can move elements on my pages, but menu actions, such as simple copy and paste, no longer work and are seemingly disabled.

 

This only began happening after an update to MacOS Monterey, and I can't find any other users with similar issues and potential resolutions.

 

This has brought my workday to a grinding halt, and outside of rebuilding the entire interface in Figma, I see no other option than to hope rolling back to the previous version of MacOS via a system restore is going to fix the issue (I've already started that process). 

 

I am moving my workflow to Figma, and coincidentally started that process this week, but I'm probably a good week away from transposing my design system and rebuilding my component libraries. 

 

Has anyone else run into a similar issue? 

 

Export disabled:

 

Screen Shot 2021-10-27 at 5.47.06 PM.png

 

Copy and paste disabled, along with other actions:

 

Screen Shot 2021-10-27 at 5.47.19 PM.png

Views

1.5K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Hi Silverjerk,

 

We are sorry for the frustration and thanks reporting the issue. We are unable to reproduce the issue at our end. We would like to know the version of XD you're using. Does that happen with all the files or you noticed this on a specific file? 

If it's reproducible at your end, could you please record a video of your workflow and share with us so that we can investigate better by following your steps?

 

We will try our best to investigate the issue.

 

Thanks,

Harshika

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Thanks, Harshika. 

 

The issue is definitely consistent; and even with fresh installs it continues to happen. Attached a video for review at this link.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 28, 2021 Oct 28, 2021

Copy link to clipboard

Copied

Thankyou for sharing the video link, Silverjerk.  Is it possible for you to share the About XD info and the XD file? If yes, please upload the XD file to a shared location such as CC or Dropbox and share the URL with me over a private message.

 

Please also share the Adobe ID, phone number and location with me as well.  

 

We would also request you to please create a new file and then try if it's happening on new files as well.

 

We will try our best to investigate.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 29, 2021 Oct 29, 2021

Copy link to clipboard

Copied

Thanks, here are the links for the Doc. I would need your email to share the actual file on CC.  

 

https://xd.adobe.com/view/c05af09a-8b9e-466d-b4b7-63b04e774dc1-9509/

 

I do not want to share Adobe ID, location and phone number here, for obvious reasons. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 29, 2021 Oct 29, 2021

Copy link to clipboard

Copied

Hi there,  I have sent a private message to you with my email and some troubleshooting steps, like, remove external display/ devices from the C - type port and check if the shortcuts are working for you. 

 

Here's another interesting thing, in macOS Monterey, all shortcuts appears disabled for all the menu items, it is not just with XD. They get highlighted when you hover over them. However, your situation is a little different than this, apart form being greyed out (as expected) they are not functioning.

 

I appreciate your co-operation and patience with this and we'll try our best to get it fixed for you asap. 

Awaiting your response.

 

~Atul_Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 29, 2021 Oct 29, 2021

Copy link to clipboard

Copied

Thank you, @Silverjerk, for sharing the file. I have saved it as a copy, and you can revoke my access to the file. I tried to use shortcuts on the file, and it is working fine at my end.

 

Would you mind confirming that your shortcuts are working if you remove the external display from the USB-C/TB3 port? 
If yes, please share the logs from your machine using this link:- https://helpx.adobe.com/creative-cloud/kb/cc-log-collector.html. In addition, you may upload the logs to CC or Dropbox and share them via private message. 


I am assuming we are close to identifying the root cause here. These insights would be helpful for our product team to take it further. 

 

Thanks, 

Atul_Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

Good evening.
I had the same problem.
I could not save the project as well as export, but when I removed the second screen the problem was solved.

Thanks!! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

I have the same problem. For me the task is possible to do but it is impossible for me to get any dialog box for this option. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Hi Magnus, thank you for sharing the details. Can you confirm if you're able to use the shortcuts after removing the extended monitor from C- type/TB3 port? 

 

If yes, please share the logs from your machine using this link:- https://helpx.adobe.com/creative-cloud/kb/cc-log-collector.html. Please upload the logs to CC or Dropbox and share them via private message. 

 

Thanks,

Atul_Saini

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

quote

Hi Magnus, thank you for sharing the details. Can you confirm if you're able to use the shortcuts after removing the extended monitor from C- type/TB3 port? 

 

If yes, please share the logs from your machine using this link:- https://helpx.adobe.com/creative-cloud/kb/cc-log-collector.html. Please upload the logs to CC or Dropbox and share them via private message. 

 

Thanks,

Atul_Saini

 

 


By @Atul_Saini


Yes I can confirm it now works without the extended screen. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

I spoke too soon. If I boot my Mac with either screen or docking station the export function is not working and even though I disconnect it won't start working again. 

I have to use this program daily and now ill be far behind in making my ads...

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

@Silverjerk and @Magnus Smogeli,

 

Thank you for your patience. Would you mind switching your primary and secondary monitor and checking if you can use the menu options? I'd also request you to reinstall the application and check if that makes any difference.

 

I would also appreciate it if you could find some time to collect and share the logs from your machine, as mentioned in my previous post. It would help our product team to proceed with the investigation.  

 

Thanks,

Atul_Saini

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

I have the exact same issue as described above and tried re installing still having the same problems. When i deleted the cache it would work for a second than back to not be able to export any assets.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

I did some further testing and these are the results: 

 

Dell TB dock without screen: working

HP TB dock with screen: not working

1 External screen with USB C: working

2 External screens with USB C: not working

 

in other words the problem arises once I plug in MORE than 1 external monitor. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 08, 2021 Nov 08, 2021

Copy link to clipboard

Copied

LATEST

Thanks, Magnus for sharing your investigation. In the meantime the team is investigating the issue you may try one of these options as a workaround,

 

  • Change primary monitor from System Preferences (Display) and then restore the settings back to original. Steps are shared here.
  • If that doesn't help, we would suggest disconnecting the external monitors.

 

Let us know if it helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines