Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Adobe XD time trigger stopped working

New Here ,
Sep 08, 2021 Sep 08, 2021

Copy link to clipboard

Copied

I'm running the latest 43.0.12.14 ver of XD. On my project, the time trigger is not working on some artborads when playing through the entire project, but strangely it works fine if I just play from the artboard where the time trigger is set. That means the time trigger is set up correctly but is not triggered when played from previous artboards before it. I've never encountered this issue in previous versions of XD.

Views

180

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

After some testing, I found the root of the problem: Component with hover state will cause the time trigger to break. This problem can be replicated with duplicating 3 artboards with a simple component with a hover state. The 1st artboard will have a Tap trigger to the 2nd and the 2nd artboard a time trigger with delay >= 0.4s to the 3rd. During playback, if u tap the 1st artboard outside of the component, the animation works fine. If instead, you hover over the component on the 1st artboard and then tap over it, it will stop at the 2nd artboard and not play the delayed time trigger to the 3rd artboard. I believe the hover action of the component on the 2nd artboard stopped the time trigger from playing. I hope this can be reported as a bug for the next fix.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 09, 2021 Sep 09, 2021

Copy link to clipboard

Copied

LATEST

Hi there,

 

Sorry to hear about the trouble. Will it be possible for you to share the file and the published link so that we can test this on our end? You can add the file to a shared location and share the link with me through DM by clicking on my name. We'll also need the version of XD and OS along with a screenshot capturing the artboard on which the time triggers are not working.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines