• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Artboard links not working

Advisor ,
Jul 05, 2020 Jul 05, 2020

Copy link to clipboard

Copied

Artboards links are not working. I'm linking from a menu text to artboard but nothing happens when previewing in prototype mode. I don't get a link hand when hovering over the linked text either.

 

W10

XD 30.2.12.3

TOPICS
Prototyping

Views

1.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 05, 2020 Jul 05, 2020

Copy link to clipboard

Copied

Hi, 

Sorry to hear that,

Can you please help me in knowing whether it is happening only with one document or happening with every document.

Please Can you share video of issue you are facing with this channel.

 

Thanks, 

Vertika Gupta

Adobe XD

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
Jul 06, 2020 Jul 06, 2020

Copy link to clipboard

Copied

I've spend alot of time on this issue and it seems to me that artboard links won't work with components and also some times on copied artboards. I have one artboard where the top menu is the master component, the links added to that menu to all the other artboards wont work. No link hand when mouse over of text. No nothing. Yet the text is linked and the link arms are all showing in prototype mode. XD also fails when an artboard is copied and renamed and then put between two artboards, then if you add a link from that artboard on the whole artboard (not a singel element) it often fails to work. Its not included in the row of artboard and it "skips" to the next. These are just a few of the quirky instabilities of artboard links. There are more and they keep coming for each so called upgrade.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 06, 2020 Jul 06, 2020

Copy link to clipboard

Copied

Its works for me as from any object as well from component.Please share link of your project to test in browser. 

 

Thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

This is happening to me right now and I'm at at a total loss. It's never happened before.

The link is clearly created and connected to another artboard. I have other links which are identical in style which are linking just fine. I didn't do anything differently. Yet this one link will NOT WORK. Whether in the preview or the actual prototype online. It's driving me crazy. I don't know what else to do. Very hard to find threads on this topic.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

P.S. I have zero components in this particular artboard, so it's not a component issue. Literally a simple text+element group, and the prototyping on it won't work.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

I had the same issue today. It turned out that some of my triggers were set to "keys and gamepad" instead of "tap". unsure if this was user error or bug but changing back to "tap" fixed it for me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

Hey OMG, same thing for me. I just started a whole thread about it earlier once I figured it out. (Should have updated my response here too).

 

What gives! I'm thinking it's something to do with XD, since both of us had the issue!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2022 Sep 28, 2022

Copy link to clipboard

Copied

Hi All,

Sorry so late to the party, but I just wanted to confirm this XD glitch is still a real thing. I was having this issue on two newly created pages (duplicated from artboards with fully working navs) and 1/4 nav items stopped working on both new artboards! I triple-checked that my triggers were set to tap, and they were, so I finally deleted the "corrupted" nav element from each new artboard, and pasted JUST that element into the group again... I had to reset both the hover and tap triggers, and funny enough, the trigger it wanted to default to was Games and Keypad! I've never used this trigger, so I'm not sure why it wants to go there, but once I changed it to tap again, it works!!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 30, 2022 Sep 30, 2022

Copy link to clipboard

Copied

LATEST

Glad to hear you're back on track and thanks for updating the post with your research. We really appreciate your efforts. Please feel free to reach out to us in the future for any query related to XD.

 

We would be happy to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines