Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Bug when creating stack consisting only of components

Explorer ,
Jul 29, 2021 Jul 29, 2021

Copy link to clipboard

Copied

I'm trying to create a stack from a group of components. The only items in this group are components.

 

When I turn stacks on, a new group is created around the original and XD doesn't know how to set the stacking automatically.

 

When I break the original group, I'm able to set the stack values correctly and everything works as expected.

TOPICS
Design

Views

221

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 30, 2021 Jul 30, 2021

Copy link to clipboard

Copied

Hi plainclothes,

which version of Adobe XD are you using? Does this problem only occur on a specific file or multiple files? Could you attach a short video?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 30, 2021 Jul 30, 2021

Copy link to clipboard

Copied

I'm using 42.0.22.11 arm64.

 

Yesterday I battled this issue for 10 mins and it seems to effect everything.

Today alls well with the same doc and components that started it.

 

Looks like I've found another XD ghost. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Aug 03, 2021 Aug 03, 2021

Copy link to clipboard

Copied

Hi plainclothes,

I am glad that your problem seems to have been solved. If the problem should occur again contact us.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 04, 2021 Aug 04, 2021

Copy link to clipboard

Copied

LATEST

I think I finally figured this out. I had a stack of components that were touching. That seems to blow XD's mind every once in a while. It consistently messes things up when the elements are overlapping. So I'm guessing the zero-gap scenario had some minor overlap by mistake.

 

Can't the stack just read in zero or negative spacing from the start? 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines