desktop preview and published link behave differently

Engaged ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

I've been battling with this for far too long and it's really frustrating.

My prototype works as expected in desktop preview but when I view it on a share link, there's very erratic behaviours.

As an example, I have some images with a coloured overlay set to multiply that appears on hover. All good in desktop preview but once I share and go to the link, the overlay is not there. A strange keyline is appearing around the images instead together with a dotted texture. See attached images.xd issues.jpg

Views

322

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Sep 12, 2022 Sep 12, 2022

Which browser are you previewing in? And have you tried restarting your computer? I know that sounds silly, but I've seen many a weird thing fixed by a simple restart.

Likes

Translate

Translate
Community Expert ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

Can you share prototype link to test it? Thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

not publicly

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

Does it affect multiple files or just this one?

Look around in the layers panel to see if there's something else hidden somewhere that could be interfering, this is strange behavior.


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

so far just this one, there's nothing else interfering. As you can see it works as expected on the desktop preview, the fault is in the shared link. I find that everything in XD is strange behaviour...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

Did you look in the layers panel to see if maybe there are any hidden or leftover elements that might be creating that?


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

yes I did and there's nothing of the sort.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

Which browser are you previewing in? And have you tried restarting your computer? I know that sounds silly, but I've seen many a weird thing fixed by a simple restart.


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

That did the trick, thanks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

LATEST

Yeah! I know it's simple, but restarting an app or a computer is always a good first step in troubleshooting. It's like computers can stressed out and tired too, haha 🙂


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

I think you posted this in the wrong place 🙂 


— Adobe Certified Expert & Instructor at Noble Desktop | Web Developer, Designer, InDesign Scriptor

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines