• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Drag animation not working

New Here ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

I have two tables, one behind the other. These tables consist of separate rows. I want to add a row from the table below to the table above by drag and drop method. When I try to use the drag animation it reloads the same page and does not switch to the other linked page. I'm not sure what causes this. I will be glad if you help

Views

107

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Merhaba Didem,  

I tried to create "overly simple" (:)) two tables to simulate the elements you described and the drag trigger works perfectly for the animation/transition.

You can see the prototype here (you can test it by dragging the top row of the table 2 (the one below) to the bottom of table 1) : https://xd.adobe.com/view/446a115e-e9b6-4dd8-997b-ecbbe8cb293c-1139/  

and the file here: https://www.dropbox.com/s/5wjoaobwtc605bz/two-tables.xd?dl=0

 

In order auto animate to work, make sure layer structure, element & layer names etc are same in both artboards, those are the problems that I can think of. Please check and let us know, maybe some other expert also suggests something, hope this helps!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

LATEST

Hi @Didem26917035777n,

 

Thank you for reaching out, and sorry to hear you're having trouble with the Drag trigger in XD. Would you mind telling us the version of XD and the operating system you're working on? Please also share the screenshot of your design in prototype mode so that we can see the interactions.

 

Have you tried copy-pasting the design from prototype mode into a new file and seeing if that works?

 

We'll try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines