Layer in the back still overlaying

Community Beginner ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

 

Look at the image below. The phone should be showing underneath the other elements, but its still overlaying. This is so essential, but is still broken. How can you deploy such a broken build? 

 

XD is so bugged on basic behaviour, I am forced to migrate to Figma/Sketch. It used to work great, but similar to Illustrator and Photoshop, all good things have to be ruined by Adobe... 

 

Screenshot 2022-09-12 at 16.58.02.png

TOPICS
Design , Product performance

Views

173

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Community Expert , Sep 12, 2022 Sep 12, 2022

Hi @Saro GFX, have you checked the z-index property on the right side panel, under the "Transform" section? The only explanation for that would be the underneath layer's z-index to be bigger than the ones in the layers above. Hope this helps!

Likes

Translate

Translate
Community Expert , Sep 12, 2022 Sep 12, 2022

Does the phone have a positive z value (3D transformation)? If so it appears on top of other elements with lower z value (or no 3D transformation).

Likes

Translate

Translate
Community Expert ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

Hi @Saro GFX, have you checked the z-index property on the right side panel, under the "Transform" section? The only explanation for that would be the underneath layer's z-index to be bigger than the ones in the layers above. Hope this helps!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

Does the phone have a positive z value (3D transformation)? If so it appears on top of other elements with lower z value (or no 3D transformation).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 13, 2022 Sep 13, 2022

Copy link to clipboard

Copied

Thank you, that fixed indeed the issue. Although I think that if you disable the 3D box, it should also reset the z-index. Especially since Cmd+T is such a easy shortcut to hit accidently. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 13, 2022 Sep 13, 2022

Copy link to clipboard

Copied

LATEST

I agree with that.

I hit Cmd + T often unintentionally - because it's a Photoshop shortcut for free transform 😆

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines