Lottie animation is not playing on web in XD 45 version on win10 machine

Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Hello everyone, tell me, there is a problem with lottie animation, it does not play when I create a test link, but everything is fine in Adobe XD itself!

 

 

<Title renamed by moderator>

TOPICS
Product performance

Views

2.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Explorer , Oct 27, 2021 Oct 27, 2021
I found a solution to this problem, I imported the Json file into AE and deleted the layers with the text, because the animation was not playing because of this! But now there are no percentages for animation, perhaps your specialists will be able to find a better solution !?

Likes

Translate

Translate
Adobe Employee , Nov 10, 2021 Nov 10, 2021
I think the issue is not the Text but the Font that is used. Try changing the Font to one that you know works in XD. Hope this helps, Randy 

Likes

Translate

Translate
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Here is json file

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Hi there,

 

Sorrry to hear about the trouble. To reproduce this on my end, I'll need a few more details like:

 

  1. The version of the OS.
  2. Is this happening with this specific Lottie file or multiple lottie files?
  3. Please share a screenshot of the prototype mode.

 

We're here to help, just need more details.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Version 45.0.62
This is exactly this animation, everything is fine with the others! Here is the prototyping mode in Adobe XD and web

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Win 10

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Thank you for sharing the information. Is it possible for you to share the source of the file? 

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Okay, do you need access to your project in Adobe XD? or the Json file itself?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

We would like to know from where you have downloaded this Json file. Does that happen with this specific Json file or all files?

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

You can also download this animation from the LottieFiles plugin in Adobe XD itself!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

This is exactly this animation, everything is fine with the others!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Thanks for sharing the link for the lottie file. It doesn't seems to work at my end as well. There seems to be an issue with this specific lottie files as rest other seems to work. 

 

I would suggest using the other lottie animations for now if that works for you.

 

Thank you for highlighting this to us.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

It's a shame, as this animation fits my layout very well! Tell me if there is someone from technical support who could tell me how to change this file so that it works?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Sorry for the trouble, you5CF6. We would also like to confirm few more things with you-

 

  • Did you add any other Timed Interactions with a samller Delay?
  • Did you add any Lottie elements to Artboard? These are "Play Automatically" by default, which is a Time Trigger with a Delay of 0.

 

If yes, then currently, Adobe XD only supports 1 Timed Interaction per Artboard. The Timed Interaction with the smallest Delay takes precedence.

 

Let me know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Tell me if there is someone from technical support who could tell me how to change this file so that it works?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

I am checking with the team regarding this and will get back to you as soon as I hear back from them. We are investigating on your issue.

 

We're sorry for the inconvenience.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

I found a solution to this problem, I imported the Json file into AE and deleted the layers with the text, because the animation was not playing because of this! But now there are no percentages for animation, perhaps your specialists will be able to find a better solution !?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

I think the issue is not the Text but the Font that is used. Try changing the Font to one that you know works in XD.

 

Hope this helps,

Randy 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 10, 2021 Nov 10, 2021

Copy link to clipboard

Copied

Hello, 

I experienced the same issue with an animation using the text animate property in After effects too, also it does not even preview when you add a video with autoplay in the document.

 

Hope there is a fix.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

Hi folks,

 

Harshika brought me here, because i had a simular issue. 
As it appears,. if you have a costum animation made in After Effects, be sure that you transform your Text-Layers into Shapes in AE. Seems like the option to transform Fonts into Shapes by bodymovin doesnt work. 

With doing that manually you shoudnt have any problems.

Cheers 
Björn

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 08, 2021 Dec 08, 2021

Copy link to clipboard

Copied

Hi All,

 

Lottie files with native font embedded will not play back in the web player and the team is working on this issue. We've shared the lottie Json files shared by you on the bug logged. 

 

We will keep you posted.

 

In the mean time, please try the workaround suggested in this post and let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 08, 2022 Apr 08, 2022

Copy link to clipboard

Copied

LATEST

I am using this Lottie animation in android https://lottiefiles.com/70883-animation-fade-in-fade-out i have placed arial.ttf file in my assets/fonts folder with out it I was getting crash (not found file) but I think it is not reading it now...
162171733-da3d186b-cb7b-4f21-acdb-96237b65cedc
I have also try using programmatically but it also not working
162172016-c21527a7-8169-4a67-918e-a24de70bb89e
it not throwing any exception or error no crash nothing just not playing animation of text

 

this is not reading font file pleases help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines