Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Required components conflict

Community Beginner ,
Nov 18, 2020 Nov 18, 2020

Copy link to clipboard

Copied

Hi all,

 

When updating my design library/design system in XD, I often get this error in XD the first time I press the "Update" button:

 

f_monfort_0-1605755234296.png

 

When I press "update" the second time, the library updates successfully and this error doesn't appear anymore. Every update I have to do, I face this issue again.

 

May I ask what this error means and how to fix it?

TOPICS
Product performance

Views

662

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 01, 2020 Dec 01, 2020

Copy link to clipboard

Copied

Hi there,

 

We're so sorry for the delay in response. Could you please confirm if you are still getting this error on the latest version of XD which is XD 35.1? If yes, please share a few more details like:

 

  1. Is this happening with a specific file or multiple files?
  2. Do you get this error every time after updating XD?

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 16, 2021 Feb 16, 2021

Copy link to clipboard

Copied

So im on verison 37.0.32.10 and this is still an issue?

 

It happens when using a design system UI components file with lots of pages...  i have a timeline built on one page, i want to add to might propotype file - i try adding i get this issue reponse and of course my timeline states arent up-to-date.

 

lots file telling me but i cant make them all out... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 10, 2021 May 10, 2021

Copy link to clipboard

Copied

This is happening for me too; I can't figure out how to fix it. I've deconstructed the elements and they all appear fine and connected and such.

Screen Shot 2021-05-10 at 3.21.54 PM.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 13, 2021 May 13, 2021

Copy link to clipboard

Copied

do we have solution for this.. I have same problem. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

_0-1623942412302.png

I have this issue too. It prevents me from using my components elsewhere other than the file they are defined in.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

I am suffering from this problem too. The error message suggests to to update the libraries with the conflicting components to the same version, but how can you do it?

I have created one component library file that contains tens of components (masters), shared the library, and used the components in several project files. I update the library with the new components frequently and sometimes also fix the existing components — so it is not a "frozen" document. Depending on a component, the project files can contain from tens to hundrends of instances of a component.


@Rishabh_Tiwari

  • The problem occurs with multiple files — not just with a specific one.
  • I cannot say if the problem appears after each update of XD — It can be so too. I updated to the version 42.1.22.4 last week but noticed the problem with a couple of XD files today.
  • The problem occurs mostly with project files I have not opened for a while (e.g. a month) but the library has been updated meanwhile.
  • When the problem occurs, any attempt to update the component (by clicking the blue icon) in Document assets leads XD application to crash — or at least the colorful spinwheel appears to the screen (for minutes or even hours) and XD turns to be unresponsive.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

LATEST

For this error message:

"Component [name] has required components that conflict with components in your document. Please update the libraries with these components to the same version: [library,...]"


This generally happens when trying to Import or Update a Component has a nested Component, and the nested Component has a pending Update. Start by trying Update All to update required Components that are Local to your Document.

 

If error persists, open each external Library (listed at end). Opening each external Library ensures that they are converted to same version of XD you are running. Also Update All to apply any pending Updates to these docs.

 

Hope this helps,

Randy

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines