• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Scroll-to Animations not working in exported XD project

Community Beginner ,
Feb 16, 2023 Feb 16, 2023

Copy link to clipboard

Copied

Hello,

I have problem with my xd project, I set some "scroll to" animations in the prototype, it work well inside xd, but when I export the project to web, the animation doesn't work

 

Anyone know why and how to fix it? 

 

<Title renamed by moderator>

TOPICS
Prototyping , Share or publish

Views

1.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Feb 24, 2023 Feb 24, 2023

Hey, fixed it for you, although I'm not sure what the issue was, think it was some glitch in the file itself. When I recreated the same scenario in a new file, everything worked as intended.

 

Here's your file:

https://www.dropbox.com/s/a65hiz2iekp2kne/The_Inner_Farmer_fixed.xd?dl=1

 

Here's the prototype:

https://xd.adobe.com/view/bcc195b6-562e-4dda-9d4a-20f89e2b43f6-e992/

 

What I did:

1. changed some things in your component - removed the repeat grid, deleted the component and pasted an insta

...

Votes

Translate

Translate
Adobe Employee ,
Feb 17, 2023 Feb 17, 2023

Copy link to clipboard

Copied

Hi @שקד284479127psx,

 

We're sorry to hear that you're having trouble with your XD project's scroll-to animations. We understand that the animations are working fine inside XD, but when you export the project to the web, they don't work.

To help you resolve this issue, we would need to gather some more information. Could you please provide us with the following:

  • The version of Adobe XD you're using
  • The web export format you're using (HTML, PNG, PDF, etc.)
  • The web browser and version you're using to view the exported project
  • The steps you're taking to export the project
  • Any error messages or warnings you're receiving during the export process

Once we have this information, we'll be better equipped to diagnose and resolve the issue. We appreciate your patience and look forward to hearing back from you soon.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 18, 2023 Feb 18, 2023

Copy link to clipboard

Copied

Hey, thank your responding. Here is the requird info:
XD verison: 56.1.12
export format: HTML

I'm using Opera GX browser V. LVL 4 (core: 94.0.4606.107)

steps to export: I go to the share tab inside XD, in the link setting I chooshe - presentation, anyone with a link, click on Updade link, it goes up to 100%, and generate the link. I enter the link and besides the scroll to animation, all the other animation works fine.

please let me know if you farther information

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

hey, is there any solution fir the problem?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

Can you try on a different browser than Opera to see if the issue is browser specific?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

I tried on microsoft edge and google chrome, it still doesn't work

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

yes it does.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

https://xd.adobe.com/view/3e286819-9884-4bc9-95c8-13f4b120d55f-6b7b/?fullscreen

This is my project. When hover the "Inner farmer" logo on the left side of the page, it open a menu with 3 headers, when I click for example on the "The farm" header, I created in XD a "scroll to" animation, so it will scroll to the part of "The farm" in the page.

inside XD it's works fine, but not on the web unfortunately

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

Hi @שקד284479127psx,

 

Thank you for sharing the requested info. Is it possible for you to share the XD file with me over a private message so that we can check on our end?

 

If yes, please upload the file to a shared location such as CC or Dropbox and share the URL with me.

 

I will try my best to investigate.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 24, 2023 Feb 24, 2023

Copy link to clipboard

Copied

Hey, fixed it for you, although I'm not sure what the issue was, think it was some glitch in the file itself. When I recreated the same scenario in a new file, everything worked as intended.

 

Here's your file:

https://www.dropbox.com/s/a65hiz2iekp2kne/The_Inner_Farmer_fixed.xd?dl=1

 

Here's the prototype:

https://xd.adobe.com/view/bcc195b6-562e-4dda-9d4a-20f89e2b43f6-e992/

 

What I did:

1. changed some things in your component - removed the repeat grid, deleted the component and pasted an instance of it instead.

2. rewired the "Scroll to" actions to images and other elements, instead of the section titles - that's when it started working. When I returned the links to the section titles, it was still working.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

great, it work like a charm now. Thank you so much🙌

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

although, I having a problem exporting the project on my own now.

I keep getting the same error when try to create a link - 44:23.

I have read that the problem might be in the bit map of the project because it cross the 64000000 limit, but earlier when I exported the project it worked fine

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 25, 2023 Feb 25, 2023

Copy link to clipboard

Copied

LATEST

Hey, not sure about that one. I'd suggest, be it a bit time consuming, to make a new file and paste the design elements in it, assembling everything nicely, with a proper layer order and so on. There might be something corrupted in the old file making it glitch out from time to time, and maybe it carried over even in the fixed version I sent.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines