• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

[Text]-Text tool changes font when leaving edit mode in XD.

New Here ,
Feb 26, 2020 Feb 26, 2020

Copy link to clipboard

Copied

The font changed to a weird .Applesomething font name and then the text looks the same once you leave the editing mode. Might be separate issues. Anyone else experienced this? XD 27.1.12.4

 

<The Title was renamed by moderator>

TOPICS
Design , Product performance

Views

2.2K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Apr 29, 2024 Apr 29, 2024

This worked - has been bugging me for years! Thanks

Votes

Translate

Translate
Adobe Employee ,
Feb 26, 2020 Feb 26, 2020

Copy link to clipboard

Copied

Hi there,

 

That's sounds strange we haven't heard anyone else experiencing the similar issue. Could you please share a short video of the workflow or the screenshot for better understanding? Is it happening with a specific font or all the files? 

 

We will try our best to help.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 13, 2020 Jun 13, 2020

Copy link to clipboard

Copied

I have the same issue. I'm using Kollektif font for a text field and while I'm inside the field, editing it, it shows some other font. It's abnouxiously annoying, because everytime I exit the field, the whole text changes its placement. Any fixes?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 15, 2020 Jun 15, 2020

Copy link to clipboard

Copied

Hi there,

 

I am sorry to hear you are facing trouble with font getting everytime you stops editing in XD. I would like to know a few more details to investigate about the issue.

 

  • Would you mind sharing a short video of your workflow?
  • Is it happening with all the files or with a specific file?
  • Please share the screenshot of your about XD info page.

 

We will try our best to help.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2020 Jul 02, 2020

Copy link to clipboard

Copied

This is happening for me on PC as well. The font displays correctly when unselected. When clicking into the type to edit, the font changes to something different with different spacing as well. This is frustrating as I must click out of editing to see the final display. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 02, 2020 Jul 02, 2020

Copy link to clipboard

Copied

Hi GR Michael,

 

I am sorry for the frustration. Is it possible for you to share the above asked information so that we can escalate this to our team for investigation?

 

We will try our best to help.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

Hi Michael,

 

Thanks for sharing the video. I see that the font name or property doesn't change in the right side property pane. Is it possible for you to share the file as well with me so that I can check at my end? Please share the OS and XD version of your machine.

 

I will try my best to help.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

XD Version 31.2.12.4  Cloud Sync 4.3.51.3

Windows 10 Pro

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 18, 2020 Aug 18, 2020

Copy link to clipboard

Copied

Thanks for sharing the details, GR Michael. Could you please share the file as well with us over a PM so that we can check at our end?

 

Note: Please add the url of the post over a PM for reference.

 

I will try my best to help.

 

Thanks,

Harshika

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 22, 2021 Jul 22, 2021

Copy link to clipboard

Copied

I am experiencing the same thing...when I would click to edit text, it would change to a sans serif font but when I clicked off of it, it changes back. I found that I had to activate the fonts directly on my computer (I use a font management program) if I had XD open I'd have to restart XD and it fixes the issue. I'm on a PC - Windows 10 - XD version 41.1.12.9

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

Same here!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 13, 2020 Aug 13, 2020

Copy link to clipboard

Copied

I found out this is font related. I just tried to make a video about it and test it with common fonts like Verdana and Calibri and this is not happening with those fonts.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 14, 2020 Aug 14, 2020

Copy link to clipboard

Copied

Hi Rangel,

 

Thanks for reaching out and sharing your findings. This generally happens when the actual fonts are being replaced by the system fonts and this happens with specific fonts with different font-weight. We can surely test this on our end, for that, we'll need the details about the version of XD and the Operating System along with details.

 

Regards

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

2022, still the same bug... :)))

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

Same, I was hitting this bug and came here. I'm disappointed this was discovered two years ago and it hasn't been fixed. Restarting my computer seemed to fix it, at least temporarily.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 13, 2023 Apr 13, 2023

Copy link to clipboard

Copied

2023 and it's still there 🙃

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 24, 2023 Apr 24, 2023

Copy link to clipboard

Copied

Yeah, I switched to Figma in the meantime 🤷‍:male_sign:

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 25, 2024 Jan 25, 2024

Copy link to clipboard

Copied

2024 and it is still happening with Google's Montserrat.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 29, 2024 Jan 29, 2024

Copy link to clipboard

Copied

Hi,

 

Sorry to hear about the trouble. Is this happening with a specific file & font or multiple files & fonts? Can you share a small video of the issue along with the version of XD & OS? We'll try our best to assist you. 

Thanks

Rishabh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 29, 2024 Jan 29, 2024

Copy link to clipboard

Copied

Hi,

 

This problem happens with https://fonts.google.com/specimen/Montserrat (the static version of the font). It helped a bit when I uninstalled the Adobe Montserrat font. The problem seems to be with the SemiBold weight.

As you can see in this video, the font changes from Montserrat SemiBold to Open Sans (I think) when I am clicked into the text box, so it makes judging distance difficult since the x-width of the characters of the font is different. The problem does not seem to happen with the other variations of the font. I don't think I am doing anything to extraordinary to make this issue occur; it just happens. Even when I pull the text to it's own text block, it still happens.

 

Thank you for your attention.

 

Windows 11

XD Version: 57.1.12.2

https://youtu.be/iOfmZHjTGGE

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

I have the same problem, Any update and idea how can I do something to the good result?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2023 Jan 12, 2023

Copy link to clipboard

Copied

I have the same problem but it only does this with adobe fonts. Very confusing! Fortunately, I can still use Arial 😞 2023...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 06, 2024 Mar 06, 2024

Copy link to clipboard

Copied

I had this problem, and the solution was super simple: by default, when I selected the text tool, both "fill" and "border" were selected in the properties panel. Unselected "border" removed the extra content and matched what I thought I was going to get. 

I don't know if this will solve everyone else's problem, but it solved mine -- more of a UX oddity than a software bug.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 11, 2024 Apr 11, 2024

Copy link to clipboard

Copied

Hey guys I had the same issue and I fixed it after realizing that adobe was storing all of my fonts on the cloud and not locally. After I made sure all of my fonts were installed locally through the creative cloud app, the problem was resolved.

Just open your creative cloud app > click on the 'fonts' icon at the top right > install all your font families.

This also fixes the issue where you couldnt access your adobe fonts from non adobe apps like Figma on desktop.

Hope this helps everyone.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines