Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Unable to create a toggle element using states in XD.

New Here ,
Mar 17, 2021 Mar 17, 2021

Copy link to clipboard

Copied

I'm trying to create a toggle button that changes changes between 2 states. I used the tap event in both states to go change to the other state. First time I tap the button, it changes state correctly. After that, reverting to the other state just doesnt work because it changes state but quickly goes back to the state before the tap. Why is this happening? Looks like the event fires twice. When using 2 artboards for this purpose the issue doesnt happen.

 

<The Title was renamed by moderator>

TOPICS
Product performance

Views

241

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Mar 21, 2021 Mar 21, 2021
Hi Marco, I tried creating a toggle using component states and it worked fine. I have attached the video of the state details and also the preview of the working. If this is not what you are trying to achieve then please let us know. Hope it helps. Regards, Jagriti Kashyap

Likes

Translate

Translate
Adobe Employee ,
Mar 18, 2021 Mar 18, 2021

Copy link to clipboard

Copied

Hi Marco,

 

Thank you for reaching out. It would be really helpful if you can share a video or screenshot showing the issues for better understanding so that we can try to replicate and investigate at our end. Please also share the OS and XD versions of your machine.

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Hello! Thank you for replying. My machine is a 2018 macbook pro 15" with macOS Catalina 10.15.4 and i am using XD 38.0.12.13. The issue I have encountered appears to be happening only when I have another link with a drag event with the toggle element inside. I attached a screen recording demonstrating turning off the drag link and trying the toggle element in both scenarios.

 

Thank you!

Marco Afonso

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 21, 2021 Mar 21, 2021

Copy link to clipboard

Copied

Hi Marco,

 

I tried creating a toggle using component states and it worked fine. I have attached the video of the state details and also the preview of the working. If this is not what you are trying to achieve then please let us know.

Hope it helps.

 

Regards,

Jagriti Kashyap

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 05, 2021 Apr 05, 2021

Copy link to clipboard

Copied

LATEST

Hi there,

 

We would like to follow up on your issue. Are you able to resolve the issue? You may try updating XD to 38.1 version and see if that helps.

 

Please feel free to update the discussion if you need further assistance from us.

 

We would be happy to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines