• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Unable to update linked component in XD

New Here ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

Hi, 

The linked component is not updated. Whenever we click on «Update», it displays a error message «Unable to update component beacause of an error». There is no way for us to know what error it is so we can fix it!

 

Please help. 

Thanks!

TOPICS
Product performance

Views

235

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

Hi Wei-Hsin5FA5,

 

We are sorry to hear you are unable to update the linked component in XD. We would like to know once you have updated the component in your main document, have you updated your published library as well? 

 

If yes, does that happen with a specific component or with all component?

 

Please share the version of XD and the OS details of your machine.

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

Hi Harshika, 

 

Thanks for the follow up!

The problem resolved by itself after I deleted a corrupted component in the source document. 

 

Is there a way to delete a missing element? I don't see the option of delete on the right click(see screen shot). 

Thanks!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

LATEST

Great. Have you deleted the component from the main source document? From the screenshot, it looks like you're trying to delete the unlinked component as it shows red error.  

 

You can definitely try deleting this component from the main source document and see if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines