Adobe Xd is getting slower

New Here ,
Feb 17, 2019 Feb 17, 2019

Copy link to clipboard

Copied

Hello everyone

I'm working on an app using Adobe Xd CC and i couldn't help but notice that the more content i add, the slower it gets. And by slow I mean "can't even zoom in or out" kind of slow, which is getting kind of annoying.

And as if that wasn't restrictive enough, some features decided to just stop working on certain pages. For instance I can't set new transitions between those pages while I still can with the first ones I designed.

I'm clueless and a bit irritated at this point, my PC can run anything quite fast but this.

Is it because the software was only designed to manage a few pages? Is it something else? Please help!

Sorry for the bad English and thank you in advance if you have any answer.

Regards

Views

7.9K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Explorer , Jul 16, 2019 Jul 16, 2019
Hi Sherif - for what it’s worth, I ran the update that came out this morning and I’ve been flying through my XD all day. Not sure if you magically put some fixes in with that release? In any case - it’s running better for me now. I’ll stay on this thread and let you know if any more issues come up. Thank you all for getting back to me. Much appreciated. Chris

Likes

translate

Translate

Translate
New Here , Feb 12, 2020 Feb 12, 2020
Hi, I have been having the same problem for a while. Assumed that was a problem of the device & upgraded to a SSD. Switched to macbook pro after that. The problem was persisting. After I noticed this thread I deleted all the components & XD is fast as before. I am not sure if its a coincidence. Components where helpful but it becomes a problem to use.

Likes

translate

Translate

Translate
Community Beginner ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

I'm having the exact same problem, and it's been happening more and more since I've been using the new components. Now it's taking some time to even select my path in order to change its border thickness - very very frustrating, especially with deadlines to keep on top of.

Anyone got any advice?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

Hi Matthew,

I understand that it could be annoying. I would suggest updating your graphics drivers? Please visit the manufacturer site to check for and apply the latest updates to graphics drivers and let us know if that works for you.

A few more details would be super helpful like if you are using Windows OS here? If yes, could you please share the version of XD which you are using at the moment?

Awaiting your response.

Thanks,

Harshika

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 21, 2019 Jun 21, 2019

Copy link to clipboard

Copied

I'm using a Macbook Pro (2017) on the latest version of Mojave 10.14.5 (which I've been on this for some time),

XD version 20.0.12.10, and I've uninstalled and reinstalled Creative Cloud. I've also cleared out my internal cache, ran first aid on my disk utility, and I've reset my SMC just to be on the safe side.

Anything else I can try?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 21, 2019 Jun 21, 2019

Copy link to clipboard

Copied

Does this seem to happen on new files as well, or is it limited to documents with components?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 24, 2019 Jun 24, 2019

Copy link to clipboard

Copied

Well, I've not really used any new files currently, but new or old, all my files would be using components if that helps? It seem to happen every now and again, for about half an hour, then works as normal until the next time it decides to stop working.

I didn't have this problem before, even on larger files.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 24, 2019 Jun 24, 2019

Copy link to clipboard

Copied

Is this document something you could share with us so that we could get our developers to look at? Alternatively, we could try looking at the logs, but it won’t be as easy to debug.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2019 Jun 25, 2019

Copy link to clipboard

Copied

Unfortunately I can't because it's part of an unreleased project. All the individual files link to a Creative cloud file of master components - could that be causing the problem?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 25, 2019 Jun 25, 2019

Copy link to clipboard

Copied

I’m trying to figure that out. Can you at least give me the number of components in the master document?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 25, 2019 Jun 25, 2019

Copy link to clipboard

Copied

Hi Matthew -

As Elaine mentioned, it would be really helpful to get the logs and the files (if possible) to diagnose that issue with our engineering team.

How many linked components are you consuming in your document? Are they all coming from one source document or multiple ones?

Are the performance issues are mainly visible on canvas operations or also in the Assets Panel?

Thanks Matthew.

-Sherif

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Sorry, just saw the response.

The majority is coming from one source file which has too many components to count (which might say a lot), a full user flow for this particular project which links to every other file. If it's all down the to number of linked components, that's something I can solve myself, however some files don't link to the master and act the same way from time to time.

Also, how do I send the logs??

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Hi Matthew,

Please generate log files using the information provided in this document <How to use the Creative Cloud Log Collector tool > After the files have been generated, upload the files to a shared location such as Creative Cloud, and share the URL with me over a private message.

Please send the URL of this forum post for reference. To send a private message, click my profile picture and use the Message button.

Please let me know if you face any issues with this.

Thanks,

Harshika

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Harshika just sent me your logs, which are great! Can you please also let me know what your machine specs and OS build number are? It will help us try to diagnose the problem.

Does this happen without linked assets?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 26, 2019 Jun 26, 2019

Copy link to clipboard

Copied

Also, for my own reference, I filed 82742.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 27, 2019 Jun 27, 2019

Copy link to clipboard

Copied

Not sure how much detail you're after but, I'm using a MacBook Pro (13-inch, 2017) with Mojave 10.14.5, 16GB, 2.5GHz i7.

Yes, also files without linked asset. Seems to be affecting files which use multiple components.

It seems to be the same thing regardless. One minute it's working perfectly fine, then the next, there's delays in my cursor actions, components won't update, it takes ages to delete, write text, or save, then I leave it for about 20/30mins and it's back to normal for a bit. When it happens it only affects XD because I'm still able to doing everything else fine on my MacBook.

Do you need anything else?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 27, 2019 Jun 27, 2019

Copy link to clipboard

Copied

Could you PM me your Email address in case we need to get a hold of you? Just hover over my name in the forums and select the “Message” button.

Just as a heads up, all of our North America offices are off next week, so it’s likely we’ll not be able to look at it until the week after.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 11, 2019 Jul 11, 2019

Copy link to clipboard

Copied

What are the download/upload speeds on your internet connection?

Are you on a VPN?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 12, 2019 Jul 12, 2019

Copy link to clipboard

Copied

Screen Shot 2019-07-12 at 9.36.29 AM.png

I'm working on an internal network with stupid high internet speeds. This lagging in XD continues to be an issue for me.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 12, 2020 Feb 12, 2020

Copy link to clipboard

Copied

Hi, I have been having the same problem for a while. Assumed that was a problem of the device & upgraded to a SSD. Switched to macbook pro after that. The problem was persisting. After I noticed this thread I deleted all the components & XD is fast as before.

 

I am not sure if its a coincidence. Components where helpful but it becomes a problem to use.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 20, 2019 Jun 20, 2019

Copy link to clipboard

Copied

Discussion successfully moved from Adobe Creative Cloud to Adobe XD

Regards, Abambo
Hard- and Software Engineer and Photographer.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 28, 2019 Jun 28, 2019

Copy link to clipboard

Copied

I'm also having this issue @elainecc. Running Adobe XD 20.1.12.4 on Creative Cloud Sync 4.2.7.2 on MacOS Mojave 10.14.5 with AMD Radeon R9 M380 2 GB. All local files run without issue, but Cloud files that house all my library components don't allow me to take barely any action without stalling out with the rainbow wheel. This is a huge hindrance to working with our shared design system and is slowing down my work exponentially. Can you help?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 28, 2019 Jun 28, 2019

Copy link to clipboard

Copied

Hi there! I’m asking our team to reach out to grab more information from you. Just as a heads up, our North America team (including myself) is off for the week next week for a company holiday, so you won’t hear back from us until after that. Thanks!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 02, 2019 Jul 02, 2019

Copy link to clipboard

Copied

Thanks, for the update. I'm noticing that the lockup tends to happen at the same time it auto-saves, which is after just about any time I make a change. I'm glad it's saving my progress but it's very inconvenient that I can't actually get any work done.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2019 Jul 10, 2019

Copy link to clipboard

Copied

Same exact issue, and same exact observation.

Brand new MacBook Pro. Lots of components. Super sluggish.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 11, 2019 Jul 11, 2019

Copy link to clipboard

Copied

Hi Nate.aguila,

Sorry for the trouble that you're facing with Adobe XD. I'd request you to please generate log files using the information provided in this document <How to use the Creative Cloud Log Collector tool > and also if you can share the file with me which has all the components that will be helpful. After the files have been generated, upload the files to a shared location such as Creative Cloud, and share the URL with me over a private message.

Please send the URL of this forum post for reference. To send a private message, click my profile picture and use the Message button.

Please let me know if you face any issues with this.

Thanks,

Harshika

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines