Bad performance on Windows since last update

Community Beginner ,
Mar 23, 2021 Mar 23, 2021

Copy link to clipboard

Copied

Hi,

Since last Windows or XD update, I'm having a very bad performance with Adobe XD on windows. It feels very slow, for example, when I'm zooming in and out, it's not smooth as it used to be. Render is blurred and pixelated until I'm done with zooming. Also, files with a large number of layers are very slow to work with now. When I try to transform these layer groups with hundreds of paths inside, it feels terribly slow. Almost like it doesn't utilize GPU at all.

 

And just an important note, before the update it was working completely fine, so my specs shouldn't be a problem, but I'll include it below.

 

XD version:

38.0.12

 

Windows:

Version 20H2 (OS Build 19042.879)

 

Nvidia driver version:

461.92

 

Specs:

Kingston HyperX 64GB 3200MHz

AMD Ryzen 7 3700X

Zotac Nvidia RTX 2070 Super AMP

A-DATA 1TB M.2 PCIe Gen 3 x4 NVMe ASX8200

TOPICS
Product performance

Views

152

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Mar 24, 2021 Mar 24, 2021
UPDATE:I downloaded and installed Nvidia Studio Drivers and it seems that problem is solved. It works now as before.

Likes

Translate

Translate
Community Beginner ,
Mar 24, 2021 Mar 24, 2021

Copy link to clipboard

Copied

LATEST

UPDATE:

I downloaded and installed Nvidia Studio Drivers and it seems that problem is solved. It works now as before.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines