Highlighted

Change the size of the preview window XD

New Here ,
May 27, 2016

Copy link to clipboard

Copied

I have a project with a lot of art boards. They have the size of 1280x1024. When I preview these after the latest update (0.5.4.51) I only see half of the window. I would like to have the ability to change the size of the preview window.

Just to clarify the current behavior...

In most cases, if you resize an existing artboard to be taller, it automatically turns into a scrolling artboard.  The original height will be the viewport size seen in the preview, and the new height will be the total height of the content that you can scroll around within that viewport.

So for example, in the original screenshot above you may have started with the "Web 1280" artboard size and then resized it taller -- it looks like it's 1280x1024 in the screenshot?  Whenever you select anything inside the artboard, you'll see a blue dotted line indicating the viewport height (and in the Preview window or web sharing view, you can use the mousewheel or trackpad to scroll vertically).

Automatically making a scrolling artboard is handy, but unfortunately it's not always what you want.  So, in our next update we'll give you options to turn scrolling on or off on any artboard.

In the meantime, if you want a taller artboard to just be tall -- never scroll -- then you can use this workaround:

  1. Select the artboard tool
  2. Drag to draw a new artboard as a custom size
  3. Optional: Type width/height values in the properties panel to get a more precise size
  4. Locate one of your old artboards that has unwanted scrolling turned on.  Marquee-select over the entire artboard to select everything on it, then cut-paste the content onto the new artboard.

Artboards that were drawn by dragging with the Artboard tool will never have scrolling auto turned on.  After step 3, you can use Cmd-D to duplicate the blank artboard you created if you have multiple old artboards to fix.

I know that workaround is a bit clunky -- but luckily it's temporary.  In our next release, you'll be able to select (or multi-select!) artboards and just turn off scrolling directly.

Hope that helps explain things!

TOPICS
How to, Preview

Views

12.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Change the size of the preview window XD

New Here ,
May 27, 2016

Copy link to clipboard

Copied

I have a project with a lot of art boards. They have the size of 1280x1024. When I preview these after the latest update (0.5.4.51) I only see half of the window. I would like to have the ability to change the size of the preview window.

Just to clarify the current behavior...

In most cases, if you resize an existing artboard to be taller, it automatically turns into a scrolling artboard.  The original height will be the viewport size seen in the preview, and the new height will be the total height of the content that you can scroll around within that viewport.

So for example, in the original screenshot above you may have started with the "Web 1280" artboard size and then resized it taller -- it looks like it's 1280x1024 in the screenshot?  Whenever you select anything inside the artboard, you'll see a blue dotted line indicating the viewport height (and in the Preview window or web sharing view, you can use the mousewheel or trackpad to scroll vertically).

Automatically making a scrolling artboard is handy, but unfortunately it's not always what you want.  So, in our next update we'll give you options to turn scrolling on or off on any artboard.

In the meantime, if you want a taller artboard to just be tall -- never scroll -- then you can use this workaround:

  1. Select the artboard tool
  2. Drag to draw a new artboard as a custom size
  3. Optional: Type width/height values in the properties panel to get a more precise size
  4. Locate one of your old artboards that has unwanted scrolling turned on.  Marquee-select over the entire artboard to select everything on it, then cut-paste the content onto the new artboard.

Artboards that were drawn by dragging with the Artboard tool will never have scrolling auto turned on.  After step 3, you can use Cmd-D to duplicate the blank artboard you created if you have multiple old artboards to fix.

I know that workaround is a bit clunky -- but luckily it's temporary.  In our next release, you'll be able to select (or multi-select!) artboards and just turn off scrolling directly.

Hope that helps explain things!

TOPICS
How to, Preview

Views

12.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 27, 2016 0
Adobe Employee ,
May 27, 2016

Copy link to clipboard

Copied

Hi there, c.alerius-

Were you able to see this before and are now unable to see the full screen? What is your screen's resolution? Are you trying to use full screen? Can you try resizing the Preview window? Also, we'd love to get a screenshot of what you're seeing to make sure we're seeing everything.

Thanks,

-Elaine

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 27, 2016 0
New Here ,
Jun 07, 2016

Copy link to clipboard

Copied

Hi elainecc,

Yes, before I updated the software I did'nt have this problem.

Well, My screen has 5k resolution. And I have tried in both full screen and not.

I have been in contact with your support team and they said that I cannot change this, unless I make a new project. But that would be too much work for this project, I will do a workaround, but I would love to have the possibility to change this in the future.

In the first screen shot you see the preview window, and in the second you see how the mockup is supposed to look.Experience1.pngExperience2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 07, 2016 0
Community Beginner ,
Jun 07, 2016

Copy link to clipboard

Copied

Hi there,

I'm looking into this issue for you. 1 question: are you using El Capitan?

Thanks,

Zoltan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 07, 2016 0
New Here ,
Jun 07, 2016

Copy link to clipboard

Copied

Hi,

Yes I'm using El Capitan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 07, 2016 0
Community Beginner ,
Jun 14, 2016

Copy link to clipboard

Copied

Hi there,

I wasn't able to reproduce the issue on my end. Is it possible that you can share the XD file with me?

Thanks,

Zoltan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 14, 2016 0
New Here ,
Jun 15, 2016

Copy link to clipboard

Copied

Okey, sure. Here it is. As you can see the top of the image doesn't fit. I would like to be able to set a custom size of the preview.

4059EE 1.7-2

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2016 0
Community Beginner ,
Jun 15, 2016

Copy link to clipboard

Copied

Could you share the XD file itself (or the affected artboards)? zhorvath@adobe.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2016 0
New Here ,
Jun 16, 2016

Copy link to clipboard

Copied

Ok, I have sent the file to you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 16, 2016 0
Community Beginner ,
Jun 16, 2016

Copy link to clipboard

Copied

I've got an answer for you.

The preview window represents the artboard size. In your case the content is clipped by the artboard, so the preview window will clip the content too. (Resizing the preview window doesn't modify the dimensions of the artboard, so that's the reason why you can't make the content visible by resizing the preview window.)

With the following steps you can easily modify all your artboard to match the dimensions of your content:

  • Zoom out and marquee select all your artboards. (all artboards will be selected)
  • Set the Height (H) value on the property inspector to the desired height. (all artboards will extend down)
  • Select all content with cmd+a.
  • Move the content down until it starts at the top of your artboards.
  • Preview window shouldn't clip the top of your content anymore.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 16, 2016 1
New Here ,
Jun 17, 2016

Copy link to clipboard

Copied

hi,

Thanks but thats not correct. When I resize the artboard i get a dotted line at the spot where the preview stops. I can resize the artboard but it doesn't effect the preview.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2016 0
New Here ,
Jun 26, 2016

Copy link to clipboard

Copied

Hello,
I have the same issue,

You can select all Your artboards and then change its mode (landscape/portrait), change it and then change it back again, this had helped me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2016 1
Community Beginner ,
Jul 28, 2016

Copy link to clipboard

Copied

c.alerius​, mastems

Thanks for reporting the issue again and your patience. We've changed the design and incorporated into Xd. The update that addresses your question will roll out with one of our upcoming releases.

Thanks,

Zoltan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 28, 2016 1
New Here ,
Jul 29, 2016

Copy link to clipboard

Copied

I'm running into this issue as well, and would love a solution to this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 29, 2016 0
Adobe Employee ,
Aug 29, 2016

Copy link to clipboard

Copied

Just to clarify the current behavior...

In most cases, if you resize an existing artboard to be taller, it automatically turns into a scrolling artboard.  The original height will be the viewport size seen in the preview, and the new height will be the total height of the content that you can scroll around within that viewport.

So for example, in the original screenshot above you may have started with the "Web 1280" artboard size and then resized it taller -- it looks like it's 1280x1024 in the screenshot?  Whenever you select anything inside the artboard, you'll see a blue dotted line indicating the viewport height (and in the Preview window or web sharing view, you can use the mousewheel or trackpad to scroll vertically).

Automatically making a scrolling artboard is handy, but unfortunately it's not always what you want.  So, in our next update we'll give you options to turn scrolling on or off on any artboard.

In the meantime, if you want a taller artboard to just be tall -- never scroll -- then you can use this workaround:

  1. Select the artboard tool
  2. Drag to draw a new artboard as a custom size
  3. Optional: Type width/height values in the properties panel to get a more precise size
  4. Locate one of your old artboards that has unwanted scrolling turned on.  Marquee-select over the entire artboard to select everything on it, then cut-paste the content onto the new artboard.

Artboards that were drawn by dragging with the Artboard tool will never have scrolling auto turned on.  After step 3, you can use Cmd-D to duplicate the blank artboard you created if you have multiple old artboards to fix.

I know that workaround is a bit clunky -- but luckily it's temporary.  In our next release, you'll be able to select (or multi-select!) artboards and just turn off scrolling directly.

Hope that helps explain things!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2016 0
New Here ,
Aug 25, 2016

Copy link to clipboard

Copied

The prototype mode only supports the sizes predefined by the XD app.

If you decide to design at 1080 x 1920 for an Android app for example, the prototype will clip the preview.

I don't think this was tested. But its pretty obvious to me. Shame on Adobe for releasing this feature without doing basic testing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 25, 2016 0
New Here ,
Dec 16, 2016

Copy link to clipboard

Copied

Hello--

Was the control to turn off scrolling ever implemented? I am working with the latest release and cannot find it.

--Jim

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2016 0
Adobe Employee ,
Dec 16, 2016

Copy link to clipboard

Copied

Hi, jimgasperini-

Yes, you can turn it off in the property inspector when you select the artboard. Turn the "scrolling" selection from Vertical to None to turn the scrolling off.

Screen Shot 2016-12-16 at 5.19.05 PM.png

Hope that helps,

-Elaine

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 16, 2016 1
New Here ,
Dec 18, 2018

Copy link to clipboard

Copied

I had the same problem, and all you have to do is open the same link in Chrome. This worked for me. My preview was also cut half way in Edge.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 18, 2018 0