Highlighted

Components Glitching in Preview Mode / Presenting

New Here ,
Feb 12, 2020

Copy link to clipboard

Copied

When creating complicated components (nesting, multiple states, or just multiple animations within one state), my components completely bug out in preview mode and sometimes within the design editor itself. They usually appear fine in the design section, but when tested they bug out by clipping/glitching layers together or layers appearing when they should have 0 Opacity, or things showing in the wrong place.

 

I've also noticed when these bugs occur, they sometimes effect the navigation of the app making it impossible to click "Prototype" or "Share" portions of the software.

 

Components seem very broken in this new version of XD. Never had this issue before. I am now having to dumb down my components and create different art boards instead of having everything in one art board (the only seeming work around). Totally unnacceptable. I want to keep using XD but these bugs are going to force me to switch to a different prototyping tool until addressed.

 

I've attached a screenshot of a hidden blue layer, clearly visible and clipping another layer when it should not be there.

 

Would love to know why this is happening and if something can be done in the mean time while this gets patched?

TOPICS
Preview, Product performance, Prototyping

Views

396

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Components Glitching in Preview Mode / Presenting

New Here ,
Feb 12, 2020

Copy link to clipboard

Copied

When creating complicated components (nesting, multiple states, or just multiple animations within one state), my components completely bug out in preview mode and sometimes within the design editor itself. They usually appear fine in the design section, but when tested they bug out by clipping/glitching layers together or layers appearing when they should have 0 Opacity, or things showing in the wrong place.

 

I've also noticed when these bugs occur, they sometimes effect the navigation of the app making it impossible to click "Prototype" or "Share" portions of the software.

 

Components seem very broken in this new version of XD. Never had this issue before. I am now having to dumb down my components and create different art boards instead of having everything in one art board (the only seeming work around). Totally unnacceptable. I want to keep using XD but these bugs are going to force me to switch to a different prototyping tool until addressed.

 

I've attached a screenshot of a hidden blue layer, clearly visible and clipping another layer when it should not be there.

 

Would love to know why this is happening and if something can be done in the mean time while this gets patched?

TOPICS
Preview, Product performance, Prototyping

Views

397

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 12, 2020 0
Preran LATEST
Adobe Employee ,
Feb 14, 2020

Copy link to clipboard

Copied

Apologize for your experience. Which version of Adobe XD are you on? The team has fixed some in XD 27 but several improvements are on their way. However, from what you said, it looks like you are facing these issues after an upgrade and everything worked as you liked in the previous version. If that is the case, I suggest getting in touch with our support team for investigation https://adobe.ly/2WYE62m

 

Let me know if you need more info or assistance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 14, 2020 1