Highlighted

Components pulled from assets panel do not look like the master component

New Here ,
Dec 30, 2019

Copy link to clipboard

Copied

Hi guys, 

I am working on a big project and I created a library (over 200 components) for my team to use. When we pull certain components from the assets panel they do not look like the original, however, when I duplicate the component from the master it shows up fine. This solution does not work because my library is used by many people.

 

For example: 

I created a tab bar that is to be used globally by my team but when we pull from the assets panel (on the original library or from a linked library) it will have extra tabs that are placed incorrectly (10-30 pixels off) or the font size will change, or it may populate two of the same component. 

 

I have also noticed that the components in the asset panels on the original library are displayed in the same incorrect way. But if you right-click and click "highlight on canvas" it shows you the correct master component that is not wonky.

 

I apologize if this is confusing but it is annoying every time we use a component it shows up wonky and you have to fix it manually. I wish I could show you the bug but it is confidential info. I am also not sure if I could recreate the bug as well.

 

Thanks in advance,

M

there are some problems if you have components with overrides inside your master components. for me creating different component states for every override fixed the issue.

TOPICS
Error, Other, Performance, Product issue

Views

592

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Components pulled from assets panel do not look like the master component

New Here ,
Dec 30, 2019

Copy link to clipboard

Copied

Hi guys, 

I am working on a big project and I created a library (over 200 components) for my team to use. When we pull certain components from the assets panel they do not look like the original, however, when I duplicate the component from the master it shows up fine. This solution does not work because my library is used by many people.

 

For example: 

I created a tab bar that is to be used globally by my team but when we pull from the assets panel (on the original library or from a linked library) it will have extra tabs that are placed incorrectly (10-30 pixels off) or the font size will change, or it may populate two of the same component. 

 

I have also noticed that the components in the asset panels on the original library are displayed in the same incorrect way. But if you right-click and click "highlight on canvas" it shows you the correct master component that is not wonky.

 

I apologize if this is confusing but it is annoying every time we use a component it shows up wonky and you have to fix it manually. I wish I could show you the bug but it is confidential info. I am also not sure if I could recreate the bug as well.

 

Thanks in advance,

M

there are some problems if you have components with overrides inside your master components. for me creating different component states for every override fixed the issue.

TOPICS
Error, Other, Performance, Product issue

Views

593

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 30, 2019 0
Adobe Community Professional ,
Dec 30, 2019

Copy link to clipboard

Copied

Any chance you could create some non-confidential assets so that you can create screenshots to show the results you're seeing?

Does everyone have the same version of XD?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 30, 2019 2
New Here ,
Jan 06, 2020

Copy link to clipboard

Copied

Hi,

Thanks for the response. If there is an email or someone from Adobe I can talk to directly in a closed thread I can send you screenshots. 

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 06, 2020 0
Community Beginner ,
Jun 26, 2020

Copy link to clipboard

Copied

I am on version 30.1.12.4 and I see this with just about any component I use. 
I have to copy/paste the component (in shared projects or the same file, it doesn't matter) as opposed to using the assets panel. 

This example isn't anything proprietary, so here's an easy example. 
Here's this icon component inside of my "browser header" component, this is the master component:

docutechc2626245_0-1593205914362.png
Here is a copy dragged from the assets panel:

docutechc2626245_1-1593205987315.png

but if I directly copy/paste the master:

docutechc2626245_2-1593206013558.png

(side note: the close icon only has one state, the default)

I can't tell you how frustrating this is, this coupled with all the other component state bugs has made them essentially useless.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2020 0
Explorer ,
Jan 02, 2020

Copy link to clipboard

Copied

there are some problems if you have components with overrides inside your master components. for me creating different component states for every override fixed the issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 02, 2020 2