Highlighted

[Design]-Component states doesn't get copied from one file into another in Adobe XD on macOS.

Community Beginner ,
Dec 17, 2019

Copy link to clipboard

Copied

I have a master design system file with a ton of components.

Most components have several states.

When I copy a component from the master design system file to a new file, in the new file only the "default" state is available. 

 

This problem occurs with some components, but not all.

 

Running XD 25.1.12.7 on macOS 10.15.2

 

Here is the component in the master file

Screen Shot 2019-12-17 at 10.23.05.png

And here is the component in the new file (only default state available)

Screen Shot 2019-12-17 at 10.26.20.png

 

<The Title was renamed by moderator>

Topics

Design, Product performance

Views

266

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

[Design]-Component states doesn't get copied from one file into another in Adobe XD on macOS.

Community Beginner ,
Dec 17, 2019

Copy link to clipboard

Copied

I have a master design system file with a ton of components.

Most components have several states.

When I copy a component from the master design system file to a new file, in the new file only the "default" state is available. 

 

This problem occurs with some components, but not all.

 

Running XD 25.1.12.7 on macOS 10.15.2

 

Here is the component in the master file

Screen Shot 2019-12-17 at 10.23.05.png

And here is the component in the new file (only default state available)

Screen Shot 2019-12-17 at 10.26.20.png

 

<The Title was renamed by moderator>

Topics

Design, Product performance

Views

267

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 17, 2019

Copy link to clipboard

Copied

Hi there,

 

We are sorry to hear you are having trouble copying components with component states into another document. I am unable to reproduce the behavior at my end on mac. Would you mind creating a new component with component states in a new document & paste into a another document?

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 08, 2020

Copy link to clipboard

Copied

Hi - in our UX team of three, we are having exactly the same problem. We are a small team but our work spans multiple applications across the healthcare organisation in which we work. To streamline our workload, we have created master files containing buttons, icons etc all with multiple states – we have spent days optimising these master files – however (and the results always vary), sometimes the components copy across containing all the states, and sometimes they just bring across the default state. Sometimes it's the same components that have worked previously that don't copy and then sometimes they copy across properly again. This sounds ridiculous I know, but if we quit Xd and attempt again the next day, often the components copy correctly (but that's not a realistic solution). Our only guess was that maybe we are 'super-users' in that our master files are densely populated with components and the each component may have 5 or more states, therefore adding a huge memory load to the app. This is a big concern for us. As a team we are stretched very thin and really need this feature to function properly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 08, 2020

Copy link to clipboard

Copied

Hi Nick, 

 

We understand it could be very frustrating for you. It shouldn't supposed to happen like that. Would you mind telling us the number of components you have in this file? What is the size of the file? Are you using the current version of XD (28.4)?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 09, 2020

Copy link to clipboard

Copied

Thanks for getting back so promptly Harshika.

  • We're all on auto-updates and using 28.4.14
  • The master component file (where I'm copying the components from) and that I'm currently experiencing problems with, is 2.7 MB in size (though we're all experiencing the same problem intermittently with different files similar to that described below)
  • The master component file above contains just over 160 components (mainly icons with different medical alert values).
    About 25 of these have a single state, so not a issue when copying.
    About 180 have three states (Default, Hover and Inactive, and are a single colour)
    The remainder (over 40 components) all have several states (sometimes as many as 20) and each state may use up to 3 colours. These are mainly the files that are causing problems when copied to other files

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 09, 2020

Copy link to clipboard

Copied

Thanks for sharing the additional details. It seems to be an issue with complex files. Is it possible for you to share the file with me over a private message so that I can investigate on it and escalate it to the team?

 

I will try my best to figure out the situation.

 

[Note]- Please share the link of this post for reference to PM.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
May 04, 2020

Copy link to clipboard

Copied

Hi Harshika, I have exactly the same problem when copying/pasting components with state from one file to another: When I copy a component from the master design system file to a new file, in the new file only the "default" state is available. 

I think this is a bug since it happens quite often. Do you have a solution for this? You can see how it happens here: https://www.loom.com/share/552f686bf04a43b08294c833767cb924

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...