Highlighted

[Design]-Component states doesn't get copied from one file into another in Adobe XD on macOS.

Community Beginner ,
Dec 17, 2019

Copy link to clipboard

Copied

I have a master design system file with a ton of components.

Most components have several states.

When I copy a component from the master design system file to a new file, in the new file only the "default" state is available. 

 

This problem occurs with some components, but not all.

 

Running XD 25.1.12.7 on macOS 10.15.2

 

Here is the component in the master file

Screen Shot 2019-12-17 at 10.23.05.png

And here is the component in the new file (only default state available)

Screen Shot 2019-12-17 at 10.26.20.png

 

<The Title was renamed by moderator>

[EDITED] it worked when I did this: I saved the XD file into my local machine. Then, copied the component to a new XD file. I was copying the component with a file that was not saved in my machine... it was the history file from the Adobe cloud. And don't forget to create a local component, because when I copied, it linked the component to the other file.

[EDIT]: it's not copying the component states, if the XD file is not saved in a local machine. If it's, it copies... but anyway, the issue continues if we don't save the XD file, like a history file when we're just previewing it.

TOPICS
Design, Product performance

Views

535

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

[Design]-Component states doesn't get copied from one file into another in Adobe XD on macOS.

Community Beginner ,
Dec 17, 2019

Copy link to clipboard

Copied

I have a master design system file with a ton of components.

Most components have several states.

When I copy a component from the master design system file to a new file, in the new file only the "default" state is available. 

 

This problem occurs with some components, but not all.

 

Running XD 25.1.12.7 on macOS 10.15.2

 

Here is the component in the master file

Screen Shot 2019-12-17 at 10.23.05.png

And here is the component in the new file (only default state available)

Screen Shot 2019-12-17 at 10.26.20.png

 

<The Title was renamed by moderator>

[EDITED] it worked when I did this: I saved the XD file into my local machine. Then, copied the component to a new XD file. I was copying the component with a file that was not saved in my machine... it was the history file from the Adobe cloud. And don't forget to create a local component, because when I copied, it linked the component to the other file.

[EDIT]: it's not copying the component states, if the XD file is not saved in a local machine. If it's, it copies... but anyway, the issue continues if we don't save the XD file, like a history file when we're just previewing it.

TOPICS
Design, Product performance

Views

536

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 17, 2019 3
Adobe Employee ,
Dec 17, 2019

Copy link to clipboard

Copied

Hi there,

 

We are sorry to hear you are having trouble copying components with component states into another document. I am unable to reproduce the behavior at my end on mac. Would you mind creating a new component with component states in a new document & paste into a another document?

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 17, 2019 0
New Here ,
Apr 08, 2020

Copy link to clipboard

Copied

Hi - in our UX team of three, we are having exactly the same problem. We are a small team but our work spans multiple applications across the healthcare organisation in which we work. To streamline our workload, we have created master files containing buttons, icons etc all with multiple states – we have spent days optimising these master files – however (and the results always vary), sometimes the components copy across containing all the states, and sometimes they just bring across the default state. Sometimes it's the same components that have worked previously that don't copy and then sometimes they copy across properly again. This sounds ridiculous I know, but if we quit Xd and attempt again the next day, often the components copy correctly (but that's not a realistic solution). Our only guess was that maybe we are 'super-users' in that our master files are densely populated with components and the each component may have 5 or more states, therefore adding a huge memory load to the app. This is a big concern for us. As a team we are stretched very thin and really need this feature to function properly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2020 0
Adobe Employee ,
Apr 08, 2020

Copy link to clipboard

Copied

Hi Nick, 

 

We understand it could be very frustrating for you. It shouldn't supposed to happen like that. Would you mind telling us the number of components you have in this file? What is the size of the file? Are you using the current version of XD (28.4)?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2020 0
New Here ,
Apr 09, 2020

Copy link to clipboard

Copied

Thanks for getting back so promptly Harshika.

  • We're all on auto-updates and using 28.4.14
  • The master component file (where I'm copying the components from) and that I'm currently experiencing problems with, is 2.7 MB in size (though we're all experiencing the same problem intermittently with different files similar to that described below)
  • The master component file above contains just over 160 components (mainly icons with different medical alert values).
    About 25 of these have a single state, so not a issue when copying.
    About 180 have three states (Default, Hover and Inactive, and are a single colour)
    The remainder (over 40 components) all have several states (sometimes as many as 20) and each state may use up to 3 colours. These are mainly the files that are causing problems when copied to other files

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2020 0
Adobe Employee ,
Apr 09, 2020

Copy link to clipboard

Copied

Thanks for sharing the additional details. It seems to be an issue with complex files. Is it possible for you to share the file with me over a private message so that I can investigate on it and escalate it to the team?

 

I will try my best to figure out the situation.

 

[Note]- Please share the link of this post for reference to PM.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2020 0
Explorer ,
Jul 13, 2020

Copy link to clipboard

Copied

[EDIT]: it's not copying the component states, if the XD file is not saved in a local machine. If it's, it copies... but anyway, the issue continues if we don't save the XD file, like a history file when we're just previewing it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2020 0
Explorer ,
Jul 13, 2020

Copy link to clipboard

Copied

Harshika,

take a look how to reproduce this problem that widiantoz posted below:
https://www.loom.com/share/552f686bf04a43b08294c833767cb924

 

This is a serious problem! The component states are not being copied to a new file.

 

I made a mistake, when centralizing one object, and it selected all objects from the project(well, I made it fast, but XD was "saving" and it got confused, freezed and when it got back, all objects were centralized, a complete disaster!)... Adobe XD freezed, and I couldn't rollback because it restarted XD. I had a lot of work to copy a previous version of the file... it's another issue with XD: we can't rollback a previous version, just by selecting the version. We have to copy and paste - but this is not so practical. It should be easier if we just select the version we want and all it's done. As the components states are not being copied, PLUS the issue about duplicated components, I gave up and now I'll create a new link with the previous file from history. It's so frustrating, and I have to tell all my team to disconsider the old link and use the new one... people start to get angry because of this! Another isse is the auto "saving...": XD freezes while saving, and when it get back, it's a mess... there's too delay with the actions while it's saving. The auto "saving..." is not so good when doing fast commands like CTRL + A... for twice, it selected all objects in the project I'm working. And I had to create new links, because it's a big project, and it didn't rollback.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2020 0
Explorer ,
May 04, 2020

Copy link to clipboard

Copied

Hi Harshika, I have exactly the same problem when copying/pasting components with state from one file to another: When I copy a component from the master design system file to a new file, in the new file only the "default" state is available. 

I think this is a bug since it happens quite often. Do you have a solution for this? You can see how it happens here: https://www.loom.com/share/552f686bf04a43b08294c833767cb924

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2020 1
Explorer ,
Jul 13, 2020

Copy link to clipboard

Copied

I discovered it today... and I lost the project. Had to rollback to an older version and created a new link. This is really bad! Did you have to rollback to a previous version of the file? It's not practical: you have to copy and paste all the project... WTF! And now, with this issue with component states being not copied, it's useless... I'm so angry and frustrated with XD! I don't know why I don't migrate to Figma or ask to my company buy a Mac to use Sketch! lol

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2020 0
Explorer ,
Jul 13, 2020

Copy link to clipboard

Copied

[EDITED] it worked when I did this: I saved the XD file into my local machine. Then, copied the component to a new XD file. I was copying the component with a file that was not saved in my machine... it was the history file from the Adobe cloud. And don't forget to create a local component, because when I copied, it linked the component to the other file.

[EDIT]: it's not copying the component states, if the XD file is not saved in a local machine. If it's, it copies... but anyway, the issue continues if we don't save the XD file, like a history file when we're just previewing it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 13, 2020 1
Community Beginner ,
Sep 01, 2020

Copy link to clipboard

Copied

Since recently we noticed our components lose their states if we compy them from our master file to a mock-up. It does not happen to all components, just certain ones. I think it mostly happens, if the component is also used as a base for a more complex component.

For example, we do have a box as a component with different states and use it in combination with text in an other component to make the common forumlar checkbox.

 

As you can see in the video, we have the checkbox with states in the master file, but after compying it to another file, it looses its states. 

 

components-bug.gif

 

Please fix this isse!
Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2020 0
Adobe Employee ,
Sep 01, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear you are having trouble copying the component with states in an XD file. I found similar post describing the same issue: https://community.adobe.com/t5/adobe-xd/design-component-states-doesn-t-get-copied-from-one-file-int...

 

Please check the post and try the suggestion in the correct answer to the post.

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2020 0
Community Beginner ,
Sep 01, 2020

Copy link to clipboard

Copied

Hi Harshika,

 

thank you for your quick response. I checked the solution but it did not work for me. Some components still lose their state. The only way to re-gain it, is to make a quick change in the parent component, this way the child component in the other file gains its states back (as if it remembers).

 

However, for our colleagues who are not as skilled in XD as our team and who just want to use the mock ups, it is quite annoying.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 01, 2020 1
New Here ,
Sep 03, 2020

Copy link to clipboard

Copied

This is still happening in version 32.1.22.3 on mac. It works if I create a new document and paste there but that is not a solution. I cannot move everything over to a new doc, I would lose too much. This is a serious bug!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 03, 2020 0
Adobe Employee ,
Sep 06, 2020

Copy link to clipboard

Copied

Hi there,

 

I am sorry to hear you are still experiencing the issue with copying components states in XD. We have the current version of XD 32.2. Could you please update and let us know if that helps?

 

I will try my best to escalate the issue.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 06, 2020 0