Highlighted

[Design]-Editing Component Breaks States and Animations in XD.

Community Beginner ,
Nov 19, 2019

Copy link to clipboard

Copied

I am currently designing a mobile phone app. The app has a hamburger menu. Pressing the icon reveals the slide over menu with a state change and an animation.

 

If I were to choose the default state, and group two layers together then it would break the display of all the elements in the "display menu" state.

 

The menu is off the screen. Elements are scattered randomly all over the place. 

 

In my mind, if I group layers in the defaut state, it should group those layers for all states and that way the auto-animation doesn't break. I have no idea why elements would be randomly positioned all over the place after grouping two layers.

 

This seems like a bug by the odd nature of the positioning of the elements.

 

<The Title was renamed by moderator>

TOPICS
Design, Product performance

Views

128

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

[Design]-Editing Component Breaks States and Animations in XD.

Community Beginner ,
Nov 19, 2019

Copy link to clipboard

Copied

I am currently designing a mobile phone app. The app has a hamburger menu. Pressing the icon reveals the slide over menu with a state change and an animation.

 

If I were to choose the default state, and group two layers together then it would break the display of all the elements in the "display menu" state.

 

The menu is off the screen. Elements are scattered randomly all over the place. 

 

In my mind, if I group layers in the defaut state, it should group those layers for all states and that way the auto-animation doesn't break. I have no idea why elements would be randomly positioned all over the place after grouping two layers.

 

This seems like a bug by the odd nature of the positioning of the elements.

 

<The Title was renamed by moderator>

TOPICS
Design, Product performance

Views

129

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 19, 2019 0
Adobe Employee ,
Feb 05, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry for the delay in response. Would you mind confirming if you're still experiencing the same in the latest version of XD? If yes, we would request you to please share a short video of the workflow.

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 05, 2020 1
ahazel82 LATEST
Community Beginner ,
Feb 07, 2020

Copy link to clipboard

Copied

I think this has been resolved with the latest updates to Adobe XD, thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2020 0