Highlighted

[Design]Really nasty bug - curve anchor handle disappears

Explorer ,
Mar 02, 2020

Copy link to clipboard

Copied

Hey guys,

This is a very nasty bug I am encountering, which makes drawing a total pain in the bottocks.

These are the steps to reproduce it:

1. Draw a rectangle

2. Double click it to turn it into a path

3. Select the top left anchor point and double click it to make it a curve

4. Select the right handle and hit DELETE to remove it.

RESULT: the left handle gets removed as well.

 

This bug makes it incredibily difficult to draw shapes, I have to use other apps to make shapes and import them into XD, when I could easily use XD if it wasn't for this ugly bug.

 

I also uploaded a video of the bug.

 

Please fix it asap 🙂

 

Thank you for such a great tool 🙂

Chris

 

I also

Adobe Community Professional
Correct answer by Peter Villevoye | Adobe Community Professional

For what it's worth, I tried it on my Windows (with version v28) and it functions correctly (also on Mac). Only one handle is deleted and the otrher remains. So there must be something wrong with the user's system or installation. Maybe a clean install of XD might help ?

TOPICS
Design, Product performance

Views

487

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

[Design]Really nasty bug - curve anchor handle disappears

Explorer ,
Mar 02, 2020

Copy link to clipboard

Copied

Hey guys,

This is a very nasty bug I am encountering, which makes drawing a total pain in the bottocks.

These are the steps to reproduce it:

1. Draw a rectangle

2. Double click it to turn it into a path

3. Select the top left anchor point and double click it to make it a curve

4. Select the right handle and hit DELETE to remove it.

RESULT: the left handle gets removed as well.

 

This bug makes it incredibily difficult to draw shapes, I have to use other apps to make shapes and import them into XD, when I could easily use XD if it wasn't for this ugly bug.

 

I also uploaded a video of the bug.

 

Please fix it asap 🙂

 

Thank you for such a great tool 🙂

Chris

 

I also

Adobe Community Professional
Correct answer by Peter Villevoye | Adobe Community Professional

For what it's worth, I tried it on my Windows (with version v28) and it functions correctly (also on Mac). Only one handle is deleted and the otrher remains. So there must be something wrong with the user's system or installation. Maybe a clean install of XD might help ?

TOPICS
Design, Product performance

Views

488

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 02, 2020 0
Adobe Employee ,
Mar 02, 2020

Copy link to clipboard

Copied

Hi Cristian_banu,

 

I understand how frustrated this could be, I'll try my best to assist you here. Thank you for sharing the steps and the video. I'd like to inform you that I have shared your feedback with the product team. I'll update this discusison as soon as I hear anything from the team.

 

Thanks,

Atul_Saini

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2020 1
Explorer ,
Mar 04, 2020

Copy link to clipboard

Copied

Hi Atul

Thanks a lot, I really appreciate it 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 0
Explorer ,
Mar 15, 2020

Copy link to clipboard

Copied

Any news about this bug? XD received 2 updates since I reported this bug, and it's still there.

Thank you,

Chris

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 15, 2020 0
Adobe Community Professional ,
Mar 16, 2020

Copy link to clipboard

Copied

For what it's worth, I tried it on my Windows (with version v28) and it functions correctly (also on Mac). Only one handle is deleted and the otrher remains. So there must be something wrong with the user's system or installation. Maybe a clean install of XD might help ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 16, 2020 1