Highlighted

Disable Auto Resizing Component Bounds

New Here ,
Dec 11, 2019

Copy link to clipboard

Copied

I just updated Adobe XD and it appears, they're automatically setting the component bounds to fit the content which is great is some scenarios but I have an existing project where I intentionally left empty space in components (e.g. for padding, spacing) and it's not even allowing me to turn this on/off like Sketch does. Now if I make any change to these elements, it automatically gets rid of all that space. I've tried manually resizing and turning the Responsive Resize on/off but to no avail.

 

I've also tried putting an invisible background layer behind it, but that layer doesn't get automatically get resized so if, for example, your text runs longer than the invisible background layer, there's not padding on the end. (And yes, this background layer is pinned to the edges, which in Sketch would make it resize with the whole object).

 

So to summarise, my issues are that a) It's indiscriminate b) it doesn't recognise padding. Is there a way to get around this? Is there a way to, at the very least, make it behave as before?  

Thanks!

Not the exact thing, but I found a similar request here https://adobexd.uservoice.com/forums/353007-adobe-xd-feature-requests/suggestions/33680956-disable-resizing-font-size-when-resizing-group If it doesn't match yours, I suggest creating a separte request using this link https://adobexd.uservoice.com/ 

TOPICS
Missing feature, Product issue

Views

291

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Disable Auto Resizing Component Bounds

New Here ,
Dec 11, 2019

Copy link to clipboard

Copied

I just updated Adobe XD and it appears, they're automatically setting the component bounds to fit the content which is great is some scenarios but I have an existing project where I intentionally left empty space in components (e.g. for padding, spacing) and it's not even allowing me to turn this on/off like Sketch does. Now if I make any change to these elements, it automatically gets rid of all that space. I've tried manually resizing and turning the Responsive Resize on/off but to no avail.

 

I've also tried putting an invisible background layer behind it, but that layer doesn't get automatically get resized so if, for example, your text runs longer than the invisible background layer, there's not padding on the end. (And yes, this background layer is pinned to the edges, which in Sketch would make it resize with the whole object).

 

So to summarise, my issues are that a) It's indiscriminate b) it doesn't recognise padding. Is there a way to get around this? Is there a way to, at the very least, make it behave as before?  

Thanks!

Not the exact thing, but I found a similar request here https://adobexd.uservoice.com/forums/353007-adobe-xd-feature-requests/suggestions/33680956-disable-resizing-font-size-when-resizing-group If it doesn't match yours, I suggest creating a separte request using this link https://adobexd.uservoice.com/ 

TOPICS
Missing feature, Product issue

Views

292

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 11, 2019 0
Adobe Employee ,
Dec 11, 2019

Copy link to clipboard

Copied

Not the exact thing, but I found a similar request here https://adobexd.uservoice.com/forums/353007-adobe-xd-feature-requests/suggestions/33680956-disable-r... If it doesn't match yours, I suggest creating a separte request using this link https://adobexd.uservoice.com/ 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 1
chrisenn LATEST
New Here ,
Dec 11, 2019

Copy link to clipboard

Copied

Ok, done. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 1