Highlighted

Drag trigger stopped working

Community Beginner ,
Aug 06, 2020

Copy link to clipboard

Copied

Hi! I was animating a slide menu using the drag trigger + auto animate from one artboard to another. It was working just fine, until i started wiring buttons from withing the menu itself. Now, I can`t see the drag effect on the preview mode, both on my computer and on the XD app on my android. I tried re-wiring everything but it still doesn't work. I can`t figure it out if it`s an sudden bug with the preview or if i messed something up by wiring other elements (i tried deleting all wires and start from scratch with the drag animation, but it's still not working.)

 

thank you very much!

Views

102

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Drag trigger stopped working

Community Beginner ,
Aug 06, 2020

Copy link to clipboard

Copied

Hi! I was animating a slide menu using the drag trigger + auto animate from one artboard to another. It was working just fine, until i started wiring buttons from withing the menu itself. Now, I can`t see the drag effect on the preview mode, both on my computer and on the XD app on my android. I tried re-wiring everything but it still doesn't work. I can`t figure it out if it`s an sudden bug with the preview or if i messed something up by wiring other elements (i tried deleting all wires and start from scratch with the drag animation, but it's still not working.)

 

thank you very much!

Views

103

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Aug 06, 2020

Copy link to clipboard

Copied

Hello,

 

Hi,

 

I have the same problem. I deleted everything and i did it again but it still doesn't work.

 

Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 06, 2020

Copy link to clipboard

Copied

what also happened is that before my auto animate really had the 'sliding from one thing to the other effect', now everything i autoanimate briefly fades and appears as the other element. i`ve included a video showing my desired result. I've changed the 'tap' effect to drag, and it was working with this same effect! now i can't seem to make it work again.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 06, 2020

Copy link to clipboard

Copied

Hi Clara and Eden,

 

This is definitely strange. The attached video shows the XD tutorial it doesn't look like the correct video. Could you please check again and share the video again? Please share the OS and XD version of your machine. Is it happening with every file or with specific file?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 06, 2020

Copy link to clipboard

Copied

Hi Harshina! Thank you for your reply.

The video linked in my post is correct! I was trying to achieve that same slide in/slide out effect, but using a drag trigger. I have a windows computer, with XD version 31.2.12.

 

I created a new file and made an example interaction. The drag trigger is very stiff, and the rectangle fades for a moment before appearing completly. Before, in my original file, I was able to create a nice slide up effect using the drag trigger and autoanimate, and got a result similar to the one on the video, But suddently it stopped working.

 

thanks!Adobe XD 2020-08-06 20-35-08_1.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 06, 2020

Copy link to clipboard

Copied

Here is a new way to drag. I will try tomorrow .
Very easy .

https://youtu.be/EDOnqkDKEAY

--
Eden Sahilé

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 13, 2020

Copy link to clipboard

Copied

Hi Clara,

 

I am sorry for the delay in response. I tried to use drag with auto animate and it worked fine at my end on windows machine. Could you please check out this link: https://xd.adobe.com/view/c2614b34-1555-4470-a42a-eccdbdff0653-9732/?

 

Would you mind signing out of XD and Creative Cloud, restart the machine and then sign back in? 

 

Let me know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 10, 2020

Copy link to clipboard

Copied

Same problem here. I tried to put a drag trigger between two artboards and it just doesn't work in preview mode and on the app. Wtf is going on ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Aug 13, 2020

Copy link to clipboard

Copied

Hi Alexandre,

 

Sorry for the trouble you're facing with drag trigger. Is it possible for you to share a short video of your workflow for better understanding so that I can follow the same workflow at my end and test? What is the OS and XD version of your machine?

 

I will try my best to investigate on the issue.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...