Elements in component states jump around in prototype

Community Beginner ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

In the editor, my component looks just as I'd expect. 

In preview and posted prototypes, the elements in the component jump around between states.

 

I started out with a nested component to get the menu I needed but simplified things to try and make things easier on XD. I've been banging my head against the wall on this for close to an hour, trying every variation I can think of. Nothing seems to make a difference. 

 

This is the second time I've hit this behavior with XD in the last week. For the last one, I just gave up and created an old school static representation of each state for my team. Cutting edge.

 

Here's the states in design mode. Gif compression wiped out most of the differences, but you get the idea. The "more" button is not part of the component.

 

xd--good-states.gif

And here's how it behaves in Preview mode and shared prototypes.

 

xd--bad-proto.gif

Views

96

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 20, 2021 Jul 20, 2021

Copy link to clipboard

Copied

LATEST

( Apparently, I can't edit my post … )

 

I should note that the "fixed size" text tweak that seems to work when the text moves vertically, did not help me in this situation. I also tried getting rid of auto-animate -- that makes the text flash as if the layer is being turned off.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines