Highlighted

Exported asset not included in shared prototype

Advocate ,
Aug 25, 2020

Copy link to clipboard

Copied

I have selected a vector icon for export (Mark for Export) and shared the prototype for development, but the icon is not available for download in the assets panel. The icon is in the prototype, I can select it in code wiev but it's not for download. Why? I've tried numerous times but it doesn't work.

Views

43

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Exported asset not included in shared prototype

Advocate ,
Aug 25, 2020

Copy link to clipboard

Copied

I have selected a vector icon for export (Mark for Export) and shared the prototype for development, but the icon is not available for download in the assets panel. The icon is in the prototype, I can select it in code wiev but it's not for download. Why? I've tried numerous times but it doesn't work.

Views

44

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

Hey there.

Can you please add a screenshot of the layers panel while in Design mode, where you marked it for export? Please also expand any groups it might contain, so we can see the layer hierarchy.

Secondly, make a screenshot while in the Share tab, where we can see the export settings for the link on the right side.

If you can share the specs link for the prototype as well, that would be great, or if it's sensitive info, just a screen of the right side of the prototype opened in the browser, where the icon should be available to download.

Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advocate ,
Aug 25, 2020

Copy link to clipboard

Copied

I'm not at liberty to share my files due to strict company policy but this is the UI sections you are refferring to. Everything is as normal and every other asset in my prototype is shared but not this one icon I'm referring to.

I have also discovered that the CC prototype area is buggy and instable. Sometimes it gives me a code spec icon (brackets) to click to see code view, other times just clicking the prototype will switch the view to codeview but then the codeview icon is gone from the right menu in the CC UI! It's buggy in typical Adobe style. Is Adobe in a process to change the way the CC prototype work? It's on and off all the time like this. Sometimes three menu icons and back to two. Then it has bracket icon and then suddenly not.

 

asset01.png

asset03.png

asset02.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

On the icon, I see it's a linked component. If you unlink it, does that fix the issue? I know that's not supposed to be a problem, but just try it so we can pinpoint why it's happening. Are any of the other assets that export fine linked components as well?

 

One more experiment - copy the linked icon in a new blank document, make a dev link, and see if it exports then, so we can see if the issue is tied to that file specifically, or it happens with any file this icon is linked in.

 

On the other stuff, I haven't presonally seen problems with these things, but it's not hard to believe. I imagine they will be releasing some big update for Adobe MAX in October, as usual, and I hope many of these issues will be taken care of, at least to some extent. But who knows. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Advocate ,
Aug 25, 2020

Copy link to clipboard

Copied

The icon is a component, so unlinking it will break the dynamic properties it carries. However, suddenly it appeared in the asset panel for download in codespec view. I didn't do anything to achive that, it just happened. This is why I suspect a bug here. Sometimes I get the bracket icon in the workspace menu in the prototype section and other times I don't. Suddenly assets appear in the asset panel and sometimes they don't. Sometimes I select one instance of an icon used 12 places in the same artboard (download icon for instance) and suddenly ALL instances appear in the asset panel in the CC prototype section, like I selected all of them for export, but I never did. It's a never ending story of instability and oddities really.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...