Highlighted

Linear gradient not imported to XD

Community Beginner ,
Feb 19, 2020

Copy link to clipboard

Copied

Hi,

I am running into a problem importing an AI graphic to XD. The radial gradient is imported, but the linear gradient is displayed as solid color, although in the inspector on the right siede side the fill says gradient. It is supposed to be in the sword.

Does anybody know ho to fix this?

 

Thank you!

 

FridaScreen Shot 2020-02-19 at 15.55.24.png

TOPICS
Design

Views

521

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Linear gradient not imported to XD

Community Beginner ,
Feb 19, 2020

Copy link to clipboard

Copied

Hi,

I am running into a problem importing an AI graphic to XD. The radial gradient is imported, but the linear gradient is displayed as solid color, although in the inspector on the right siede side the fill says gradient. It is supposed to be in the sword.

Does anybody know ho to fix this?

 

Thank you!

 

FridaScreen Shot 2020-02-19 at 15.55.24.png

TOPICS
Design

Views

522

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 19, 2020 1
Adobe Community Professional ,
Feb 19, 2020

Copy link to clipboard

Copied

I've tried pasting and importing two elements with linear and radial gradient, and they both work fine. So there must be someting intricate in the content you've created. Any weirdly grouped or compound element, a funky clipping mask, or a transparancy mask in it, not doing anything else but unnecissarily increasing the complexity ?

 

Schermafbeelding 2020-02-20 om 08.16.51.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 19, 2020 1
Community Beginner ,
Feb 20, 2020

Copy link to clipboard

Copied

Hi Peter,

thank you so much for replying. No, nothing fancy like clipping masks or so. Just that the linear gradient is angled and not vertical. I tried the unite tool in the pathfinder before exporting the asset, as somebody in this forum suggested and that worked miraculously. Obviously angled gradients are not expeorted/ imported properly otherwise. Weird?! 

Thank you!

 

Frida

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 0
Adobe Community Professional ,
Feb 20, 2020

Copy link to clipboard

Copied

I just tested an angular linear gradient and it still worked fine, both as a Paste and an Import. So there must be something else at play here...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 1
Community Beginner ,
Feb 20, 2020

Copy link to clipboard

Copied

Oh that is so weird. I have no idea what it could be. I copy pasted and imported only the sword, without the other graphics and it is still doing it. Huh.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 0
Adobe Community Professional ,
Feb 20, 2020

Copy link to clipboard

Copied

Did you move the gradient around inside the shape? Can you show the complete object with visible gradient annotator in Illustrator?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 1
Community Beginner ,
Feb 20, 2020

Copy link to clipboard

Copied

Hello Monika,

yes, I did. I will attach the screenshot. Thank you!

 

FridaScreen Shot 2020-02-20 at 12.37.35.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 0
Adobe Community Professional ,
Feb 20, 2020

Copy link to clipboard

Copied

I'm not sure if Xd supports moving around a gradient like you can do in Illustrator.

So can you try if it's possible to achieve the sane with just using the gradient panel, the rotate angle and the gradient stops?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 1
Adobe Community Professional ,
Feb 21, 2020

Copy link to clipboard

Copied

Ha ! Monika in da House 🙂

Adobe XD accepts various kinds of gradients from Illustrator very well, both as pasted and imported graphic, with multiple colors, shifts in balance, and even opacity levels. So it must be something with the overall construction of that particular shape, causing XD to mis-interprete the Fill.

 

Schermafbeelding 2020-02-21 om 10.43.11.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2020 0
Community Beginner ,
Feb 21, 2020

Copy link to clipboard

Copied

Haha, yes Monika helped me out multiple times when I started to learn Illustrator in 2017 🙂  Its getting even weirder. The solution you suggested Monika fixed the gradient ont the sword, thank you!  But the little end of the hilt, nope, still not showing the gradient. Here the solution helped, that Khaledi suggested, switch to radial and back to linear and tataa, there is the gradient. (3rd Sword) Weird!

Screen Shot 2020-02-21 at 04.38.32.pngScreen Shot 2020-02-21 at 04.16.00.pngScreen Shot 2020-02-21 at 04.19.20.png 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2020 0
Adobe Community Professional ,
Feb 21, 2020

Copy link to clipboard

Copied

So the issue originates in Illustrator, though it doesn't seem to cause a problem in Illustrator or similar (probably Postscript/PDF capable) environments. Would be nice and wise if the Adobe XD developers could get the problematic part of your drawing, for a closer examination. This is and will be happening more often...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2020 0
Community Beginner ,
Feb 21, 2020

Copy link to clipboard

Copied

I am happy to upload or share the .ai file to the developers if I know where to upload it.. 

Thank you all for your help!! At least I found two solutions to fix the problem in XD with the help here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2020 0
Adobe Community Professional ,
Feb 22, 2020

Copy link to clipboard

Copied

Perhaps some one like Preran reads this and will leave a reply or contact you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2020 0
Community Beginner ,
Mar 03, 2020

Copy link to clipboard

Copied

Thank you Peter, nobody has contaced me yet, but I will message Preran.

Best

 

Frida

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0
Explorer ,
Feb 20, 2020

Copy link to clipboard

Copied

I also have this issue time to time, normally helps to switch to radial gradient in XD and then back to linear and after that normally you can see all gradients colors

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 2
Community Beginner ,
Feb 20, 2020

Copy link to clipboard

Copied

Oh! Thank you! I will definitely try that 🙂

 

Frida

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2020 0
Community Beginner ,
Sep 29, 2020

Copy link to clipboard

Copied

Experiencing the same problem and here's how I solve it for now..

Nik5E22_0-1601386713436.png

Here's how it look on Adobe Illustrator. Here's how it looked on XD when pasted / imported.

Nik5E22_1-1601386759863.png

 

Make sure to compound path gradient elements in your illustration. I asure you it works.. Here a link on what are compound paths. (It's easy as right clicking and making it a compound path)

 

Here's how it look on illustrator when I make the gradient shape to a compound path.
Right click then press Make Compound Path

 

After that try pasting on XD it should work 100% .. I got this solution while exploring on XD on how to truly save this because I have an urgent project in UI UX xD.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2020 1
Community Beginner ,
Oct 11, 2020

Copy link to clipboard

Copied

Thank you so much! I will definitely try that! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 11, 2020 0
Community Beginner ,
Oct 26, 2020

Copy link to clipboard

Copied

Same issue here.

I tried the compound solution but it didn´t work, maybe because i have a gradient go through different shapes (letters).
The quick solution I found was to save the vector as SVG, on a different file.
Dragged the SVG into my XD composition and it worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 26, 2020 0
Explorer ,
Nov 05, 2020

Copy link to clipboard

Copied

I have the same problem. I tested it with a simple figure and the result is the same. I hope they solve it soon, because it is quite annoying.

DanielBlazquez_0-1604577649433.png

 

DanielBlazquez_1-1604577657424.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2020 0
Adobe Community Professional ,
Nov 05, 2020

Copy link to clipboard

Copied

Your problem is not the same, because importing or pasting elements with linear or radial gradients into XD work fine !! So there must be something strange with your sample... 

When copying/pasting doesn't seem to work, then check this setting in the Preferences (it's in Dutch, but I hope tou can find and verify it). It defines what is brought over by the clipboard:

Schermafbeelding 2020-11-05 om 22.28.10.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2020 0
Explorer ,
Nov 06, 2020

Copy link to clipboard

Copied

Hi Peter. I have the same settings. It is a clean file from Illustrator and XD. It stopped working when updating to v25. 

 

PD: There is a new version. Let's cross our fingers and see if it has been fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2020 0