Mouse zooming scroll direction is reversed.

Community Beginner ,
Oct 16, 2020 Oct 16, 2020

Copy link to clipboard

Copied

In XD, when zooming with my external mouse on my macbook pro, normally I hold Command+Scroll Up to zoom in. This works fine in photoshop. However, in XD, it zooms out instead of zooming in. Scrolling the page goes in the correct direction, it's only reversed while zooming.

 

I understand macs in general have scrolling issues. OSX has been stupid for a long time about external mice scroll direction. As such, I use the Scroll Reverser app to reverse the scroll of my mouse, while preserving natural scrolling for the track pad. This works fine in every other application I've used, including Photoshop, but it looks like XD has a bug with this. 

 

On a related note, XD should really support scroll zooming without holding Command. Photoshop supports this, and it's the standard for every CAD application.

 

Macbook Pro 16in 2019

OSX: Catalina 10.15.7

XD Version: 33.1.12.4 (Starter), Creative Cloud Sync 4.3.60.8

Views

410

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

Hi frodo2975, 

 

Thank you for sharing your feedback about the zoom tool, we'll share it with the product team. Would you mind using the Option key + scroll-wheel for zooming in and out and let us know if that makes any changes to your workflow?  

 

Thanks,

Atul_Saini

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 19, 2020 Oct 19, 2020

Copy link to clipboard

Copied

Thanks Atul. Using the Option+Scoll Wheel does the same thing as Command+Scroll Wheel for me, so unfortunately it's still reversed.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

I'm experiencing the same thing. It has been fine for a while, but now it suddenly changed out of the blue.

Please give us access to preferences.

 

MacBook Pro (15-inch, 2016)

Mac OS: Big Sur 11.2

XD: 36.2.32.5, Creative Cloud Sync 4.5.1.1

 

Best Regards

Rasmus

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 17, 2021 Feb 17, 2021

Copy link to clipboard

Copied

Zoom is all messsed up in every application now.   30 years and now you want to change it?  Can we get a warning and an option to leave legacy for us dinosaurs.   thanks.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines