Highlighted

Overlay transitions are taking me back to a previous page instead of staying on the same page

New Here ,
Nov 21, 2019

Copy link to clipboard

Copied

I am creating a tutorial series using XD and I'm having trouble with Prototype overlay transitions on some of my artboards.  If I click through from the beginning of the set, once I get to a certain artboard, anytime I click on an overlay link, it brings me back to the previous artboard (and displays the overlay in the same position it should be displaying on the parent board).  If I start the tutorial at the board that causes problems, all my overlays behave exactly like they are supposed to.  If I click back in the tutorial and move forward again to the board in question, now all the overlay transitions move me back to the previous board again.  I thought it was potentially being caused by the fact that I have one overlay artboard being linked by two separate pages.  I tried duplicating the artboard and still have the problem.  I've also tried deleting and recreating all the transitions and it still doesn't work.

 

I saw this post but nothing was helpful in solving the problem. 

 

https://community.adobe.com/t5/adobe-xd/links-in-prototype-mode-going-to-wrong-pages-in-xd-preview/t...

 

Here is the public link for the development version:

https://xd.adobe.com/view/e63f56a0-2880-4a6a-5c36-f91994e9c836-900e/

 

To get to the problem: click the "I need a new account" on the second page.

The issue happens once you navigate to the second Accessing the Professional Edition page.

 

Thanks in advance!

 

 

TOPICS
Desktop, Error, Product issue

Views

241

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Overlay transitions are taking me back to a previous page instead of staying on the same page

New Here ,
Nov 21, 2019

Copy link to clipboard

Copied

I am creating a tutorial series using XD and I'm having trouble with Prototype overlay transitions on some of my artboards.  If I click through from the beginning of the set, once I get to a certain artboard, anytime I click on an overlay link, it brings me back to the previous artboard (and displays the overlay in the same position it should be displaying on the parent board).  If I start the tutorial at the board that causes problems, all my overlays behave exactly like they are supposed to.  If I click back in the tutorial and move forward again to the board in question, now all the overlay transitions move me back to the previous board again.  I thought it was potentially being caused by the fact that I have one overlay artboard being linked by two separate pages.  I tried duplicating the artboard and still have the problem.  I've also tried deleting and recreating all the transitions and it still doesn't work.

 

I saw this post but nothing was helpful in solving the problem. 

 

https://community.adobe.com/t5/adobe-xd/links-in-prototype-mode-going-to-wrong-pages-in-xd-preview/t...

 

Here is the public link for the development version:

https://xd.adobe.com/view/e63f56a0-2880-4a6a-5c36-f91994e9c836-900e/

 

To get to the problem: click the "I need a new account" on the second page.

The issue happens once you navigate to the second Accessing the Professional Edition page.

 

Thanks in advance!

 

 

TOPICS
Desktop, Error, Product issue

Views

242

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 21, 2019 0
Adobe Community Professional ,
Dec 07, 2019

Copy link to clipboard

Copied

Your shared example requires a password, so I can't access it.

 

Initially, interacting with any overlayed artboard's unlinked item will automatically revert to the Previous Artboard. That's its default setting. So the overlay will disappear from the originating artboard. Any manually linked item on that overlay will normally move forward to the set artboard.

 

Watch for this (blue) return icon on a handle:

Schermafbeelding 2019-12-07 om 16.29.25.png

In the new version it looks like a dangling one.

 

Once the handle is pointing to nothing, or when the destination is otherwise edited, the overlay might not be returning to the previous artboard anymore. In order to restore this helpful default returning behavior, you need to link the item to anything first, and then select Previous Artboard from the Destination menu. (This option is inaccessible when the item is unlinked.)

Schermafbeelding 2019-12-07 om 16.29.16.png

 

Due to those dangling wires and the option of having more outgoing links (with different triggers) in the newer version, it might look a bit messy. But you'll manage to tame the jungle...

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 07, 2019 0