[Share]-How to share all artboards in XD with no interaction?

New Here ,
Nov 19, 2019 Nov 19, 2019

Copy link to clipboard

Copied

when i try to share the project, 2 screens are not sharing ..

 

<The Title was renamed by moderator>

TOPICS
How to, Share or publish

Views

17.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct Answers

Adobe Community Professional , Nov 20, 2019 Nov 20, 2019
All artboards (Screens) must be connected to the home artboard before you share. All the artboards grey in color in the share tab won't be shared. Check the following link for more information. - https://helpx.adobe.com/ca/xd/help/share-designs-prototypes.html

Likes

Translate

Translate
Adobe Employee , Dec 27, 2019 Dec 27, 2019
Hi there, Thank you for sharing the information asked by Italo. "The Artboards needs to be connected"means you need to make sure that in Prototype mode all the artboards are connected with each other as well as with home artboard.  If you have nothing connected in Prototype mode, then you need to make sure that you haven't made any artboard as home artboard to share all the artboards. Hope it helps. Thanks, Harshika

Likes

Translate

Translate
Adobe Employee , Jan 31, 2020 Jan 31, 2020
Hi, I see your point here about being able to publish all artboards. Given that there is a home artboard already set on canvas, and there is no direct way of removing it, you are unable to publish all screens. We understand that this can be annoying.   Please note that we are going to provide the ability to set and unset of a Home artboard in Prototype mode soon. Apart from that, we are also thinking about providing a way to publish all artboards from Share mode, irrespective of whether you hav...

Likes

Translate

Translate
Community Beginner ,
Jan 22, 2020 Jan 22, 2020

Copy link to clipboard

Copied

Hi there,

We are sorry to hear you are facing trouble updating link in XD. Would you mind telling if you are on the latest version of XD (25.3.12.1)? All artboards are connected directly or indirectly to your home artboard?

 

Thanks,

Divya

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied

When I created the file, I was not using the current version.  Then I updated, but the problem persisted.

 

NONE of my artboards are currently connected. I made the 'mistake' of testing how the new hover interaction, which made my buttons interactive.  Even though nothing was linked to anything.  I tried to remove them all and delete all of the interactivity, but XD still wanted things connected (even though they never were).  I don't know how to remove the "home" artboard setting.  Can NO artboards be set to home?  I'm so super confused.

 

That said, I've updated XD, as mentioned, and I've tried to replicated the issue and it doesn't seem to be happening anymore.  Does that mean it was fixed with the latest update?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 23, 2020 Jan 23, 2020

Copy link to clipboard

Copied

Hi Annika,

 

Thank you for reaching out. We had a similar discussion regarding this topic here: https://community.adobe.com/t5/adobe-xd/share-how-to-share-all-artboards-in-xd-with-no-interaction/m...  We would request you to please try the solution mentioned in the post. 

 

Let us know if that helps.

 

[Merged post]

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2019 Dec 19, 2019

Copy link to clipboard

Copied

In the recent update, I am facing an issue with sharing artboards for development. When I create a link for the first time, all the artboards are selected and it works fine. But when I make any changes, or add screens, for some reason the new artboards along with some old ones remain unselected/greyed-out and do not get updated in the link. Why is this happening? How do I resolve this?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 20, 2019 Dec 20, 2019

Copy link to clipboard

Copied

Hi BabaYaga1203,

 

Thank you for using Adobe XD. We are sorry to hear you are facing trouble in updating share link. Please make sure that grayed-out art-boards are connected (directly or inderectly) to the HOME art-board.

 

Let us know if it helps.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2019 Dec 27, 2019

Copy link to clipboard

Copied

Hi Shwetha, 

I'm sorry, but could you give me some more information on what do you mean when you say that the artboards need to be connected & how should I go about doing that?

Much appreciated.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 20, 2019 Dec 20, 2019

Copy link to clipboard

Copied

Hi, we are sorry you are having problems with Adobe XD. In order to help you, we need some useful information, such as:

  • the version of Adobe XD you are using;
  • the features of your pc;
  • if this error only occurs with this file or also with others;
  • if you have connected all the artoboards.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 27, 2019 Dec 27, 2019

Copy link to clipboard

Copied

Sure Italosan,

 

1. My XD version -  25.1.12

2. PC - Windows 10 - 64 bit

3. So far, faced this issue with 3 different files (twice with the immediate previous version-24.4.22 I assume,  and once with the current)

4. I am not really sure what does 'the artboards need to be connected' mean? It wasn't really a prototype if that's what you are asking. They were only design files that were being shared with the dev-team.

 

How I've dealt with it so far is - I simply copy all the artboards to a new file, all the artboards are then shareable and I end up creating a new link for this. 

 

Hope this helps.

 

Thanks in advance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 27, 2019 Dec 27, 2019

Copy link to clipboard

Copied

Hi there,

 

Thank you for sharing the information asked by Italo. "The Artboards needs to be connected"means you need to make sure that in Prototype mode all the artboards are connected with each other as well as with home artboard. 

 

If you have nothing connected in Prototype mode, then you need to make sure that you haven't made any artboard as home artboard to share all the artboards.

 

Hope it helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Hi

I have a file with one main artboard (it's a one page website) and when I try to share it gives me an error message:

The artboard contains no interactions. Please add interactions or choose a new home artboard.

I have shared files before without adding any interactions, has this changed?

Thanks

Criserror.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Hi Cris,

 

We are sorry to hear you are having trouble sharing a single artboard. We had a similar discussion in the past here: https://community.adobe.com/t5/adobe-xd/unable-to-see-all-art-boards-while-share-for-review-in-adobe... We would request you to please try the suggested solution in the post.

 

Let us know if that helps.

 

Note: [Merged Post]

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2020 Jan 20, 2020

Copy link to clipboard

Copied

Hi, Is there a way to deselect the "home" in prototype mode? I can't share all my artboards. I really don't want to change my share link. If I copy and paste my artboards to a new file my master components are gone. Please help asap.

 

Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2020 Jan 20, 2020

Copy link to clipboard

Copied

Hey, not sure exactly what you mean, might be nice if you can share a screen of your environment. You can change the "Home" artboard by selecting a different artboard in prototype mode and clicking on the little home icon in the upper left corner. You don't need a new share link, you just need to update the one you already have.

 

If not all artboards are getting shared and some are greyed out in the share mode, this is because some of them have interactions between them, and some don't. Only the ones which are "connected" to each other will show up in the prototype. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 20, 2020 Jan 20, 2020

Copy link to clipboard

Copied

Appreciate your reply. All my artboards are not wired in prototype mode, it's just that when I share my project only the one with the "home artboard" is selected others are greyed out. It says that I have to link/wire the other artboards for me to share it. Is there a way to share all my artboards without linking/wiring them to the home artboard?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 20, 2020 Jan 20, 2020

Copy link to clipboard

Copied

You can't really do anything in share mode, it only shows which artboards are "active". You must make changes in prototype mode.

 

The 'home artboard' needs to have some connection to the others if you want them to show up. It doesn't need to have a connection to all artboards individually, it can just have a connection to another artboard, which itself is connected to the others, but it needs to be a part of the "chain".

 

The other option is to not have any interactions at all, and this way everything shows up, but the only way to navigate will be arrows and the bottom navigation. 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

I removed all the interactions/wires/links, the only thing I can't remove is the home artboard. Before I messed around with the prototype mode there is no selected home artboard and I can share all my artboards.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

Home artboard will always be there. You can only change which one is the home artboard, but you can't have it without one. Even if you delete it, the 'home' marker will go to another one.

 

There isn't a home selected when you make a new file, but that's not the issue. Your prototype needs to start somewhere. If you don't have any connections whatsoever in the whole file, all artboards should have the blue border in 'share' mode. If it's still not the case, you probably missed a wire somewhere. Select all the artboards in prototype mode and it will show up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

Thank you so much, I will check each and every layer in my artboards for missed wire. Appreciate the help. 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 21, 2020 Jan 21, 2020

Copy link to clipboard

Copied

No worries, just zoom out, select all artboards in prototype mode and you'll see it 🙂

 

Cheers!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2020 Jan 29, 2020

Copy link to clipboard

Copied

I have selected all my artboards in prototype mode and I have no wires or links. I can't share all of my artboards in share mode.

 

Prototype mode.jpgShare mode.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2020 Jan 09, 2020

Copy link to clipboard

Copied

Hi,

 

I have this problem where I've applied interactions to a page. This page messes up the ability to Share a presentation - since only said page shows. There are no left/right arrows to navigate the presentation! If I remove the prototyped page the arrows are back. Is this a bug or a feature? 🙂

 

Regards

Johan

 

<The Title was removed by moderator>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 09, 2020 Jan 09, 2020

Copy link to clipboard

Copied

Hi Johan,

 

We are sorry to hear you are experiencing issue with XD. Would you mind sharing a short video of the workflow for better understanding so that we can check at our end? What is the OS & XD version of your machine?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 09, 2020 Jan 09, 2020

Copy link to clipboard

Copied

Hi Harishka,

 

I can't show you the problem since it's an ongoing project, but I've discovered that my problem is discussed on this thread (where you provided an answer!):

 

https://community.adobe.com/t5/adobe-xd/unable-to-see-all-art-boards-while-share-for-review-in-adobe...

 

There seem to be no clear solution to the problem of artboards not showing i Presentation mode except that you have to connects all artboards with each other and the Home artboard, which is a clunky "solution" at best and works just so-so. I also tried killing all my prototype connections but that didn't solve the problem. Only pasting each artboard into a new XD file worked. Luckily I only have like ten pages in my project. But what if there where a hundred? That would take precious time.

 

In the thread you say that:

 

"If you have nothing connected in Prototype mode, then you need to make sure that you haven't made any artboard as home artboard to share all the artboards."

 

But if I have made an artboard the Home artboard, how do I "deselect" it - and will I be able to see all artboards in the presentation if I do?

 

Possibly I don't understand how XD works, but this prototype/share/presentation problem seems to need some work from Adobes side.  🙂

 

Regards

Johan

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 10, 2020 Jan 10, 2020

Copy link to clipboard

Copied

Hi Johan, 

 

Thank you for the detailed explaination and sharing your feedback. We understand it could be annoying for you. We would request you to please submit your feedback here: https://adobexd.uservoice.com/forums/353007-adobe-xd-feature-requests/suggestions/13615728-choose-wh... and upvote the request to add your voice.

 

As a workaround, you can copy paste everything from design mode by pressing CTRL+A on windows & CMD+A on mac into a new document where you don't have any artboard as home artboard and then you can share all your artboards with no interaction. 

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 14, 2020 Jan 14, 2020

Copy link to clipboard

Copied

Don't know if it will help anyone else, but I managed to get my one artboard file to share by creating a hover interact in a component. That seemed to do the trick.

The one artboard was automatically set to home artboard and as far as I know you can't 'un-set' it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines