Highlighted

[Share]-Prototype links within hover states of component instances don't work in XD.

Community Beginner ,
Nov 13, 2019

Copy link to clipboard

Copied

I set up a topbar navigation menu with default states (white text links) and hover states (white changes to blue text links PLUS a dropdown menu of subnav links appears on hover).

 

In the Master component, I added tap interactions to the subnav links in the dropdown menu that appears upon hover.  The sub nav tap links in the dropdown menus work properly when I hover and tap on the MASTER within the prototype. However, when I copy and paste the master onto another page, the hover still works but the linked taps in the dropdown menu that worked on the master component no longer work on the instance. Even when I try to rewire the tap links in the dropdown menu manually within the instance, the links still won't work.

 

Bottom line, prototype tap links don't appear to work when they sit within the hover state of instances.  Is this a known issue or is there a work around please?  I've spent a lot of hours on this already and can't get it to work.

Topics

Product performance

Views

202

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

[Share]-Prototype links within hover states of component instances don't work in XD.

Community Beginner ,
Nov 13, 2019

Copy link to clipboard

Copied

I set up a topbar navigation menu with default states (white text links) and hover states (white changes to blue text links PLUS a dropdown menu of subnav links appears on hover).

 

In the Master component, I added tap interactions to the subnav links in the dropdown menu that appears upon hover.  The sub nav tap links in the dropdown menus work properly when I hover and tap on the MASTER within the prototype. However, when I copy and paste the master onto another page, the hover still works but the linked taps in the dropdown menu that worked on the master component no longer work on the instance. Even when I try to rewire the tap links in the dropdown menu manually within the instance, the links still won't work.

 

Bottom line, prototype tap links don't appear to work when they sit within the hover state of instances.  Is this a known issue or is there a work around please?  I've spent a lot of hours on this already and can't get it to work.

Topics

Product performance

Views

203

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 13, 2019

Copy link to clipboard

Copied

I am experiencing similar issues as well; hoping Adobe chimes in!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 22, 2019

Copy link to clipboard

Copied

Having the exact issues here. It makes it impossible to set up a good menu component if the component keeps forgetting interactions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 22, 2019

Copy link to clipboard

Copied

Apologize for the experience. I am checking wiht the team and will get back as soon as I have more info.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 25, 2019

Copy link to clipboard

Copied

I checked with the team. They are not able to reproduce your issue, and require your files for further investigation. Can you uplaod your XD file to a shared location and share the URL here, or with me over a private message?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 08, 2020

Copy link to clipboard

Copied

I just sent you a private message Preran. Thanks! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Apr 09, 2020

Copy link to clipboard

Copied

Hi Llewellyn Martin,

 

I have received your file from Preran and I am investigating on it. I will get back to you on this soon.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
mask207 LATEST
Community Beginner ,
Apr 09, 2020

Copy link to clipboard

Copied

Harshika, thanks for looking into this. I also sent you a private message
with a link to my original XD file from Nov 2019 where I was having trouble
with this (and was never able to get it to work properly).

I hope a bug fix can be implemented soon, before my next project requires
similar functionality!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...