Highlighted

[Share]-Text Overrides to Components not showing in Specs panel in XD.

Community Beginner ,
Jan 07, 2020

Copy link to clipboard

Copied

I have created a hover box component to use throughout my website - it changes color and shows text upon hover. It works great except all my text instances are showing as the master component text when I publish the developers link. So my developers can't copy the text from the content box in the specs panel - all of the content boxes have the master text instead of the instance text. Is there a way to fix this without creating a new component for each box on the site?

 

<The Title was renamed by moderator>

TOPICS
How to, Share or publish

Views

104

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

[Share]-Text Overrides to Components not showing in Specs panel in XD.

Community Beginner ,
Jan 07, 2020

Copy link to clipboard

Copied

I have created a hover box component to use throughout my website - it changes color and shows text upon hover. It works great except all my text instances are showing as the master component text when I publish the developers link. So my developers can't copy the text from the content box in the specs panel - all of the content boxes have the master text instead of the instance text. Is there a way to fix this without creating a new component for each box on the site?

 

<The Title was renamed by moderator>

TOPICS
How to, Share or publish

Views

105

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 07, 2020 1
Adobe Employee ,
Jan 08, 2020

Copy link to clipboard

Copied

Hi Whitney,

 

We are sorry for the trouble. If I heard you right, i am assuming this is the same fucntionality you are looking for: https://adobexd.uservoice.com/forums/353007-adobe-xd-feature-requests/suggestions/38978644-component...? If so, please submit your feedback & upvote the request to add your voice.

 

I would also suggest checking this post having a similar discussion around the same issue: https://community.adobe.com/t5/adobe-xd/component-states-wont-work-when-shared-for-review-developmen...

 

Please let us know if you're experiencing a different situtaion. We'll try oue best to help.

 

Thanks

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2020 0
Community Beginner ,
Jan 08, 2020

Copy link to clipboard

Copied

Thank you, Harshika!

 

I did upvote for the component states to be added to the development link. That doesn't really answer my question though. Let me see if I can explain better...

 

In the hover components that I have created, there are text that changes for each component. So I'm using the master component for the color & effect and then updating only the text in each state. When I share the developers link, the hover & text is working and shows correctly in the comments view but when you switch over to the specs panel view, the text shows as only the master component text, not the updated text for each state.

 

Is this something that would be addressed with the Component States to Development (Design Specs) Feature Request or is there something that I am doing incorrectly?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2020 1