Highlighted

Some bitmap images get missed off my @2x jpeg export of an @1x artboard

New Here ,
Nov 19, 2019

Copy link to clipboard

Copied

Outputting a @2x version of an @1x artboard resulted in images missing from the outputted @2x file towards the bottom of the canvas, however text and vector data at the same depth was still visible though.  The non @1x version outputted correctly.

 

After doing some tests with @2x and @3x versions to look for any patterns.  It seems most of the dropping of bitmap images in the design happens after 16,380px of canvas depth.  

 

On searching for 16,380 number and XD problems, it does look like XD is supposed to have a max output size of 16000px.   So what’s strange is that it happily exceeds that artboard size limit (I’ve tested 24,000 artboards – which it will create) but in doing so, it’ll just miss out any bitmap data after the 16k depth, making it unusable (without hacking the output file afterwards with pasted over sections to fill the holes) 

 

Surely a 16,000px image (a page of just 8,000px in depth – output @2x) is not too uncommon to be catered for in what’s meant to be Adobe’s platform for the future of web design?

 

Can anyone at Adobe comment on this seemingly handicapping depth limit?

TOPICS
Import and export, Product issue

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Some bitmap images get missed off my @2x jpeg export of an @1x artboard

New Here ,
Nov 19, 2019

Copy link to clipboard

Copied

Outputting a @2x version of an @1x artboard resulted in images missing from the outputted @2x file towards the bottom of the canvas, however text and vector data at the same depth was still visible though.  The non @1x version outputted correctly.

 

After doing some tests with @2x and @3x versions to look for any patterns.  It seems most of the dropping of bitmap images in the design happens after 16,380px of canvas depth.  

 

On searching for 16,380 number and XD problems, it does look like XD is supposed to have a max output size of 16000px.   So what’s strange is that it happily exceeds that artboard size limit (I’ve tested 24,000 artboards – which it will create) but in doing so, it’ll just miss out any bitmap data after the 16k depth, making it unusable (without hacking the output file afterwards with pasted over sections to fill the holes) 

 

Surely a 16,000px image (a page of just 8,000px in depth – output @2x) is not too uncommon to be catered for in what’s meant to be Adobe’s platform for the future of web design?

 

Can anyone at Adobe comment on this seemingly handicapping depth limit?

TOPICS
Import and export, Product issue

Views

52

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 19, 2019 0
New Here ,
Nov 19, 2019

Copy link to clipboard

Copied

A quick update to this post: 1 hour of testing later  

 

I’ve since tried to unpick the problem by reducing the variables. 

 

• Create New file 

• Create New artboard (of same depth as in original file with problem) in new file

• Copying one of the images that didn’t appear on the export from the problem file

• Pasting that into new file+artboard at same y position as in old file

 

RESULT: Still didn’t appear in the @2x export of the artboard

 

 

At first I thought it could be something to do with the image being a component object…

 

So I unlink component

…still same export problem

 

Then I unmasked the image

Bingo, it appeared in the @2x export.

 

Then I tried remasking it with the same rectangle from the original mask

…didn’t export.

 

Then I tried unmkasking it again

… again, the image appeared ( as expected)

 

So I created a new rectangle and masked it with that

… it also appears fine.

 

 

I’m not sure what I’ve learned from this.   That a regular placed image WILL appear lower than 16,000px on an export.    That possibly components and/or masks do mess objects up so they don’t render past 16,000px deep. That the mask rectangle gets corrupted somehow… and creates the same problem if reused.

 

I’ve since tried to recreate a masked image component from scratch and swapped images in and out on the component instances and I can’t replicate the problem at all.  So maybe I need to just rebuild all the components from scratch in my proper design project file, although this is clearly huge faff as the project is pretty well established (many pages, many instances).   

 

Maybe the whole thing was just a result of a crash at some point in the files history which messed things up?

 

Anyone else seen anything similar occurring, or find a way of fixing, or identify what triggered it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2019 0