Highlighted

SVG and AI import are horribly broken [Windows]

New Here ,
Oct 10, 2020

Copy link to clipboard

Copied

I was working on a client site and setting up my CC library with colors/logos when I noticed something off about the logo. Zooming in, I found that the logo was actually disfigured in a way that is completely unacceptable. I have added picture below to show what I mean.

Illustrator_O.pngXD_O_Broken.pngIllustrator_Charcuterie.pngXD_Charcuterie_broken.png

 

This needs to be fixed ASAP.

TOPICS
Design, Import and export, Missing feature, Product performance

Views

80

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

SVG and AI import are horribly broken [Windows]

New Here ,
Oct 10, 2020

Copy link to clipboard

Copied

I was working on a client site and setting up my CC library with colors/logos when I noticed something off about the logo. Zooming in, I found that the logo was actually disfigured in a way that is completely unacceptable. I have added picture below to show what I mean.

Illustrator_O.pngXD_O_Broken.pngIllustrator_Charcuterie.pngXD_Charcuterie_broken.png

 

This needs to be fixed ASAP.

TOPICS
Design, Import and export, Missing feature, Product performance

Views

81

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 10, 2020 0
Adobe Employee ,
Oct 12, 2020

Copy link to clipboard

Copied

Hi Steven,

 

We're so sorry to hear about the trouble. Could you please share a few more details like:

 

  1. Please confirm if this is happening while importing assets from Illustrator to CC Library and then to Adobe XD?
  2. Does this happen while importing the logo from AI to XD without the CC library?
  3. Is this happening with assets created in Illustrator or with assets created in other applications?

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0
New Here ,
Oct 12, 2020

Copy link to clipboard

Copied

This happens when:

  1. Importing an SVG from the Adobe CC Library panel in Adobe XD (click and drag from CC Library window into XD window).
  2. Dragging and SVG into Adobe XD from my file browser.

 

This does not happen when:

  1. I copy a graphic in Illustrator, and paste in into XD

    So far, I have only seen this issue using assets created in Illustrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 12, 2020 0