Text in Component jumps when using auto-animate

New Here ,
Feb 14, 2021 Feb 14, 2021

Copy link to clipboard

Copied

I noticed that this behavior is random and doesn't happen in every component.

 

I have a simple sign-up screen that has a component with different fields (2 states: empty and filled) and a button, which is a nested component with 2 states as well (active and inactive). When a user clicks on the button, it shrinks into a circle and a label disappears. 

 

When I preview this in XD, the label moves away (up and left) and by the end of the animation, it jumps back where it should be. Screenshots (1 and 2) show that the layers have identical names and (3) how the text "jumps" out. Attached is a screen recording showing the same.

 

Not sure what triggers this bug but it seems to happen after editing the main component. 

 

Screen Shot 2021-02-15 at 3.28.59 PM.pngScreen Shot 2021-02-15 at 3.29.17 PM.pngScreen Shot 2021-02-15 at 3.28.10 PM.png

 

 

TOPICS
Prototyping

Views

200

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 15, 2021 Feb 15, 2021

Copy link to clipboard

Copied

Hi there,

 

Thanks for reaching out. We'll need to test this on our end so will it be possible for you to share the actual file with us? If yes, please add the file to a shared location like Google Drive or DropBox and share the link either here or you can DM me by clicking on my name. We'll also need the version of XD and OS which you are using.

 

Note: While sending the DM, please add this discussion link in the subject.

 

Regards

Rishabh

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 15, 2021 Feb 15, 2021

Copy link to clipboard

Copied

Hi there,

 

I tried recreating this use but couldn't ( attached video for the reference ). As Rishabh mentioned please share the file (Two artboard where you are seeing the problem) along with requested details.

 

Thanks,

Rajasekhar. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 04, 2021 Mar 04, 2021

Copy link to clipboard

Copied

Hi Alexander,

 

It's been a while we haven't heard back from you. We would like to know if you are still experiencing the issue. Please feel free to update the discussion if you need further assistance from us.

 

We would be happy to help.

 

Thanks,

Harshika

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines