Highlighted

troubles with nested components and hover states

New Here ,
Apr 24, 2020

Copy link to clipboard

Copied

 I'm having the problem with nested componenets and haven't been able to figure it out yet! When you tap top-tier nav item, I want it to drop down and show 2 subnav options. Each of the sub options also has a hover effect and tap function on it. When I isolate each hover and tap action to test them, they work fine. But when I put it all together, the nested second layer of hover states and tap states doesn't seem to work

Views

185

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

troubles with nested components and hover states

New Here ,
Apr 24, 2020

Copy link to clipboard

Copied

 I'm having the problem with nested componenets and haven't been able to figure it out yet! When you tap top-tier nav item, I want it to drop down and show 2 subnav options. Each of the sub options also has a hover effect and tap function on it. When I isolate each hover and tap action to test them, they work fine. But when I put it all together, the nested second layer of hover states and tap states doesn't seem to work

Views

186

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 24, 2020 0
Adobe Employee ,
Apr 24, 2020

Copy link to clipboard

Copied

Hi Dipti,

 

Sorry to hear you are having trouble with nested components in XD. Is it possible for you to share the screenshot of your prototype mode showing all the interactions? It will help us in understanding the workflow. 

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0
New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

Hi Harshika,

Thanks for the response. I've created one file to explain the issue
https://xd.adobe.com/view/ab51620a-8ec0-4195-53a2-4805a4db72c3-dd60/

 

Let me know if this helps to understand the problems with nested components.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2020 0
Adobe Employee ,
Apr 29, 2020

Copy link to clipboard

Copied

Thank you for sharing the link. It would be helpful if you can guide me which dropdown to check. Do I need to click By Column dropdown?. Would it possible for you to share the screenshot of the prototype mode showing all the interactions? Is the hover working fine in desktop preview?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2020 0
New Here ,
May 04, 2020

Copy link to clipboard

Copied

dipti_rathi_0-1588655350012.png

In the above screenshot, there is hover tooltip inside the panel of 'i' icon click event which is again a compnonent. If this panel opens by default then hover tooltip works. But if panel opens when click of 'i' icon (which is expected behaviour ) then hover within that componenet wont work. Same for sample size dropdown. If by default open then click on compute button works but if drodpwon is trigger when click on the arrow then click event on button doens't work as it is part two nested components. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2020 0
New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

Hi Harshika,

Have not received any updates on the issue posted. Let me know if you need more clarifications

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
New Here ,
Apr 29, 2020

Copy link to clipboard

Copied

Hi,

 

I have exactly the same probleme with nested components inside rollover. Each alone work fine, but when i put one component inside an other one. Only the first rollover work.

 

Thanks,

David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2020 0
Adobe Employee ,
Apr 29, 2020

Copy link to clipboard

Copied

Hi David,

 

I am sorry you ran into trouble with hover in nested components. Would you mind sharing a short video of your workflow from scratch so that we can test at our end?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 29, 2020 0
New Here ,
Apr 30, 2020

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2020 0
Adobe Employee ,
May 05, 2020

Copy link to clipboard

Copied

Thanks for sharing the prototype link, David. I am not quite clear with the link. Could you please share the screenshot of your design in prototype mode showing all the interaction and wires?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 05, 2020 0
New Here ,
May 06, 2020

Copy link to clipboard

Copied

I'm not sure this would help you but her it is :

mr-gu-JQOU2N_0-1588760158238.png

Thanks

David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 06, 2020 0
New Here ,
Jun 09, 2020

Copy link to clipboard

Copied

hi,

 

do you have any news about this issue?

 

Thanks

 

David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
Adobe Employee ,
Jun 11, 2020

Copy link to clipboard

Copied

Hi David, 

 

Sorry for the delay in response. It appears that this is the same workflow you're following please have a look: https://adobexd.uservoice.com/forums/353007-adobe-xd-feature-requests/suggestions/38968075-hover-ins...

 

This might be the cause of the issue. Let me know if it's the similar issue

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 11, 2020 0
New Here ,
Jun 16, 2020

Copy link to clipboard

Copied

Hi, 

 

Yes it's the same issue

 

David

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 16, 2020 0