Unable to select and drag items across artboards in Adobe XD.

Community Beginner ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Hello,

 

On the latest version of XD, when I select an item and want to move it to an artboard that is not within the active view, the view doesn't move to view the artboard in the direction i'm moving my mouse. Same happens when I try to make an interaction and link it to an artboard that is not in the current view (see screenshot). Any help?issue.png

 

<Title was renamed by moderator>

TOPICS
Product performance

Views

831

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 01, 2021 Jun 01, 2021

Copy link to clipboard

Copied

Hi there,

 

Thanks for reaching out and sorry to hear you are unable to drag assets across artboards. I am unable to reproduce the issue at my end on my windows machine. I have attached the gif below. 

 

Drag selected items.gif

 

Could you please share the version of XD and the OS you're using? I would request you to please try signing out of XD, the Creative Cloud desktop app, and then sign back in.

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 02, 2021 Jun 02, 2021

Copy link to clipboard

Copied

Thanks, Harshika.

 

The interaction in the gif is exactly what I am not able to do. I'm glad you got what I was talking about. When I drag anything, the screen doesn't move the same way it does in your gif.

 

My Xd version is 40.1.22.3 and I'm on windows 10. I signed out and in again and the issue is not fixed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 03, 2021 Jun 03, 2021

Copy link to clipboard

Copied

That's strange. Does that happen with every file or with this specific file? If with every file, then you can try uninstalling XD from Creative Cloud Desktop app and reinstall it.

 

If it's happening with a specific file, please copy the content from the prototype mode and paste it into a new file, and then try again.

 

Let me know if that works. I'll try my best to help. 

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 05, 2021 Jun 05, 2021

Copy link to clipboard

Copied

thanks again,

 

I tried reinstalling but nothing changed. Also, this is happening with all my files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 06, 2021 Jun 06, 2021

Copy link to clipboard

Copied

Hey there, are your graphics card drivers up to date? What GPU are you using?
Does anything change if you minimize / maximize Xd?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 07, 2021 Jun 07, 2021

Copy link to clipboard

Copied

hendelgohary_0-1623100170791.png

No it doesn't matter whether the window is minimized or maximized, and this screenshot shows my GPU info. It's a Nvidia RTX 2070

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Can you also post a screenshot for the nVidia GPU?

 

image.png

 

Did you verify whether you are running on the latest studio drivers for the 2070? You can find the latest studio driver here

 

Also, please make sure you are running Xd with the nvidia gpu and not the intel integrated graphics, which seems to be used by default according to the screenshot you sent.

 

To do this, open Settings. On the left, select Display, then at the very bottom click on "Graphics Settings".

 

Once there, under the section Graphics Performance Preference, at the dropdown select Microsoft Store App, and then Adobe Xd, and click on "Add":

 

image.png

 

After that, Adobe Xd will appear in the list below. Click on it, then click Properties, and make sure you select the option with the NVIDIA GPU:

 

image.png

 

I know Xd and other Adobe programs have issues with certain Driver versions and GPUs. It might not like your integrated GPU, or its driver. Try updating the drivers and setting it up to run with the nvidia, and see if it fixes it 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Hi

I did everything you said but nothing changed 😞 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

If you are sure, that:

1. Xd is running on the nvidia gpu

2. You have the latest drivers for your GPU

3. Xd is also updated to the latest version (41 as of today)

 

I really can't think of anything else that might be causing it. Sorry.  Maybe someone else who's more technical can come up with a solution. It really does sound like some sort of an issue with system configuration, if it happens with all files, and reinstalling didn't fix it. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Thanks for trying all the suggestions from our expert. Is it possible for you to share any sample XD file with me so that I can take a look and see if it's behaving the same at my end? If yes, please upload the file to a shared location such as CC or Dropbox and share the URL with me over a PM or here.

 

I will try my best to investigate the situation.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

It doesn't happen for me  maybe the thing you want to proto type is too far

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 10, 2021 Jun 10, 2021

Copy link to clipboard

Copied

Hey Imran,

 

Thanks for reaching out. We would like to know if there is an issue with a specific file at your end or all the files? If possible, could you please share the XD file with me so that I can investigate the situation here?

 

I will try my best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 11, 2021 Jun 11, 2021

Copy link to clipboard

Copied

LATEST

Its not me that asked the question

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines