Unable to Update Library

Community Beginner ,
Nov 25, 2020 Nov 25, 2020

Copy link to clipboard

Copied

I am unable to update my library using the UPDATE action in XD. The update button is there - as well as the banner, but when I click "UPDATE"  nothing is happening. I am unable to figure out what is the cause - file size, server issue? Any suggestions?

 

katieh041487_0-1606328699883.png

 

TOPICS
Product performance

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 25, 2020 Nov 25, 2020

Copy link to clipboard

Copied

Hi Katie,

 

Sorry to hear you are unable to update the published library in XD. Could you please try to sign out of XD, Creative Cloud, reastart the machine and then sign back in? I am able to publish the library fine at my end. Please also make sure you're on XD 35.1 version.

 

Let us know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 25, 2020 Nov 25, 2020

Copy link to clipboard

Copied

I quit all Adobe products, exited CC, and rebooted my PC. I still am unable to update the library. It looks like it's publishing but then it returns me to the UPDATE screen and any new components are not on the library. I am on Windows 10 and v53.1.12 of XD.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 28, 2020 Nov 28, 2020

Copy link to clipboard

Copied

 

Hi Harshika,

I also have the same issue.

I also have the same version as KatieH only difference is that I am on a Mac?

Please advise?

With kind regards

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 08, 2020 Dec 08, 2020

Copy link to clipboard

Copied

SAME ISSUE. I have an huge delivery reliant on this component library.

 

Need help. 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2020 Dec 18, 2020

Copy link to clipboard

Copied

I also restarted the Creative Cloud, the computer, and of course, Adobe XD and I still cannot update the library.

 

Please, help…

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Same issue here. I work with two published libraries, but only one can be updated. When I try to update the other one, by clicking on the Update button, I get just a glimpse of the progress bar at the top and a persistent blue toast message at the bottom. I cannot update the library. Please help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 18, 2020 Dec 18, 2020

Copy link to clipboard

Copied

BUMP. This issue is still very much alive and well in v35.3.12.2

 

The recommended solution does not fix the problem. Nor does doing a complete clean install of CC/Xd.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 19, 2020 Dec 19, 2020

Copy link to clipboard

Copied

Hey everyone, I could solve this on my end. I solved all missing font issues and linked components and finally could update my Library. I hope this can help others (since the sign-out and reset advice from Adobe was very poor).

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 20, 2020 Dec 20, 2020

Copy link to clipboard

Copied

My issue is still there, I am using a master document which only contains master componenten. I have no missing font nore any other components from another library (by definition). This is the base Design System Document. 

 

Still it just asks to update, after clicking the update button a snackbar appears (blue bar at the bottom) asking me to again update, and so on and so on :-(. 

 

This is bad, it doesnt asspire confidence and if such issue continue to occure i can imagine people will be running to other tools such as Skecth, Figma, Invision or whatever.... 

 

Adobe XD please advise 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 21, 2020 Dec 21, 2020

Copy link to clipboard

Copied

I can also attest to the exact same behavior Driek described above.

 

My base style guide document exhibits the behavior he has descibed. It's an intinite loop that never results in an error but also never results in a successful 'update'

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Hi All,

 

I am sorry for the delay in response. Sorry to hear you are still experiencing the issue while updating libraries. If you need immediate assistance, you may get in touch with us directly using this link: https://helpx.adobe.com/contact.html or you may share the ask details-

 

Are you facing the issues with all the libraries or with a specific library?

Have you tried on a different machine and see if that helps?

 

I will try my best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

Dear Harshika, 

Issue is still there. Ik will try and get helped using the URL you provide. On your questions about the libraries, I only have (the need for) one. Which is in my idea also the purpose of a master DS. It seems to be failing on multiple systems as well. 

At this point DS support feels unstable/broken for me, which is a pitty because I really do love XD. 

With kind regards, 

Driek 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

I'am still experiencing this issue, tried all of the recommended steps, but none of them resulted in any improvement. Currently I'm unable to publish or update any of the libraries, working on win10, newest XD version (37.1.32).

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 12, 2021 Apr 12, 2021

Copy link to clipboard

Copied

I also cannot update one of the existing libraries, even if I make changes to the master components in this XD file, the blue notification bar "Update your published library. Update Now" doesn't show up, but this library has already been published and is showing in the Libraries panel. 

 

I tried to sign out and restart the Mac, but still not working. I'm on MacOS v10.15.4 and v38.1.12.2 of XD.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 05, 2021 May 05, 2021

Copy link to clipboard

Copied

This doesn't work. But it sure does sound like it from the way it's advertised! This software belongs back in non-production ready beta.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 06, 2021 May 06, 2021

Copy link to clipboard

Copied

Last post was in haste, I'll be more specific:

 

- User UX: The Manage Libraries is hidden in a menu, and when the library file been updated, the inheriting document does not indicate the library has been updated, and futhermore, will indicate that "Libraries are up to date" when in fact they are not. 

- Changing something in a library file does not always count as a change, and therefore there are no changers to be pushed (at least the button is not displayed and instead it says ":white_heavy_check_mark: Up to date". For example: If you update a text box to scale Auto Height from Auto Width or Fixed Size, it does not consider this an update to components, and will not show a button to publish the changes. This will hide the overflow text from a review. 

 

Since libraries do not function in these instances, the whole system not worth using, especially when XD is telling the user that everything is up to date when it's not. This makes this unreliable software, and thus not acceptable for production level work. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 24, 2021 May 24, 2021

Copy link to clipboard

Copied

Hello,

I am having the same issue with the latest update 40.1.22. on Win 10. Already lost a full day in contact with Customer Support and trying different solutions, which didn't help. On top of the bug with the update button, I also got a recovered version of the affected library. It auto generates even if I delete it. At this point in time, our team is stuck and unable to progress on our project. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 26, 2021 May 26, 2021

Copy link to clipboard

Copied

Update: 
Nothing helped from the list below:
- relogging into Adobe Account
- reinstalling both the app and the cloud
- reinstalling both the app and the cloud with the help of Customer Support's Cleaner app
- Reinviting to the library and the files

After the last intervention from Customer Support, Adobe Xd doesn't recognize that I am invited to the library and instead of 'Update' I have a 'Publish' option.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Hi All,

 

We are sorry for the frustration. We would like to know if you're still experiencing the issue with XD 41 version. 

 

We'll try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 21, 2021 Jun 21, 2021

Copy link to clipboard

Copied

Yes, it still happens. But removing font errors for missing fonts solves
the problem.


--
Christian Pino | UX Designer
<Personal Info removed by moderator>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

Yes, Harshika.

I am still experiencing the issue (as described by Driek). In fact, it only just began for me with the latest release (updating XD through Creative Cloud). 

I suspect this is more of a coincidence than a direct result of updating, but I can't be sure. 

 

In my case, libraries appear to be updating when republished using the update button, but the update is immediately followed by a notification (blue banner at bottom of page) that I should update again.

My hypothesis is that there are recursive references between multiple libraries. For me, I have an icon components library and a separate components library that contains nested components; many of which include icon components from the icon components library. This is not new for our system, so it may be that the latest release (41.0.12) is, in fact, the source of my issue. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

That's definitely not expected. Is it possible for you to share a short video of your workflow so that we can escalate the issue to the team for further investigation? Please share the operating system you are working on.

 

We'll try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 24, 2021 Jun 24, 2021

Copy link to clipboard

Copied

Harshika,

Thank you for the rapid response.

 

Machine Specifications

Edition Windows 10 Pro
Version 20H2
Installed on ‎4/‎2/‎2021
OS build 19042.1052
Experience Windows Feature Experience Pack 120.2212.2020.0

 

Device name DellG5-2021
Processor Intel(R) Core(TM) i7-8750H CPU @ 2.20GHz 2.21 GHz
Installed RAM 16.0 GB (15.8 GB usable)
Device ID A7BE9AA3-91A3-4F0B-A1E8-318A404ADE4D
Product ID 00330-51655-90983-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

 

Video

You can find a vidcap here: Recursive Library Update - YouTube

This video shows 2 separate libraries that exhibit this recursion.

 

Hypothesis:

One of these libraries, "C_Portal Components" (second in the video) contains components where the parent main component is in C_Portal Components, but one or more nested (child) components are from from the "C_Icons" library (first in the video).

Several of these child components from C_Icons are, themselves, nested.

I believe that my issue comes from some manner of cross-linking between the 2 libraries.

 

Example:

C_Portal Components will contain a main component that includes several icon buttons from the C_Icons library.

These icon buttons are made up of a background components which maintains a default state and a hover state.

This allows us to have a single component govern the hover state of several button components. 

 

We're noticing that this backgound component will often cause a secondary "Update" cycle when changes are made to one of the button components in C_Icons. 

 

Example:

  1. 5 buttons are modified in C_Icons.
  2. Changes are published for C_Icons Library
  3. C_Portal Components is opened and indicates that there are 5 updates available for the document assets.
  4. Reviewing the document assets reveals the 5 buttons have the blue 'update linked asset" icon.
  5. Clicking "Update" runs successfully but is immediately followed by a return of the "Update" button for a single document asset.
  6. Reviewing the document assets reveals that the background component used in the buttons that were previously updated not has an update.

This is incorrect. The background component has not been changed in several months. However, it continues to show up in the list as updated after other components that actually have been changed are updated. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 06, 2021 Jul 06, 2021

Copy link to clipboard

Copied

LATEST

Thanks for the detailed information and for sharing the video. Is it possible for you to share the XD file as well so that I can go ahead and log a bug for the issue? If yes, please upload the file to a shared location and share the URL with me over a PM.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines