Universal components not updating

New Here ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

I'm using nested components with instances to build a series of universal components with a shared file. I'm linking the universal components into multiple design files to have a single location to update common components. Some of the nested components are not maintaining the selected instance when applied to a different file? It's not an issue of updating the components either. I have everything updated. 

 

Thanks 

TOPICS
Data loss, Product performance

Views

283

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Hi,

Is it a Cloud or local file?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

It's a cloud file.

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Is there anything in particularly different about the ones not updating?

Have you checked whether they are updating in one file and not in another one, or are they not updating wherever you place them?

 

Some screenshots of the process would be useful as well, or even a video.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

No there is nothing particular about this file. There are roughly 10 different embedded components that make up this one master component form. Each of the components is used multiple times in varied states. For example, I might have a dropdown that is in its default state, selected state, and an error state. There are about 10 lines of inputs with 1-4 inputs per line. 

 

The form has the same error with every file it's linked to. One row's inputs are defaulting the embedded component's default state and size rather than the state and text I've entered in the master component. Since the component is linked to multiple artboards in about 20 different files, I need to fix the master. Probably safest to just replace the embedded component that is causing the issue.

 

Sorry, my NDA prevents me from posting a screenshot.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 04, 2021 Apr 04, 2021

Copy link to clipboard

Copied

Hi there,

 

We are sorry to hear you are unable to update the components in your file. If you are still experiencing the issue and you are not able to share the screenshot or file with us. You can definitely connect with us directly using our contact us page and someone from the support team will be helping you on a 1:1 basis.

 

Thanks,

Harshika

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines