Highlighted

Uploading or Updating Developers Link makes XD freeze at 0%.

Explorer ,
Jun 08, 2020

Copy link to clipboard

Copied

 

So, we are currently 4 persons in our organization having the same problem. Two on mac, two on pc.

We are working on different files, co-editing not activated on any of these and different internet connections. When trying to share the document creating the development link, it gets stuck on 0%, we have left the program run for a night, to see if it could get over it given the right time, without avail.

After a lot of testing around these files, we found out that the main problem blocking the upload where certain components. When deleting those, it would start uploading without a problem. The issue with this is that we have files with hundreds of components. And checking wich ones works or not for the upload is very, very time-consuming.

 

I've uploaded the video so you can see what's happening there. Also, in the end, you can see that I have a really good internet connection, so that's not the problem.

This also happens even if all the artboards are selected to export.

 

As XD doesn't crash, I've no extra logs or information to give to try to pinpoint the problem.

 

This XD I'm using to make the test was just reinstalled from a fresh, fully erased adobe installation. No plugins added yet.

 

I hope you can help me find a solution to this. 

 

Thanks!

TOPICS
Crash on windows, Data loss, Product performance, Share or publish

Views

520

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Uploading or Updating Developers Link makes XD freeze at 0%.

Explorer ,
Jun 08, 2020

Copy link to clipboard

Copied

 

So, we are currently 4 persons in our organization having the same problem. Two on mac, two on pc.

We are working on different files, co-editing not activated on any of these and different internet connections. When trying to share the document creating the development link, it gets stuck on 0%, we have left the program run for a night, to see if it could get over it given the right time, without avail.

After a lot of testing around these files, we found out that the main problem blocking the upload where certain components. When deleting those, it would start uploading without a problem. The issue with this is that we have files with hundreds of components. And checking wich ones works or not for the upload is very, very time-consuming.

 

I've uploaded the video so you can see what's happening there. Also, in the end, you can see that I have a really good internet connection, so that's not the problem.

This also happens even if all the artboards are selected to export.

 

As XD doesn't crash, I've no extra logs or information to give to try to pinpoint the problem.

 

This XD I'm using to make the test was just reinstalled from a fresh, fully erased adobe installation. No plugins added yet.

 

I hope you can help me find a solution to this. 

 

Thanks!

TOPICS
Crash on windows, Data loss, Product performance, Share or publish

Views

521

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 08, 2020 0
Adobe Employee ,
Jun 09, 2020

Copy link to clipboard

Copied

Hi there,

 

We are sorry to hear you are having trouble. Would you mind sharing the file with me over a private message so that we can check at our end?

 

We will try our best to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 1
Explorer ,
Jun 09, 2020

Copy link to clipboard

Copied

Sure, I'll share you a part of it,
Do you want me to send you the local file? Altho the problem is with the cloud versions of the file...
I'll send you the local, so you can test it, if you cannot reproduce the error, then it's possible that it's related to the cloud-only version of it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
Explorer ,
Jun 09, 2020

Copy link to clipboard

Copied

File sent! 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
Adobe Employee ,
Jun 10, 2020

Copy link to clipboard

Copied

Thank you. I received it. I am investigating on the file at my end. I have added one test artboard name " Test Artboard-Harshika" in the file and trying to create a development link. 

 

I will share the updates with you over a private message.

 

Thanks,

Harshika

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 1
Community Beginner ,
Jun 09, 2020

Copy link to clipboard

Copied

I'm having this same issue since yesterday as well. I published an update in the morning just fine. Then a few hours later after I'd made some changes to replace a sidebar with a sidebar component, and now I can't publish the updates because the update link just sits on 0% until I eventually have to force quit XD. Restarting the machine doesn't fix the issue. It's a large file so previously it was taking a while to update, but it was doing something and not just staying at 0%. 

Edit to mention that I'm on Mac Mojave 10.14.6 and XD 29.3.32.3  CC Sync 4.3.45.2

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 1
Adobe Employee ,
Jun 09, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry to hear about the trouble. Could you please try the steps shared below:

 

  1. Sign out of XD and Adobe CC Desktop app.
  2. Close CoreSync Process and all Adobe related process from the Task Manager/Activity Monitor.
  3. Sign back in on Adobe CC Desktop app and launch Adobe XD from there and then try publishing the link and let us know how it goes.

 

Regards

Rishabh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
Community Beginner ,
Jun 09, 2020

Copy link to clipboard

Copied

Hi,

 

No luck it's still sitting at 0%. Out of curiousity I made a copy of the original. I then created a link for the copy and this worked, I then duplicated an artboard and updated the link and it appears to have published that update (I made the mistake of touching the other window with the original doc still hanging there on 0% in the midst of that update which caused xd to stop responding and I had to force quit it all.) so it seems that something may have corrupted the document, but whatever that was didn't persist into its copy? 

 

Edit: spoke too soon. went to update to remove the duplicated artboard, noticed I'd shared as design review not development the first time, switched it to development and updating the link does not work at 0 hang again, so it seems to be the development share that is the problem.

 

Edit 2: went to the original doc, switched share from development to design review and magically it is publishing. It's defnitely the share for development view that is having the hang problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 1
Explorer ,
Jun 09, 2020

Copy link to clipboard

Copied

This solution is not working for me either.

 

And yes, I can confirm that the 0% problem is only happening on development link upload.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 09, 2020 0
Adobe Employee ,
Jun 10, 2020

Copy link to clipboard

Copied

Yes you both are correct. I added an artboard and tried to publish as design for review link and it worked for the design review link but not for the development link.

 

I am checking with the team for further investigation. I will update you as soon I hear back from the team.

 

I would really appreciate your patience and sorry for the inconvenience.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 1
New Here ,
Jun 10, 2020

Copy link to clipboard

Copied

My developer just pointed out to me that the link I had previously published for him publicly (without a password) suddenly had a password on it. So I had to delete it because within XD it still showed as public and I could re-publish. When I try to publish a new link, it will slowly progress from 50-100% and then crashed giving me an Error Code 2401 and when I go to learn more the troubleshooting page is not helpful and the status of the Adobe Publish Online is green, but it's clearly having issues.

Video attached.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Community Beginner ,
Jun 10, 2020

Copy link to clipboard

Copied

Hi, This is happening to me to, a client just told me that he can't see the prototype y set because it has a password, and I tried to update the link but I get this 55:18 error

diaorva_0-1591811009575.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Adobe Employee ,
Jun 10, 2020

Copy link to clipboard

Copied

Hi Cholek,

 

I have tested with Zigmas file at my end. Could you please try to publish the link by unchecking the downloadable assets checkbox in SharePane mode?

 

Let me know if that helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Adobe Employee ,
Jun 10, 2020

Copy link to clipboard

Copied

Hi Courtrc and Diaorva,

 

There was an outage that affected the publish links. The services are back up and running. Please try to publish the links again and share the results with us.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
New Here ,
Jun 10, 2020

Copy link to clipboard

Copied

I was able to publish a new link once the issue was resolved.
Thanks.


Sent from my Verizon, Samsung Galaxy smartphone

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 1
Explorer ,
Jun 10, 2020

Copy link to clipboard

Copied

Hi Harshika!

I Think Courtrc and Diaorva issues are not exactly the same problems than ours tho. We have never experience the error messages that they have, for us XD just freezes. No matter what we do or wait.

Altho, I've seen Courtc error before, on links that are too old, I think Pre-Mar. 2020 update, some of them if you try to access them now it gives you that password-protected screen when it's not.

So, about the original problem, I just tested out:
nothing.png

 I've left it uploading for out about 18 minutes, trying to load with no avail, still stuck on 0%. When checking the task manager on windows I can see that XD is consuming around 4 to 5gb of ram while trying to do this... with peaks of 6gb. Again, it's unresponsive, so after a while, I had to kill it.

 

I did try to upload it with downloadable assets unchecked in SharePane mode, and it worked! After about 6-7 minutes it suddenly went to 50% uploaded and then very slowly went to 100%! So yeah, that's kind of a solution. Altho, I do need the links with the downloadable assets for my team.

This does give us a clue to look around more into the assets marked to export, check what can be the cause of it.

I hope you can give me a better way to fix this problem Harshika, because, as you can see on the file I sent, there are plenty of assets that are being marked for download. 🙂 Don't really want to make one of my team lose a whole day checking one by one wich one could be the possible culprit! 

I'll keep looking around, and also waiting for your ideas, Harshika!
Thank you very much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Adobe Employee ,
Jun 10, 2020

Copy link to clipboard

Copied

Glad to hear that and thanks for the confirmation. Please feel free to reach out to us in the future.

 

We would be happy to help.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Adobe Employee ,
Jun 10, 2020

Copy link to clipboard

Copied

Thank you for the update, Zigma. I am checking with the team to investigate on this issue and thanks for trying unchecking the downloadable asset checkbox and confirming that it did worked.

 

I will update you as soon as I hear back from the team.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 1
Community Beginner ,
Jun 10, 2020

Copy link to clipboard

Copied

Hi Harshika,

 

I've tried it with the downloadable assets unchecked and it has successfully uploaded the changes to the link. It jumped to 50% immediately and then took another 10-15 or so to get to 100 (which is pretty typical of that file.)  

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Adobe Employee ,
Jun 10, 2020

Copy link to clipboard

Copied

Thank you for the confirmation that the link got updated after trying the suggested step, Cholek. I would like to know the size of your file. I believe it takes longer time to update if it's a large file with large assets and components.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Community Beginner ,
Jun 10, 2020

Copy link to clipboard

Copied

it's currently 36.6 MB (though it takes as long to upload as a previous version which was 55 MB and I'd been hoping that having cut down the amount of stuff in it would have made it a little more nimble.) 

 

Thanks,

 Chloe

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 10, 2020 0
Explorer ,
Jun 18, 2020

Copy link to clipboard

Copied

Hi again guys!
HARSHIKA, I'm really sad to say that we have this problem's now also on the links that have the download assets deactivated and even in the normal prototype link.

I'll send you a pm with an example file with which is not possible to update any link, as it says directly that you have an internet connection error, or randomly it just freezes at 0% or at 50%.

 

This error has already made us lose a full week of development on our side, and I'm just over the top with frustration.

Writing you is just my last hope before trying another way to communicate this project with my team.

 

I hope you can help.

thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
Explorer ,
Jun 18, 2020

Copy link to clipboard

Copied

Because of our tests with my team here, we are kinda sure it has something to do with the components, and components that contain components inside of them, For some reason this makes Xd fail.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 18, 2020 0
Adobe Employee ,
Jun 28, 2020

Copy link to clipboard

Copied

Hi Zigmas,

 

Sorry for the delay in response. I have logged a bug for your issue and the team is working on it. I will update you as soon as I hear back from the team.

 

We really appreciate your patience.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 28, 2020 1
Explorer ,
Jun 30, 2020

Copy link to clipboard

Copied

Hi Harshika!
Thanks for the update. I'll be waiting for that bug fix then. 🙂 |

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 30, 2020 0
Participant ,
Jul 07, 2020

Copy link to clipboard

Copied

I am having the same problem on a Mac with a small file with only vector assets. I chose 'developer' as the type of link and it hangs on 0% for like 3 minutes on every single update link. ALL my other XD files do not have this issue that are set to Design Review Mode. This is a new file I made as a simple handoff for a popup layout with Developer Mode and Download Assets enabled. My ISP is gigabit up and down.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 07, 2020 1
Explorer ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi Harshika!
Do we have any news about the bug?
I've had the same problem in  3 new different projects... We are not able to fully work with XD, and because of his randomness, we are not able to avoid it even when continuously checking that the new dev links don't break at upload.

Apart from the first 0% problem, we are also more and more experiencing the "you are disconnected error" on the updating of the dev link. it seems that with the last updated something changed that make that worse.

 

I hope you can shed some light on these issues!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0
Adobe Employee ,
Jul 17, 2020

Copy link to clipboard

Copied

Hi Zigmas,

 

I can understand that it's very frustrating for you. I have checked with the team and they are still working on it. I will update you as soon as I hear back from them.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 17, 2020 1