Highlighted

XD Design Specs do not show all the artboards

New Here ,
Feb 14, 2018

Copy link to clipboard

Copied

Hey Guys,

I have a very weird problem and begging you for help -

1. I have all artboards linked to the home page, yet some of them are still missing when I put it into design specs

2. If I create a new document and just copy and paste all the artboards and put them on the design specs - they all appear and works brilliant

3. However, if I implement point 2, all my prototype connections and hotspots disappear, because they are not transfered during a simple copy/paste. So I have all my artboards which I can inspect in design specs environment, but I lose the prototype.

Can you help me understand why this happens? Is there some finite amount of hotspots that you can put and if you reach a limit, the other artboards won't appear anymore? My prototype is quite heavy - consisting around 200 artborads, but only 190 are being shown if I upload the original file with the prototype links...

If the file is corrupt in any way, is there then a chance to somehow transfer prototype links together using copy/paste in the new document? Because only thinking about tryin to relink 200 artboards once again gives me nightmares.

Similar to shared prototypes, Design Specs share flows – everything connected to your home artboard.

Note that if you copy and paste from Prototype mode, all your hotspots and wires will be maintained, so you’ll hit the same issue.

Hope that helps clarify things!

-Elaine

Views

3.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

XD Design Specs do not show all the artboards

New Here ,
Feb 14, 2018

Copy link to clipboard

Copied

Hey Guys,

I have a very weird problem and begging you for help -

1. I have all artboards linked to the home page, yet some of them are still missing when I put it into design specs

2. If I create a new document and just copy and paste all the artboards and put them on the design specs - they all appear and works brilliant

3. However, if I implement point 2, all my prototype connections and hotspots disappear, because they are not transfered during a simple copy/paste. So I have all my artboards which I can inspect in design specs environment, but I lose the prototype.

Can you help me understand why this happens? Is there some finite amount of hotspots that you can put and if you reach a limit, the other artboards won't appear anymore? My prototype is quite heavy - consisting around 200 artborads, but only 190 are being shown if I upload the original file with the prototype links...

If the file is corrupt in any way, is there then a chance to somehow transfer prototype links together using copy/paste in the new document? Because only thinking about tryin to relink 200 artboards once again gives me nightmares.

Similar to shared prototypes, Design Specs share flows – everything connected to your home artboard.

Note that if you copy and paste from Prototype mode, all your hotspots and wires will be maintained, so you’ll hit the same issue.

Hope that helps clarify things!

-Elaine

Views

3.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Feb 14, 2018

Copy link to clipboard

Copied

Similar to shared prototypes, Design Specs share flows – everything connected to your home artboard.

Note that if you copy and paste from Prototype mode, all your hotspots and wires will be maintained, so you’ll hit the same issue.

Hope that helps clarify things!

-Elaine

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 15, 2019

Copy link to clipboard

Copied

Hi Elaine,

How would you go about nominating/changing the home artboard? It seems to be randomly assigned, and not displayed anywhere. For example:

  • It's not necessarily based on being the artboard with the lowest coordinates.
  • It's not based on the ordering of the artboards list (which might've made the most sense)
  • It's not based on being the first created artboard.

Thanks,

Simon

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jan 15, 2019

Copy link to clipboard

Copied

In prototype mode, you can select the little gray tab next to the artboard title. When you click on it, it'll turn blue to denote that it's the home artboard.

customer-hometab.gif

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 16, 2018

Copy link to clipboard

Copied

I am facing the similar issue, Every time I had to add new artboard i have to use a different dcument

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Oct 24, 2019

Copy link to clipboard

Copied

This is particularly annoying. Let's figure out this use case :

  • You design a prototype to illustrate a usage scenario
  • But you can also add other screens, not directly connected to the prototype, for example to illustrate the responsiveness of the design, which doesn't impact the user flow (so the prototype)

In such a case, "share for development is pretty useless if all artboards are not available to the developers.

 

Please, escalate the problem. We can't imagine to connect everything to the home screen, no sense.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Oct 24, 2019

Copy link to clipboard

Copied

Hi there, 

 

Please refer to my response to your query on this thread here: https://community.adobe.com/t5/Adobe-XD/All-artboards-dont-get-exported-for-development/m-p/10691405... .

 

Hope it helps.

 

Thanks,

Harshika

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Oct 24, 2019

Copy link to clipboard

Copied

   Thanks, but unfortunately, it doesn't. 😞

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
sokilavc LATEST
New Here ,
Dec 17, 2019

Copy link to clipboard

Copied

yeah, @elainecc is right,

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...