終了

書き出しした動画の映像がプレビューと異なる。(エラー、画像の乱れ)

Community Beginner ,
Mar 14, 2024 Mar 14, 2024

リンクをクリップボードにコピー

コピー完了

After effects を初めて導入し、動作確認でエンコードを行ったところ、プレビュー画面では正常だったのに、出力された動画の映像が違うという状況です。

 

具体的には、

環境はWindowsのデスクトップパソコンで 性能はCore(TM) i7-11700 メモリ16GB、GPUはGeForceGTX1650です。

動画内容はボカロMVを作成するため、音源、PNGのイラスト(背景を透過したキャラクター)、背景(単色の平面)、テキストを簡易的に配置したものです。(動画時間30秒)

media encorderで書き出すと、音声は正常ですが、画像がおかしいです(添付画像)。PNGイラストを画面から少しはみ出るように配置しているのですが、上側にはみ出た部分が表示され、境目が下に延ばされたような画像が出力されて動きません。

はみ出る部分にモーションをつけて書き出すと、途中までは動いて止まって静止画になります。

mediaencoderを使わずレンダーキューから出力すると背景色のみの状態で出力されます。

プロジェクト設定でソフトウェア処理を選択しても解決しませんでした。キャッシュの消去も効果ありません。

 

同じプロジェクト内で別のコンポジションを作成し、同じような内容でmediaencoderで書き出すと、真っ黒な画面の動画になります。PNGイラストなしで書き出すとなぜかエラーになり動画は再生できません。

 

別のプロジェクトで背景色とテキストのみの動画をmediaencoderで書き出すとエラー、PNGイラストを配置したら出力はされるが真っ黒となりました。

レンダーキューで書き出したら、1回目は背景色のみ2秒(本来は背景とテキストとイラストで30秒)、2回目イラストなしで書き出したらエラー、3回目イラストをまた配置して書き出したらエラー。

 

ソフト、PCの再起動をしても状況は変わりません。PCの負荷は、書き出し時にCPU50%メモリ70%まで上昇します。

 

ここまでH.264で書き出していたのですがMPEG4にして書き出したら初めてイラストやテキストが正常に出力されました。しかし画質がものすごく荒くなりました。H.264が原因かもしれないですが、他に代用できる形式はあるのでしょうか。品質を落とさず出力したいです。

 

ご意見、ご助力いただけるとありがたいです。

キーワード
エラーまたは問題 , 読み込みと書き出し

表示

129

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines

correct answers 1 件の正解

Community Beginner , Mar 14, 2024 Mar 14, 2024

ご意見ありがとうございます。ヘルプセンターに問い合わせたところNVIDIAのバージョンをダウングレードすることを提案され、studioドライバー551.61からGameReadyドライバー551.23に変更したところ問題が解決しました。(After effects のバージョンは24.21です)

投票

翻訳

翻訳
Community Expert ,
Mar 14, 2024 Mar 14, 2024

リンクをクリップボードにコピー

コピー完了

先月、NVIDIAからGTX1650など向けに、『「NVENC」使用時にエラーが発生したり、映像が破損する』という症状に対する修正版のドライバが出たというニュースを目にしました。

 

念のため、NVIDIAのドライバのバージョンをご確認(必要に応じて更新して)いただいたり、原因の切り分けのためMedia Encoderでの書き出し時にエンコード設定のパフォーマンスを「ソフトウェアエンコーディング」(レンダラーの「ソフトウエア処理」とは異なる部分の設定です)でお試しいただくといかがでしょうか。

投票

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Community Beginner ,
Mar 14, 2024 Mar 14, 2024

リンクをクリップボードにコピー

コピー完了

ご意見ありがとうございます。ヘルプセンターに問い合わせたところNVIDIAのバージョンをダウングレードすることを提案され、studioドライバー551.61からGameReadyドライバー551.23に変更したところ問題が解決しました。

投票

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Community Expert ,
Mar 14, 2024 Mar 14, 2024

リンクをクリップボードにコピー

コピー完了

After Effects のバージョンもお知らせください。

 

H.264のレンダリングは、GPUでエンコードすることがあるので、最新のGPUドライバーをインストールしてみてはどうでしょう。
ドライバーは、Studioドライバーを選択してクリーンインストールして下さい。

投票

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Community Beginner ,
Mar 14, 2024 Mar 14, 2024

リンクをクリップボードにコピー

コピー完了

最新

ご意見ありがとうございます。ヘルプセンターに問い合わせたところNVIDIAのバージョンをダウングレードすることを提案され、studioドライバー551.61からGameReadyドライバー551.23に変更したところ問題が解決しました。(After effects のバージョンは24.21です)

投票

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines