• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

issues with ME rendering Adobe After Effects (Beta) files that include 3d objects

New Here ,
Apr 18, 2023 Apr 18, 2023

Copy link to clipboard

Copied

Hi @Christine Goldby, thanks for all of your work here on the support community site. I've been testing the new After Effects 3d features this week for use on our web-video project. The project requires 3d artwork to be rendered out in .webm format with transparency support.

 

It seems the only way to get .webm output out of Adobe products is using an external plugin from www.fnordware.com

This enables the Media Encoder (Beta) to output in .webm format w/ transparency, but I have run into some issues with ME rendering Adobe After Effects (Beta) files that include 3d objects.

- Compositions including an .obj file are able to be rendered out, but the renderer ignores the 3d layers in the composition.
- Compositions including a .glb file are not even recognised by the Media Encoder, you receive a "Could not locate file" error. Both of these errors occur while using the Mercury rendering engine.

 

For now I've found a workaround by outputting a Quicktime .MOV from After Effects (Beta), with transparency, and then running this outputted file through the Media Encoder (Beta) into a .webm file with transparency. That said, it would be great to see the Media Encoder have 3d support, and also for After Effects to have native .webm support as it is a very popular format in the space!

 

Thanks a lot,

Kyle

Bug Investigating

Views

235

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Pinned Reply

Adobe Employee , Apr 24, 2023 Apr 24, 2023

Hi @Tetranome,

 

Thanks for taking the time to post. Note that while Christine is still with us at Adobe, she has moved on to other projects. Don't worry, the rest of the team is still paying attention to these posts!

 

Regarding support for exporting to WebM format, the correct place to request that is on the Adobe Media Encoder Ideas page. There may already be a suggestion there that you can upvote or comment on.

 

Regarding exporting an After Effects Beta comp with 3D models imported, I am on

...
Status Investigating

Votes

Translate

Translate
1 Comment
Adobe Employee ,
Apr 24, 2023 Apr 24, 2023

Copy link to clipboard

Copied

LATEST

Hi @Tetranome,

 

Thanks for taking the time to post. Note that while Christine is still with us at Adobe, she has moved on to other projects. Don't worry, the rest of the team is still paying attention to these posts!

 

Regarding support for exporting to WebM format, the correct place to request that is on the Adobe Media Encoder Ideas page. There may already be a suggestion there that you can upvote or comment on.

 

Regarding exporting an After Effects Beta comp with 3D models imported, I am only able to partially reproduce the problems you are reporting.

 

Specifically, rendering a specific comp with a GLB file is failing to render the 3D model, instead replacing it with a placeholder element where the model should be. But even then, this only happens with one of the comps I tried; another GLB worked as expected. OBJ and GLTF render as expected in all cases I've tried.

 

What specific versions of After Effects Beta and Adobe Media Encoder Beta are you using? I'm using today's builds, AE Beta 23.5x12 and AME Beta 23.5x14. Are you on Mac or Windows?

 

Would you be able to share the project and 3D model files you are using? You can DM me a link if you don't want to share publicly.

Status Investigating

Votes

Translate

Translate

Report

Report
Resources