Multi-Frame Rendering is here! (AKA The multithreading you’ve been asking for)

Adobe Employee ,
Mar 10, 2021 Mar 10, 2021

Copy link to clipboard

Copied

Multi-frame Rendering is here for After Effects beta users. Right now, you will have access to Multi-Frame Rendering for export only. Keep your eye on this forum, as we will be rolling out new features until we launch.

 

Internally, we have been testing a representative sample of projects with a suite of hardware configurations, and we are excited to finally put this feature in your hands and get your feedback. Test your unique projects on your own hardware so we can ensure that our performance updates benefit all of our customers and meet speed and quality metrics before we launch.

 

Beta testing of Multi-Frame Rendering will last a little longer than some of our other features because we currently do not support Multi-Frame Rendering in Preview, Motion Graphics templates, Dynamic Link, Adobe Media Encoder and AERender Command Line Interface.

 

Check out the blog and FAQ post to learn the following:

  • What is Multi-Frame Rendering?
  • What factors influence performance?
  • Which effects have been optimized for Multi-Frame Rendering?

 

Start Testing!
We want to hear from you! Share your thoughts and ideas in this forum.

  • How much faster is Multi-Frame Rendering compared to Single-Frame Rendering with your comps on your machine?
  • Does our benchmark project perform at the expected speed on your system?
  • If you run into specific speed or quality issues with your project, share your project with us at mfrbeta@adobe.com.

 

Test Your Comps
Test your comps in Multi-Frame Render mode vs. Single-Frame Render

  • Use Ae Render Queue to export your comp in Multi-Frame mode.
  • Purge both the disk and memory cache, then
  • Use Ae Render Queue to export your project in Single-Frame mode. Note: Use the same output module for Single-Frame and Multi-Frame mode. Go to Preferences -> Memory and Performance -> Enable Multi-Frame Rendering (beta) and uncheck the box to use Single-Frame Rendering Mode

 

Leave a comment and the following information in this forum:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed (Use “Render Time” noted in your status bar)
  • Multi-Frame render speed

 

If you detect any problems with render speed or quality, submit your projects

  • Open your After Effects project
  • File -> Dependencies -> Collect Files -> Collect -> Save As (Name Your Folder)
  • After Effects will store your .aep file, footage, and text report (file log)
  • Zip up your project and send it to us at mfrbeta@adobe.com (or send a link to it hosted on your creative cloud storage if it’s too large to email).

 

Share the following information in your comment:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed (Use “Render Time” noted in your status bar)
  • Multi-Frame render speed
  • Mercury CPU or GPU Mode used

 

Test our benchmark project and see how your hardware compares
We would love to know how your hardware compares to the results we have gathered from our test suite:

Benchmark Render Speed Improvements.png

 

To test the benchmark project on your machine:

  • Download the benchmark project
  • Use Ae Render Queue to export the benchmark project in Multi-Frame mode.
  • Purge both the disk and memory cache, then
  • Go to Preferences -> Memory and Performance -> Enable Multi-Frame Rendering (beta) and uncheck the box to use Single-Frame Rendering Mode
  • Use Ae Render Queue to export the benchmark project in Single-Frame mode. Note: Use the same output module for Single-Frame and Multi-Frame mode.

 

Share the following information in this forum:

  • Your hardware specs: # cores in your CPU, GB of memory, GPU model and amount of VRAM
  • Single-Frame render speed
  • Multi-Frame render speed
TOPICS
Performance

Views

39.9K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
replies 364 Replies 364
Community Beginner ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

Results:

CUDA ON: MFR OFF // 11:36
CUDA ON: MFR ON // 3:06

That's a 3.74x increase in performance and it's very noticible

 

AMD Ryzen Threadripper PRO 3975WX 32-Cores 3.50 GHz
256 GB DDR4 RAM


GPU 1: NVIDIA GeForce RTX 3090
Driver version: 30.0.14.7111
Driver date: 6/21/2021
DirectX version: 12 (FL 12.1)
Dedicated GPU memory 13.2/24.0 GB
Shared GPU memory 2/128 GB
GPU Memory 15/152 GB


GPU 2: NVIDIA GeForce RTX 3090
Driver version: 30.0.14.7111
Driver date: 6/21/2021
DirectX version: 12 (FL 12.1)
Dedicated GPU memory 13.7/24.0 GB
Shared GPU memory 2/128 GB
GPU Memory 15/152 GB

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 01, 2021 Nov 01, 2021

Copy link to clipboard

Copied

Thanks for the update. I tested this new update with my work project, MFR makes render queue renders a lot faster but somehow it makes my preview slower. 

When MFR is disabled, the section I preview runs in realtime 24fps on third resolution but when MFR is enabled I can't get it to go past 18fps no matter how low I set the preview resolution!

 

My rig is kinda ancient by I'm not sure if the rig is the problem here 

i7 4790 / 16 GB DDR3 1600 CL9 / RX580 

I tried switching to mercury software only and OpenCL but it makes no differnce. I tried changing the MFR percentage to either higher than default 10% or even 0, but the problem presists 

 

I'm on the latest build of Win11 

 

Please HELP 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

I've found similar issues, on a reasonably high end 6-month old AMD 5950X/GTX3090/128GB RAM system, so it's probably not your "kinda ancient" rig's fault. Do you find if you quit/restart AE, the previews run perfectly for a while, then everything begins to slow down? I deleted my prefs, and things seem to be OK - for now at least, so maybe you could try that for a start?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Hi thanks for your reply. I even deleted all of my preferences, all third party plugins and re-installed AE and tried restarting the program and my rig several times, the problem presists, maybe once or twice it was blistering fast after purging cache and memory but after a pause/playback it went back to being slower than single frame rendering.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Thanks for the reports. We are going to need to gather some more data from y'all to better understand things and what you're seeing. Can you please Enable Logging (from the Help menu), reproduce the issue, shut down AE, start AE and choose Reveal Logging Files. A folder with After Effects Log and After Effects Log Last will appear. Grab those files and send them to mfrbeta@adobe.com so we can take a look at what may be happening. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

Will do. Thank you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 29, 2021 Nov 29, 2021

Copy link to clipboard

Copied

Will not render multi-proc with latest sapphire. Will crash system. 2x 3090, threadripper 3970x 32 core, 256 Gb ram. gpu sapphire disabled. Historically, the multi proc render has been pretty unstable and generally useless. Thanks for keeping with the traditions! At least I can disable "crashnow" 

 

oof

 

jjjj

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 07, 2021 Dec 07, 2021

Copy link to clipboard

Copied

Not sure what's wrong, need help. I cannot get though a single render with any settings, keeps running out of memory.

My PC specs: 

nvidia 3080 rtx - 10 gb vram

cpu intel 19-9900

32 gb ram

windows 10 64 bit

I have tried Mercury only, GPU accelerated, single and multi-frame. nothing gets past halfway before it runs out of memory. Others here have rendered on lesser specs, i dont understand...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Hello.

Thanks for reporting this issue. We are currently working on making some memory related improvements that will resolve several memory issues. 

Please stay tuned.

Thanks,

After Effects QE.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

I'm having a hell of a time with After Effects saying that it's out of memory when rendering. Been trying the Beta and 2022  can someone look at this log file and give me some help please🙏

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Tried importing the project into a new one at 8bpc and it works fine. But once I change to 16bpc, my Working space to 709 and linearised, it beach balls.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

OK, I've now Created a new project 16bpc, 709 linear. Imported the footage, redone the comps from sgratch and it all works fine. Renders super quick. How do I repair an After Effects file? As it seems like there's an issue with my working project.🤦‍:male_sign:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 06, 2022 Jan 06, 2022

Copy link to clipboard

Copied

Hi iestynx,

 

Thank you for posting about your project rendering issues. This must be frustrating. You can reduce the amount of memory After Effets uses with Preferences -> Memory & Performance. After Effects has an issue where it is not strictly obeying the limit set there, however reducing the amount of RAM available to AE will still reduce memory usage. As Joy indicates, above, we're working on a fix for this.

 

Thanks again,

Jason

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 17, 2022 Jan 17, 2022

Copy link to clipboard

Copied

Hi, thanks for letting me know. We really need to render this project out. We've had to move the online twice now because of After Effects issues. I gererated a log file where all I did was open AE then hit render, it rendered 144 frames then froze. Hope this log file helps.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 18, 2022 Jan 18, 2022

Copy link to clipboard

Copied

LATEST

I've managed to render TIFF sequences out now, doing around 3seconds each time, it's taken most of yesterday and all of today for me to get it out.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources