NaN pixels in 32 bit projects with Lumetri and more

New Here ,
Oct 06, 2021 Oct 06, 2021

Copy link to clipboard

Copied

I have a few issues with NaN pixels in 32 bit projects.  These problems are still in the latest Beta, but are the same for earlier public releases too.  It does look like the problem is different when using the software renderer (worse) than the Mercury GPU accellerated renderer.

 

I have a project that I have zipped up ready to share, but I don't seem to be able to upload a .zip  Contact me to send you the file, it's less than 5 meg in size.

 

Basically: The combination of the advanced spill supressor and lumetri plugins produces rogue pixels that are way out of range.  These pixels then cause more artefacts / corruption when other effects such as blur & sharpen are used.

There's a freely available "NaNny" plugin that exists to fix NaNs.  Oddly, this plugin doesn't seem to work when applied to an adjustment layer.  However it does work when applied in an effects stack.

Adding a non-32bit plugin to the original layer also fixes the issue.

 

NaNs and other rogue pixels are a HUGE PAIN.  There should be a built-in filter to fix these issues so we don't have to rely on a 3rd party plugin.  Anyone dealing with rogue pixels for the first time won't know what the problem is, it's extremely upsetting to see the types of screen corruption and problems they can cause without knowing why.  NaNs should not be a problem for AE users and all plugins should have some sort of native filtering to fix them.

TOPICS
Bug , Error

Views

150

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2021 Oct 06, 2021

Copy link to clipboard

Copied

I've collected and uploaded a project that demonstrates the issue:

https://drive.google.com/file/d/1LzT-UN6D7n_njZkvRAcdqyC9tvTgSu-b/view?usp=sharing

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 08, 2021 Oct 08, 2021

Copy link to clipboard

Copied

LATEST

Thanks Chris - I've got the bug ready for a team to look at next week. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources