After Effects Crashing (Zanzibar-2) when writing Expressions on Source Text in MacOS

New Here ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Hello everybody! 

 

I have noticed, that in After Effects 17.2 and later, the program is very often crashing when writing an expression in the "Source Text" property. Usually, while working on it, it works fine, and nothing happens. The crashing starts when I want to re-open the project after closing it (Zanzibar-2 Error). I have tested it on many projects, 2 machines, and with all the versions of AE 17.2+. The crashing always happens. I need to open the project with AE 17.1 and untick all Source text expressions to be able to open it again in later versions.

 

I have tested it on macOS Catalina and macOS Big Sur. I believe the problem is very critical because I am practically unable to write expressions for the Source Text.

 

Does anybody know how to solve this issue?

TOPICS
Crash

Views

306

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 30, 2020 Nov 30, 2020

Copy link to clipboard

Copied

Hi Klemen,

Thank you for reporting this issue, sorry to see you're experiencing these crashes. Would you mind providing some additional information that would help us to narrow down the cause?

  1. After Effects versions moved to 17.5.0 after 17.1.4, are you experiencing this issue in 17.5.1 ( the current release version ) or in 17.6 ( the current Beta version )? The version is visible in the About box or on the splash screen of the Beta version.
  2. What language is After Effects running in and what language is the operating system running in?
  3. Is the crash caused by opening a project with any expression in a Source Property or only with a specific expression?
  4. Has the Crash Reporter dialog been shown after the crashes occur, and if so, have you submitted the crash reports with your email attached?

 

It would be very helpful if you could capture and send us an application log using the following steps:

  • In the Help menu, select "Enable Logging" and restart After Effects.
  • Then open a project which causes the crash.
  • After the crash occurs, go to: Users/yourUserName/Library/Preferences/Adobe/After Effects (Beta)/17.6/logs. The "After Effects (Beta)" and "17.6" correspond to the version of After Effects used.
  • There should be an "After Effects (Beta) Log.txt" in the logs folder, please either post a link here or email it to aebugs@adobe.com with link to this forum post in your message.

 

Thank you again for reporting this bug, looking forward to your response.

- John, After Effects Engineering Team

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 02, 2020 Dec 02, 2020

Copy link to clipboard

Copied

Hello John!

 

Thank you so much for your reply. I really appreciate the concern and fast reply. 

 

1. Yes, I am experiencing this issue in both versions,

2. My computer region is set to Portugal, but my system language is English. Also, my computer language is set to English. 

3. Sometimes, it randomly works, but most of the time, it doesn't. That happens with any expression. 

4. Yes, I have reported the crash many times. Also, I have contacted Adobe support, but they have told me that is a common issue with the macOS, and that for now, my only option is using 17.1 (which sadly I cannot since my project demands using the new stroke tapper).

 

After listening to the podcast with the amazing Victoria Nece, I guessed contacting the Adobe AE Support community could solve the issue faster. I believe it is not affecting just me, since I have tried it on 2 different machines. Theoretically, on three, I have formatted and freshly installed all the operating system and software on one, trying to solve the issue. Hope that with reporting it, will also help others that face the same issue. 

 

I will generate and send the report soon.

 

Thank you again for all your support,

Klemen

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

Hi again Klemen,

I was able to track down your crash reports ( thank you for submitting those! ) and the issue you are experiencing is one which is known to our type team and related to Unicode characters. Our type team's investigation into this crash is ongoing and filed internally as DVAAE-4215534.

 

Unfortunately I don't have a workaround to suggest at the moment other than continuing to use a previous version as you are already doing. As a fix becomes available in the Beta builds, I will post here to let you ( and @saariko below ) know so you can try it out.

 

My apologies for the inconvience this bug has caused, hopefully I can inform you of a fix soon.

- John, After Effects Engineering Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

Could you post a link of said podcast? Curious to hear from her.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

LATEST

@www.klemen.me @saariko @NielHeesakkers  @SoGood Istanbul 

Please give the latest available After Effects (Beta) a try. The Beta has a potential fix for this issue and your testing/input would be greatly appreciated. If the crash is still occurring for you, please let us know in this thread as soon as possible.

 

Thanks again,

- John, After Effects Engineering Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

Same issues here, multiple macs, both Catalina and Big Sur, crashing only for projects with source-text expressions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

Hi saariko,

Thank you for reporting this issue, sorry to see you're experiencing this as well. Please see my post to Klemen above for more details; this is a known issue and our type team is working on getting it fixed as soon as they can. The current workaround is to use a previous version ( I believe 17.1 ) to avoid the issue.

 

Thanks again for reporting and for using the Beta,

- John, After Effects Engineering Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 08, 2021 Jan 08, 2021

Copy link to clipboard

Copied

Hi John

 

Any word on a solution? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 18, 2021 Feb 18, 2021

Copy link to clipboard

Copied

Hello John, this issue has become a really tough trouble for us. Are the team still working on it? Are there any improvement or any guesses? Actually i can not use an older version of AE, just because Big Sur doesn't support any more. And unfortunately i started to use Big Sur once. I'm just starting to think that Adobe is not take this problem as serious enough. Please respond us asap.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines