Fast Draft not working

Community Beginner ,
Oct 17, 2020 Oct 17, 2020

Copy link to clipboard

Copied

After enabling the new Fast Draft, I can't seem to make it work

Working with a decent GPU RTX 2080

TOPICS
Bug, Performance

Views

180

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 20, 2020 Oct 20, 2020

Copy link to clipboard

Copied

Hi @SternFX!
Can you please share your hardware specs? Specifically your OS + version and GPU + driver. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

Attached

------------------------------
Eran Stern
*Adobe Expert Trainer*
Motion Designer ☆ SternFX Ltd

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

Capture2.JPGCapture.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

FWIW, I just updated the GeForce driver to 456.71 and still it doesn't work - I see black screen this time

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

I just tried the feature and have a similar result with an imported EXR file.
Mac OS 1015.7 | AE 17.5.1.33
MacBook Pro (15 Inch, 2018) | 2,9 GHz Intel Core i9 | 32 GB 2400 MHz DDR4 | Radeon Pro 560X 4096 MB | Intel UHD Graphics 630 1536 MB

Fast Preview.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

@Rene Andritsch - Your case is different from all of the other reports we've been hearing, which have all been on Windows 10 with Nvidia GPU's. Your Mac AMD case is different. Do you get the same result with a simple 3D comp of shape layers, instead of the EXR files?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

Good news, @SternFX! Our developers investigated this yesterday and we believe we have a fix. It will be available in build 34 of After Effects Beta (17.5.1.34) or later, which should be coming in the next day or two. Please install the new build when it's available, test Fast Draft again, and let us know if the fix worked.

Under the hood: the Fast Draft 3D engine was expecting a specific DirectX DLL file to be present on the system. This DLL is, apparently, very common but not universal to all Windows Nvidia installs. This DLL is not actually necessary for the Fast Draft 3D engine to run, it's only useful for debugging, so we've simply disabled the requirement for this DLL.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

@SternFX and @Rene Andritsch - What color depth is your project set to? If not 8-bpc, please change it to 8-bpc.

In further discussion with one of our developers, he let me know that at 16- and 32-bpc, artifacting/garbage like the screenshots you've both posted is possible. We're still working on solving this; it won't be fixed in the Beta in the near future. Until then, please work in 8-bpc with the Fast Draft renderer.

 

@SternFX , this is probably the actual cause of your problem. Your system specs overlapped with the other problem we were investigating on Windows Nvidia configurations. In those cases, the Fast Draft 3D engine draws nothing, i.e. black. That doesn't seem to be the case for you but we got your case confused with the Nvidia/DirectX issue.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

I'm working at 8-bpc, I still see these wierd arteffects.

Will wait for the next build and check it then

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

@Tim Kurkoski when lowering to 8-bpc the artifacts with the EXR are gone. Regarding your other question, having a simple composition with a 3D shape layer there are no artifacts no matter what the bpc-setting is. BUT if I add just a simple 2D Shape Layer there is a problem with the screen rendering again (in 16-bpc and 32-bpc). As soon as I switch the layer to 3D the “artifacting” (in this case invisibility) is gone. As the placed EXR (PNG sequence) was a 2D layer as well this might be related it). Please see attached screen capture.

fastdraft-bpc.gif 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

Thanks for the screen capture, @Rene Andritsch. I think this still falls into the category of "Fast Draft 3D doesn't work quite right in 16- or 32-bpc yet." In this case it looks to me like the texture for the 2D layer isn't getting loaded properly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 23, 2020 Oct 23, 2020

Copy link to clipboard

Copied

Happy to report that it's working now after the last beat update 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 23, 2020 Oct 23, 2020

Copy link to clipboard

Copied

LATEST

Great! Thanks for the update, @SternFX .

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines